summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-01-18 10:51:02 +0000
committerAlex Legler <a3li@gentoo.org>2009-01-18 10:51:02 +0000
commit0e4903de5d6987e7d90261ae0e849f630ff89db9 (patch)
tree6e9b91142782bc33198a033560061a4a88b5186f /app-misc/alexandria
parentVersion bump (diff)
downloadgentoo-2-0e4903de5d6987e7d90261ae0e849f630ff89db9.tar.gz
gentoo-2-0e4903de5d6987e7d90261ae0e849f630ff89db9.tar.bz2
gentoo-2-0e4903de5d6987e7d90261ae0e849f630ff89db9.zip
Revbump to fix bug 254601, thanks to John Keeping for the patch.
(Portage version: 2.2_rc22/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'app-misc/alexandria')
-rw-r--r--app-misc/alexandria/ChangeLog11
-rw-r--r--app-misc/alexandria/alexandria-0.6.3-r1.ebuild77
-rw-r--r--app-misc/alexandria/files/alexandria-0.6.3-tooltips.patch90
3 files changed, 176 insertions, 2 deletions
diff --git a/app-misc/alexandria/ChangeLog b/app-misc/alexandria/ChangeLog
index 05b7700b6ffc..c91bf239e098 100644
--- a/app-misc/alexandria/ChangeLog
+++ b/app-misc/alexandria/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/alexandria
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.23 2008/04/23 18:20:26 graaff Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.24 2009/01/18 10:51:02 a3li Exp $
+
+*alexandria-0.6.3-r1 (18 Jan 2009)
+
+ 18 Jan 2009; Alex Legler <a3li@gentoo.org>
+ +files/alexandria-0.6.3-tooltips.patch, +alexandria-0.6.3-r1.ebuild:
+ Fixing tooltip crash reported in bug 254601. Patch provided by John
+ Keeping. PATCHES now is a bash array.
*alexandria-0.6.3 (23 Apr 2008)
diff --git a/app-misc/alexandria/alexandria-0.6.3-r1.ebuild b/app-misc/alexandria/alexandria-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..db88e0bf221e
--- /dev/null
+++ b/app-misc/alexandria/alexandria-0.6.3-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/alexandria-0.6.3-r1.ebuild,v 1.1 2009/01/18 10:51:02 a3li Exp $
+
+inherit gnome2 ruby
+
+IUSE="evo"
+
+DESCRIPTION="A GNOME application to help you manage your book collection"
+HOMEPAGE="http://alexandria.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS="COPYING ChangeLog README TODO"
+
+RDEPEND=">=dev-lang/ruby-1.8.0
+ >=dev-ruby/ruby-gettext-0.6.1
+ >=dev-ruby/ruby-gnome2-0.16.0
+ >=dev-ruby/ruby-libglade2-0.12.0
+ >=dev-ruby/ruby-gconf2-0.12.0
+ >=dev-ruby/imagesize-0.1.1
+ evo? ( >=dev-ruby/revolution-0.5 )"
+
+DEPEND=">=dev-lang/ruby-1.8.0
+ app-text/scrollkeeper
+ dev-ruby/rake"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-rakefile.patch"
+ "${FILESDIR}/${P}-no_amazon_3.0.diff"
+ "${FILESDIR}/${P}-tooltips.patch"
+)
+
+src_compile() {
+ rake || die
+}
+
+src_install() {
+ export PREFIX="${D}/usr"
+ rake install || die
+
+ [ -n "${DOCS}" ] && dodoc ${DOCS}
+
+ # Move the installed docs to the gentoo standard directory
+ for doc in "${D}/usr/share/doc/alexandria/*"
+ do
+ dodoc $doc
+ done
+ rm -rf "${D}/usr/share/doc/alexandria"
+}
+
+pkg_postinst() {
+ unset PREFIX
+
+ gnome2_gconf_install
+
+ # For the next line see bug #76726
+ "${ROOT}/usr/bin/gconftool-2" --shutdown
+
+ echo
+ elog "To enable some book providers you will need to emerge"
+ elog "additional packages:"
+ echo
+ elog " For the Deastore book provider:"
+ elog " dev-ruby/mechanize"
+ echo
+ elog " For Z39.50 support and the Library of Congress and"
+ elog " British Library book proviers:"
+ elog " dev-ruby/ruby-zoom"
+ echo
+ elog " For the Amazon book provider:"
+ elog " dev-ruby/hpricot"
+ echo
+}
diff --git a/app-misc/alexandria/files/alexandria-0.6.3-tooltips.patch b/app-misc/alexandria/files/alexandria-0.6.3-tooltips.patch
new file mode 100644
index 000000000000..5ff60c4211eb
--- /dev/null
+++ b/app-misc/alexandria/files/alexandria-0.6.3-tooltips.patch
@@ -0,0 +1,90 @@
+Changes backported from upstream SVN for bug 254601.
+Fixes a crash when displaying a tooltip for a book without publisher.
+
+--- lib/alexandria/ui/iconview_tooltips.rb 2008-11-25 12:31:05.000000000 +0000
++++ lib/alexandria/ui/iconview_tooltips.rb 2009-01-11 20:44:51.000000000 +0000
+@@ -25,6 +25,8 @@
+ #
+ # Ported to ruby-gtk2 (and modified for IconView) by Cathal Mc Ginley
+
++require 'cgi'
++
+ class IconViewTooltips
+ def initialize(view)
+ @tooltip_window = Gtk::Window.new(Gtk::Window::POPUP)
+@@ -36,21 +38,21 @@
+ @tooltip_window.signal_connect('expose_event') { |window, event|
+ on_expose(window, event) }
+
+- @label = Gtk::Label.new('')
+- @label.wrap = true
+- @label.set_alignment(0.5, 0.5)
+- @label.use_markup = true
+- @label.show()
++ @label = Gtk::Label.new('')
++ @label.wrap = true
++ @label.set_alignment(0.5, 0.5)
++ @label.use_markup = true
++ @label.show()
+
+- @tooltip_window.add(@label)
+- set_view(view)
++ @tooltip_window.add(@label)
++ set_view(view)
+ end
+
+ def set_view(view)
+ view.signal_connect('motion_notify_event') { |view, event|
+ on_motion(view, event) }
+- view.signal_connect('leave_notify_event') { |view, event|
+- on_leave(view, event) }
++ view.signal_connect('leave_notify_event') { |view, event|
++ on_leave(view, event) }
+ end
+
+ def on_expose(window, event)
+@@ -71,30 +73,31 @@
+ # This is much too complex... but it works for now!
+ html = ""
+ if title.size > 0
+- html += "<b>#{title}</b>"
++ html += "<b>#{CGI.escapeHTML(title)}</b>"
+ if authors.size > 0
+ html += "\n"
+ end
+ end
+ if authors.size > 0
+- html += "<i>#{authors}</i>"
++ html += "<i>#{CGI.escapeHTML(authors)}</i>"
+ end
+ if (title.size > 0) or (authors.size > 0)
+ html += "\n"
+ end
+- if (publisher.size > 0) or (year.size > 0)
+- html += "<small>"
+- if publisher.size > 0
+- html += "#{publisher}"
+- end
+- if year.size > 0
+- if publisher.size > 0
+- html += " "
+- end
+- html += "(#{year})"
++
++ html += "<small>"
++ if publisher and publisher.size > 0
++ html += "#{CGI.escapeHTML(publisher)}"
++ end
++
++ if year and year.size > 0
++ if publisher and publisher.size > 0
++ html += " "
+ end
+- html += "</small>"
++ html += "(#{year})"
+ end
++
++ html += "</small>"
+ end
+
+ def on_motion(view, event)