summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-06-14 06:42:08 +0000
committerThomas Kahle <tomka@gentoo.org>2013-06-14 06:42:08 +0000
commitee854d02591fc39dae3e4605b85445579c790204 (patch)
tree30ebed9101d55be305c71506a1bc658776c6dbfb /app-misc/anki
parentunmask net-misc/hotot-0.9.8.14 (diff)
downloadgentoo-2-ee854d02591fc39dae3e4605b85445579c790204.tar.gz
gentoo-2-ee854d02591fc39dae3e4605b85445579c790204.tar.bz2
gentoo-2-ee854d02591fc39dae3e4605b85445579c790204.zip
bump to 2.0.11
(Portage version: 2.1.12.4/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'app-misc/anki')
-rw-r--r--app-misc/anki/ChangeLog7
-rw-r--r--app-misc/anki/anki-2.0.11.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/app-misc/anki/ChangeLog b/app-misc/anki/ChangeLog
index 28817de69668..6718e874acc3 100644
--- a/app-misc/anki/ChangeLog
+++ b/app-misc/anki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/anki
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.58 2013/06/12 14:45:08 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.59 2013/06/14 06:42:08 tomka Exp $
+
+*anki-2.0.11 (14 Jun 2013)
+
+ 14 Jun 2013; Thomas Kahle <tomka@gentoo.org> +anki-2.0.11.ebuild:
+ bump to 2.0.11
*anki-2.0.10 (12 Jun 2013)
diff --git a/app-misc/anki/anki-2.0.11.ebuild b/app-misc/anki/anki-2.0.11.ebuild
new file mode 100644
index 000000000000..f4e1c4ef11b2
--- /dev/null
+++ b/app-misc/anki/anki-2.0.11.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/anki-2.0.11.ebuild,v 1.1 2013/06/14 06:42:08 tomka Exp $
+
+EAPI=5
+
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="sqlite"
+
+inherit eutils python
+
+DESCRIPTION="A spaced-repetition memory training program (flash cards)"
+HOMEPAGE="http://ichi2.net/anki/"
+SRC_URI="http://ankisrs.net/download/mirror/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="latex +recording +sound"
+
+RDEPEND="dev-python/PyQt4[X,svg,webkit]
+ >=dev-python/httplib2-0.7.4
+ dev-python/beautifulsoup:python-2
+ recording? ( media-sound/lame
+ >=dev-python/pyaudio-0.2.4 )
+ sound? ( media-video/mplayer )
+ latex? ( app-text/texlive
+ app-text/dvipng )"
+DEPEND=""
+
+pkg_setup(){
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Need send2trash since its not yet available in Gentoo
+ cp -r thirdparty/send2trash .
+ rm -r thirdparty || die
+ python_convert_shebangs -r 2 .
+}
+
+# Nothing to configure or compile
+src_configure() {
+ true;
+}
+
+src_compile() {
+ true;
+}
+
+src_install() {
+ exeinto /usr/bin/
+ doexe anki/anki
+
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ doman ${PN}.1
+
+ dodoc README README.development
+ insinto "$(python_get_sitedir)"
+ doins -r aqt anki send2trash
+}
+
+pkg_preinst() {
+ if has_version "<app-misc/anki-2" ; then
+ elog "Anki 2 is a rewrite of Anki with many new features and"
+ elog "a new database format. On the first run your decks are"
+ elog "converted to the new format and a backup of your Anki-1"
+ elog "decks is created. Please read the following:"
+ elog "http://ankisrs.net/anki2.html"
+ fi
+}