summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-07-12 12:51:27 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-07-12 12:51:27 +0000
commita84da5d3aaece46fa1c38192fa93f7ac468efaa1 (patch)
tree5119a4ac36eb2f2229f001de02fcdad119c19421 /app-misc/byobu/byobu-2.19.ebuild
parentMigrate to EAPI 2. Fix compile errors (#277166) and QA notices. (diff)
downloadgentoo-2-a84da5d3aaece46fa1c38192fa93f7ac468efaa1.tar.gz
gentoo-2-a84da5d3aaece46fa1c38192fa93f7ac468efaa1.tar.bz2
gentoo-2-a84da5d3aaece46fa1c38192fa93f7ac468efaa1.zip
Version bump
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/byobu/byobu-2.19.ebuild')
-rw-r--r--app-misc/byobu/byobu-2.19.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/byobu/byobu-2.19.ebuild b/app-misc/byobu/byobu-2.19.ebuild
new file mode 100644
index 000000000000..c9914760af58
--- /dev/null
+++ b/app-misc/byobu/byobu-2.19.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/byobu-2.19.ebuild,v 1.1 2009/07/12 12:51:27 weaver Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A set of profiles for the GNU Screen console window manager (app-misc/screen)"
+HOMEPAGE="https://launchpad.net/byobu"
+SRC_URI="https://launchpad.net/ubuntu/karmic/+source/byobu/${PV}-0ubuntu1/+files/byobu_${PV}.orig.tar.gz
+ https://launchpad.net/ubuntu/karmic/+source/byobu/${PV}-0ubuntu1/+files/byobu_${PV}-0ubuntu1.diff.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/debhelper"
+RDEPEND="app-misc/screen
+ dev-libs/newt
+ >=dev-lang/python-2.5"
+
+S="${WORKDIR}/byobu_${PV}.orig"
+
+src_prepare() {
+ epatch "${WORKDIR}"/*.diff
+}
+
+src_install() {
+ ln -s "${D}" debian/byobu
+ ln -s "${D}" debian/byobu-extras
+ emake --makefile=debian/rules install || die
+ chmod +x "${D}/usr/bin/byobu-janitor"
+ rm -rf "${D}/debian"
+ doman *.1
+ dodoc doc/*
+}
+
+pkg_postinst() {
+ elog 'To access the functionality of this package, please run the command "byobu"'
+ elog 'in place of "screen".'
+}