summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-29 15:28:17 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-29 15:28:17 +0000
commit32ec7299c1baf07edb136a1432aa7f3e95df55e3 (patch)
tree4329557720ff96766bed709c1262f6354ea30b7f /app-misc/byobu
parentStable for HPPA (bug #470544). (diff)
downloadgentoo-2-32ec7299c1baf07edb136a1432aa7f3e95df55e3.tar.gz
gentoo-2-32ec7299c1baf07edb136a1432aa7f3e95df55e3.tar.bz2
gentoo-2-32ec7299c1baf07edb136a1432aa7f3e95df55e3.zip
app-misc/byobu: Fix usage of new python r1 eclasses (missing PYTHON_REQUIRED_USE, PYTHON_USEDEP); drop py2.5 support because of incompatible deps
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'app-misc/byobu')
-rw-r--r--app-misc/byobu/ChangeLog7
-rw-r--r--app-misc/byobu/byobu-5.39.ebuild12
-rw-r--r--app-misc/byobu/byobu-5.41-r1.ebuild9
-rw-r--r--app-misc/byobu/byobu-5.41.ebuild12
4 files changed, 28 insertions, 12 deletions
diff --git a/app-misc/byobu/ChangeLog b/app-misc/byobu/ChangeLog
index 077c48274fd5..37047029c50f 100644
--- a/app-misc/byobu/ChangeLog
+++ b/app-misc/byobu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/byobu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/ChangeLog,v 1.56 2013/05/29 08:11:50 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/ChangeLog,v 1.57 2013/05/29 15:28:17 jlec Exp $
+
+ 29 May 2013; Justin Lecher <jlec@gentoo.org> byobu-5.39.ebuild,
+ byobu-5.41.ebuild, byobu-5.41-r1.ebuild:
+ Fix usage of new python r1 eclasses (missing PYTHON_REQUIRED_USE,
+ PYTHON_USEDEP); drop py2.5 support because of incompatible deps
29 May 2013; Tim Harder <radhermit@gentoo.org> byobu-5.41-r1.ebuild:
Add python deps.
diff --git a/app-misc/byobu/byobu-5.39.ebuild b/app-misc/byobu/byobu-5.39.ebuild
index 855e81d9f736..a86a648f7451 100644
--- a/app-misc/byobu/byobu-5.39.ebuild
+++ b/app-misc/byobu/byobu-5.39.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/byobu-5.39.ebuild,v 1.1 2013/05/08 10:08:40 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/byobu-5.39.ebuild,v 1.2 2013/05/29 15:28:17 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+PYTHON_COMPAT=( python{2_6,2_7} )
inherit python-single-r1
@@ -16,10 +17,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="screen"
-RDEPEND="
- dev-libs/newt
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/newt[${PYTHON_USEDEP}]
screen? ( app-misc/screen )
!screen? ( app-misc/tmux )"
+DEPEND=""
src_prepare() {
python_fix_shebang .
diff --git a/app-misc/byobu/byobu-5.41-r1.ebuild b/app-misc/byobu/byobu-5.41-r1.ebuild
index 73c8cf512fa9..e20444a18258 100644
--- a/app-misc/byobu/byobu-5.41-r1.ebuild
+++ b/app-misc/byobu/byobu-5.41-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/byobu-5.41-r1.ebuild,v 1.2 2013/05/29 08:11:50 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/byobu-5.41-r1.ebuild,v 1.3 2013/05/29 15:28:17 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+PYTHON_COMPAT=( python{2_6,2_7} )
inherit python-single-r1
@@ -15,12 +16,14 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="screen"
+
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- dev-libs/newt
+ dev-libs/newt[${PYTHON_USEDEP}]
screen? ( app-misc/screen )
!screen? ( app-misc/tmux )"
+DEPEND=""
src_prepare() {
python_fix_shebang .
diff --git a/app-misc/byobu/byobu-5.41.ebuild b/app-misc/byobu/byobu-5.41.ebuild
index 7c429997c4d3..528bfdb9c33b 100644
--- a/app-misc/byobu/byobu-5.41.ebuild
+++ b/app-misc/byobu/byobu-5.41.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/byobu-5.41.ebuild,v 1.1 2013/05/11 06:01:15 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/byobu-5.41.ebuild,v 1.2 2013/05/29 15:28:17 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+PYTHON_COMPAT=( python{2_6,2_7} )
inherit python-single-r1
@@ -16,10 +17,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="screen"
-RDEPEND="
- dev-libs/newt
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/newt[${PYTHON_USEDEP}]
screen? ( app-misc/screen )
!screen? ( app-misc/tmux )"
+DEPEND=""
src_prepare() {
python_fix_shebang .