summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2003-02-23 17:57:07 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2003-02-23 17:57:07 +0000
commitb18b4960945a7910d6f0fd9b46c0def065ae9e4c (patch)
treef92a68bc5bb84d89d5b669b60824d20ed4e1e2a6 /app-misc/chesstask/chesstask-1.3.ebuild
parentsamba-2.2.8_pre1 + samba-3.0_alpha21 (diff)
downloadgentoo-2-b18b4960945a7910d6f0fd9b46c0def065ae9e4c.tar.gz
gentoo-2-b18b4960945a7910d6f0fd9b46c0def065ae9e4c.tar.bz2
gentoo-2-b18b4960945a7910d6f0fd9b46c0def065ae9e4c.zip
chesstask ebuild
Diffstat (limited to 'app-misc/chesstask/chesstask-1.3.ebuild')
-rw-r--r--app-misc/chesstask/chesstask-1.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/chesstask/chesstask-1.3.ebuild b/app-misc/chesstask/chesstask-1.3.ebuild
new file mode 100644
index 000000000000..3c5c4d69a6ab
--- /dev/null
+++ b/app-misc/chesstask/chesstask-1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# Maintainer: Tom Bevan tom@regex.com.au
+# $Header: /var/cvsroot/gentoo-x86/app-misc/chesstask/chesstask-1.3.ebuild,v 1.1 2003/02/23 17:57:00 pvdabeel Exp $
+
+
+S=${WORKDIR}/${PN}1_3
+
+DESCRIPTION="An editor for chess problems. It will generate PostScript and HTML files."
+
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/chesstask/ChessTask1_3src.zip"
+HOMEPAGE="http://chesstask.sourceforge.net/"
+
+KEYWORDS="~ppc"
+
+# License of the package. This must match the name of file(s) in
+# /usr/portage/licenses/. For complex license combination see the developer
+# docs on gentoo.org for details.
+LICENSE=""
+
+DEPEND=">=x11-libs/qt-3
+ app-text/tetex"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S} || die "no such directory ${S}"
+
+ patch -p1 Makefile < ${FILESDIR}/Makefile-1.3.diff || die "Failed to apply patch"
+}
+
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ mkdir -p ${D}/usr/bin
+ cp ${S}/ChessTask ${D}/usr/bin
+}