summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-05-24 22:31:52 +0000
committerRick Farina <zerochaos@gentoo.org>2014-05-24 22:31:52 +0000
commit351fdee404bf971488e901efc97087dd594b9ccc (patch)
tree0888bb86f71980dacc8caefbecb78b2bd50bdd40 /app-misc/crunch
parentFix the variant-obtaining hack after changes to build dir naming in multilib-... (diff)
downloadgentoo-2-351fdee404bf971488e901efc97087dd594b9ccc.tar.gz
gentoo-2-351fdee404bf971488e901efc97087dd594b9ccc.tar.bz2
gentoo-2-351fdee404bf971488e901efc97087dd594b9ccc.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'app-misc/crunch')
-rw-r--r--app-misc/crunch/ChangeLog8
-rw-r--r--app-misc/crunch/crunch-3.6.ebuild30
2 files changed, 36 insertions, 2 deletions
diff --git a/app-misc/crunch/ChangeLog b/app-misc/crunch/ChangeLog
index 3e0792b612fd..e817a3324cc3 100644
--- a/app-misc/crunch/ChangeLog
+++ b/app-misc/crunch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/crunch
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/crunch/ChangeLog,v 1.2 2014/01/02 12:41:34 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/crunch/ChangeLog,v 1.3 2014/05/24 22:31:52 zerochaos Exp $
+
+*crunch-3.6 (24 May 2014)
+
+ 24 May 2014; Rick Farina <zerochaos@gentoo.org> +crunch-3.6.ebuild:
+ version bump
*crunch-3.5 (02 Jan 2014)
@@ -12,4 +17,3 @@
24 Nov 2013; Sergey Popov <pinkbyte@gentoo.org> +crunch-3.4.ebuild,
+files/crunch-3.4-gentoo.patch, +metadata.xml:
Initial commit, wrt bug #458122
-
diff --git a/app-misc/crunch/crunch-3.6.ebuild b/app-misc/crunch/crunch-3.6.ebuild
new file mode 100644
index 000000000000..d8171f4b5be2
--- /dev/null
+++ b/app-misc/crunch/crunch-3.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/crunch/crunch-3.6.ebuild,v 1.1 2014/05/24 22:31:52 zerochaos Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A wordlist generator"
+HOMEPAGE="http://sourceforge.net/projects/crunch-wordlist/"
+SRC_URI="mirror://sourceforge/crunch-wordlist/crunch-wordlist/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install(){
+ dobin crunch
+ doman crunch.1
+ insinto /usr/share/crunch
+ doins charset.lst
+}