summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-08-03 19:54:53 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-08-03 19:54:53 +0000
commitf6cf645afd61a23c3e7af3add0cbc2bab6596640 (patch)
treed171852f0a2e483258fc11fca96376c29b650376 /app-misc/ddccontrol-db/ddccontrol-db-20050715.ebuild
parentStable on alpha. (diff)
downloadgentoo-2-f6cf645afd61a23c3e7af3add0cbc2bab6596640.tar.gz
gentoo-2-f6cf645afd61a23c3e7af3add0cbc2bab6596640.tar.bz2
gentoo-2-f6cf645afd61a23c3e7af3add0cbc2bab6596640.zip
Initial commit, based on ebuild submitted by upstream author Nicolas Boichat <nicolas@boichat.ch>, bug #95326.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-misc/ddccontrol-db/ddccontrol-db-20050715.ebuild')
-rw-r--r--app-misc/ddccontrol-db/ddccontrol-db-20050715.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/ddccontrol-db/ddccontrol-db-20050715.ebuild b/app-misc/ddccontrol-db/ddccontrol-db-20050715.ebuild
new file mode 100644
index 000000000000..5fcf21c7f3d2
--- /dev/null
+++ b/app-misc/ddccontrol-db/ddccontrol-db-20050715.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ddccontrol-db/ddccontrol-db-20050715.ebuild,v 1.1 2005/08/03 19:54:53 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="DDCControl monitor database"
+HOMEPAGE="http://ddccontrol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/-db}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf `enable_with nls` || die "econf failed"
+ # Touch db/options.xml.h, so it is not rebuilt
+ touch db/options.xml.h
+ emake # doesn't really build anything, but there for safety
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}