summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-06-06 16:35:25 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-06-06 16:35:25 +0000
commit6a366d29abd9a7b8d62d71320f13fb58d79e127e (patch)
tree54b8abce84145ff987223538c1a1ce44fb199020 /app-misc/devtodo/files
parent(#86959) Stable on x86. (diff)
downloadgentoo-2-6a366d29abd9a7b8d62d71320f13fb58d79e127e.tar.gz
gentoo-2-6a366d29abd9a7b8d62d71320f13fb58d79e127e.tar.bz2
gentoo-2-6a366d29abd9a7b8d62d71320f13fb58d79e127e.zip
Version bump; not many changes. most upstream changes are already present in 0.1.18-r2. Added gcc-4 patch which is applicable for both 0.1.18-r2 and 0.1.19. Tidy'd old ebuilds and patches.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-misc/devtodo/files')
-rw-r--r--app-misc/devtodo/files/devtodo-0.1.18-gcc4.diff11
-rw-r--r--app-misc/devtodo/files/devtodo-0.1.19-gentoo.diff119
-rw-r--r--app-misc/devtodo/files/devtodo-fix-TERM-sigabrt.patch23
-rw-r--r--app-misc/devtodo/files/devtodo-fix-cd-builtin.patch13
-rw-r--r--app-misc/devtodo/files/devtodo.patch84
-rw-r--r--app-misc/devtodo/files/digest-devtodo-0.1.17-r21
-rw-r--r--app-misc/devtodo/files/digest-devtodo-0.1.18-r11
-rw-r--r--app-misc/devtodo/files/digest-devtodo-0.1.191
8 files changed, 131 insertions, 122 deletions
diff --git a/app-misc/devtodo/files/devtodo-0.1.18-gcc4.diff b/app-misc/devtodo/files/devtodo-0.1.18-gcc4.diff
new file mode 100644
index 000000000000..38caf1b4b12e
--- /dev/null
+++ b/app-misc/devtodo/files/devtodo-0.1.18-gcc4.diff
@@ -0,0 +1,11 @@
+--- src/Todo.h.orig 2005-06-06 12:15:58.000000000 -0400
++++ src/Todo.h 2005-06-06 12:13:41.000000000 -0400
+@@ -14,6 +14,8 @@
+ 01/02/01 Initial creation
+ */
+
++class TodoDB;
++
+ class Todo {
+ public :
+ friend class TodoDB;
diff --git a/app-misc/devtodo/files/devtodo-0.1.19-gentoo.diff b/app-misc/devtodo/files/devtodo-0.1.19-gentoo.diff
new file mode 100644
index 000000000000..4152776d58f7
--- /dev/null
+++ b/app-misc/devtodo/files/devtodo-0.1.19-gentoo.diff
@@ -0,0 +1,119 @@
+diff -urN devtodo-0.1.18.orig/acconfig.h devtodo-0.1.18/acconfig.h
+--- devtodo-0.1.18.orig/acconfig.h 2004-12-17 10:21:09.168345388 -0500
++++ devtodo-0.1.18/acconfig.h 1969-12-31 19:00:00.000000000 -0500
+@@ -1,6 +0,0 @@
+-/* System configuration directory */
+-#undef SYSCONFDIR
+-
+-/* Use termcap to get terminal width */
+-#undef USETERMCAP
+-@TOP@
+diff -urN devtodo-0.1.18.orig/configure.in devtodo-0.1.18/configure.in
+--- devtodo-0.1.18.orig/configure.in 2004-12-17 10:21:09.166345721 -0500
++++ devtodo-0.1.18/configure.in 2004-12-17 10:21:34.049210408 -0500
+@@ -25,7 +25,7 @@
+ # Don't use termcap to obtain window size
+ AC_ARG_WITH(termcap, [ --without-termcap don't use termcap to obtain terminal width])
+ if test "${with_termcap}_" = _ -o "${with_termcap}_" = yes; then
+- AC_DEFINE(USETERMCAP)
++ AC_DEFINE(USETERMCAP, [], [Use termcap?])
+ fi
+
+ # Check for various headers and functions - although I'm not doing anything
+@@ -79,7 +79,7 @@
+ AC_SUBST(READLINE_LIBS)
+
+ SYSCONFDIR="`eval echo $sysconfdir`"
+-AC_DEFINE_UNQUOTED(SYSCONFDIR, "$SYSCONFDIR")
++AC_DEFINE_UNQUOTED(SYSCONFDIR, "$SYSCONFDIR", [System configuration directory])
+ AC_SUBST(SYSCONFDIR)
+
+ AC_CHECK_PROG(HAVE_CRASH_CONFIG, crash-config, yes)
+diff -urN devtodo-0.1.18.orig/doc/devtodo.1.in devtodo-0.1.18/doc/devtodo.1.in
+--- devtodo-0.1.18.orig/doc/devtodo.1.in 2004-12-17 10:21:09.135350872 -0500
++++ devtodo-0.1.18/doc/devtodo.1.in 2004-12-17 10:21:34.050210242 -0500
+@@ -20,9 +20,6 @@
+ .TP
+ \fBtdd \fI<indices>\fP\fP
+ Mark the specified items as being done.
+-.TP
+-\fBtdl [\-g \fI<index>\fP] \fI<database>\fP\fP
+-Link the specified devtodo database into the current one, optionally grafting it as a child of the specified index.
+ .SH "DESCRIPTION"
+ .LP
+ \fBtodo\fP is a program aimed specifically at programmers (but usable by anybody at the terminal) to aid in day\-to\-day development.
+@@ -372,6 +369,10 @@
+ .TP
+ \fB~/.todorc\fR
+ User-specific options are specified in this file. Please refer to the section \fBTODORC\fR for more information.
++.SH "BUGS"
++.LP
++Because of a conflict with app-misc/tdl, the tdl symbolic link and the tdl manual page have been removed.
++See \fIhttp://bugs.gentoo.org/show_bug.cgi?id=55371\fR for more information.
+ .SH "AUTHORS"
+ .LP
+ Alec Thomas \fI<alec@swapoff.org>\fR
+diff -urN devtodo-0.1.18.orig/doc/Makefile.am devtodo-0.1.18/doc/Makefile.am
+--- devtodo-0.1.18.orig/doc/Makefile.am 2004-12-17 10:21:09.135350872 -0500
++++ devtodo-0.1.18/doc/Makefile.am 2004-12-17 10:21:34.050210242 -0500
+@@ -1,5 +1,5 @@
+ man_MANS=devtodo.1
+-manlinks=tda tdr tdd tde tdl todo
++manlinks=tda tdr tdd tde todo
+
+ install-data-local:
+ mkdir -p $(DESTDIR)$(mandir)/man1
+diff -urN devtodo-0.1.18.orig/src/Makefile.am devtodo-0.1.18/src/Makefile.am
+--- devtodo-0.1.18.orig/src/Makefile.am 2004-12-17 10:21:09.154347715 -0500
++++ devtodo-0.1.18/src/Makefile.am 2004-12-17 10:21:34.053209744 -0500
+@@ -1,18 +1,12 @@
+ bin_PROGRAMS=devtodo
+ devtodo_SOURCES=Todo.cc Todo.h TodoDB.cc TodoDB.h support.cc support.h \
+ main.cc todoterm.cc todoterm.h Loaders.cc Loaders.h todorl.h
+-binlinks=tda tdr tdd tdl tde todo
++binlinks=tda tdr tdd tde todo
+
+ devtodo_LDADD=../util/libutil.la
+ INCLUDES=-I../util
+ LIBS=@READLINE_LIBS@
+
+-if DEBUG
+-CPPFLAGS=-g
+-else
+-CPPFLAGS+=-DNDEBUG
+-endif
+-
+ install-exec-hook:
+ cd $(DESTDIR)$(bindir); for i in $(binlinks); do $(LN_S) -f devtodo $$i; done
+
+diff -urN devtodo-0.1.18.orig/src/TodoDB.cc devtodo-0.1.18/src/TodoDB.cc
+--- devtodo-0.1.18.orig/src/TodoDB.cc 2004-12-17 10:21:09.136350706 -0500
++++ devtodo-0.1.18/src/TodoDB.cc 2004-12-17 10:21:34.054209577 -0500
+@@ -949,7 +948,11 @@
+ if (out.bad())
+ throw exception("couldn't open TODO for generation");
+
+- if (titleText != "") wraptext(out, titleText, 0, options.columns);
++ if (titleText != "") {
++ wraptext(out, titleText, 0, options.columns);
++ out << endl << endl;
++ }
++
+ if (options.verbose > 1)
+ cout << "todo: generating using format '" << options.format["verbose-generated"] << "'" << endl;
+ filterView();
+diff -urN devtodo-0.1.18.orig/util/c_regex.h devtodo-0.1.18/util/c_regex.h
+--- devtodo-0.1.18.orig/util/c_regex.h 2004-12-17 10:21:09.157347216 -0500
++++ devtodo-0.1.18/util/c_regex.h 2004-12-17 10:25:41.026169344 -0500
+@@ -533,7 +533,10 @@
+ /* For now unconditionally define __restrict_arr to expand to nothing.
+ Ideally we would have a test for the compiler which allows defining
+ it to restrict. */
+-#define __restrict_arr
++#ifdef __restrict_arr
++# undef __restrict_arr
++# define __restrict_arr
++#endif
+
+ /* POSIX compatibility. */
+ extern int regcomp _RE_ARGS ((regex_t *__restrict __preg,
diff --git a/app-misc/devtodo/files/devtodo-fix-TERM-sigabrt.patch b/app-misc/devtodo/files/devtodo-fix-TERM-sigabrt.patch
deleted file mode 100644
index e90f4626cb12..000000000000
--- a/app-misc/devtodo/files/devtodo-fix-TERM-sigabrt.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/todoterm.cc.orig 2004-08-13 00:11:52.095224000 -0400
-+++ src/todoterm.cc 2004-08-13 01:15:38.901461024 -0400
-@@ -2,6 +2,7 @@
- #include "todoterm.h"
-
- #ifdef USETERMCAP
-+#include <iostream>
- #include <string>
- #include <stdexcept>
- #include <curses.h>
-@@ -14,7 +15,11 @@
- int getWidth() {
- if (!info[2047]) {
- char const *termtype = getenv("TERM");
-- if (!termtype) throw runtime_error("can't get terminal type, please set TERM envar");
-+ if (!termtype) {
-+ cerr << "can't get terminal type, defaulting to vt100." << endl;
-+ cerr << "please set the TERM env variable." << endl;
-+ setenv("TERM", "vt100", 0);
-+ }
- int result = tgetent(info, getenv("TERM"));
- if (result < 0)
- throw runtime_error("could not access termcap database");
diff --git a/app-misc/devtodo/files/devtodo-fix-cd-builtin.patch b/app-misc/devtodo/files/devtodo-fix-cd-builtin.patch
deleted file mode 100644
index 09c8bf4bb999..000000000000
--- a/app-misc/devtodo/files/devtodo-fix-cd-builtin.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- doc/scripts.sh.orig 2004-08-13 00:06:05.751876192 -0400
-+++ doc/scripts.sh 2004-08-13 00:06:56.935095160 -0400
-@@ -22,7 +22,9 @@
-
- cd ()
- {
-- builtin cd "$@" && [ -r .todo ] && devtodo ${TODO_OPTIONS}
-+ builtin cd "$@"
-+ RV=$?
-+ [ -r .todo ] && devtodo ${TODO_OPTIONS} || return $RV
- }
-
- pushd ()
diff --git a/app-misc/devtodo/files/devtodo.patch b/app-misc/devtodo/files/devtodo.patch
deleted file mode 100644
index c37fd1f542be..000000000000
--- a/app-misc/devtodo/files/devtodo.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-diff -ru devtodo-0.1.17.old/src/support.cc devtodo-0.1.17.new/src/support.cc
---- devtodo-0.1.17.old/src/support.cc 2002-12-26 05:32:18.000000000 +0100
-+++ devtodo-0.1.17.new/src/support.cc 2003-07-01 00:36:30.000000000 +0200
-@@ -2,7 +2,7 @@
- #include <cstdlib>
- #include <cstring>
- #include <cstdio>
--#include <strstream>
-+#include <sstream>
- #include <stdexcept>
- #include "support.h"
- #include "TodoDB.h"
-@@ -814,7 +814,7 @@
-
- while (in.getline(line, 1024)) {
- string str;
-- istrstream is(line);
-+ istringstream is(line);
-
- if (is >> str) {
- if (str[0] == '#') continue;
-@@ -837,7 +837,7 @@
- // multi-line event ?
- if (str == "{") {
- while (in.getline(line, 1024)) {
-- istrstream is(line);
-+ istringstream is(line);
-
- if (is >> str) {
- if (str[0] == '#') continue;
-diff -ru devtodo-0.1.17.old/util/CommandArgs.h devtodo-0.1.17.new/util/CommandArgs.h
---- devtodo-0.1.17.old/util/CommandArgs.h 2001-07-10 19:11:47.000000000 +0200
-+++ devtodo-0.1.17.new/util/CommandArgs.h 2003-07-01 00:36:30.000000000 +0200
-@@ -5,6 +5,7 @@
- #include <string>
- #include <vector>
- #include <iostream>
-+#include <cassert>
- #include "Strings.h"
-
- using namespace std;
-diff -ru devtodo-0.1.17.old/util/Regex.h devtodo-0.1.17.new/util/Regex.h
---- devtodo-0.1.17.old/util/Regex.h 2002-12-21 16:10:43.000000000 +0100
-+++ devtodo-0.1.17.new/util/Regex.h 2003-07-01 00:36:30.000000000 +0200
-@@ -6,6 +6,7 @@
- #include <map>
- #include <utility>
- #include <stdexcept>
-+#include <cassert>
- #include <sys/types.h>
- #include "c_regex.h"
-
-diff -ru devtodo-0.1.17.old/util/Strings.h devtodo-0.1.17.new/util/Strings.h
---- devtodo-0.1.17.old/util/Strings.h 2002-07-23 07:25:45.000000000 +0200
-+++ devtodo-0.1.17.new/util/Strings.h 2003-07-01 00:36:30.000000000 +0200
-@@ -7,7 +7,7 @@
- #include <cerrno>
- #include <iostream>
- #include <vector>
--#include <strstream>
-+#include <sstream>
- #include <stdexcept>
-
- using namespace std;
-@@ -118,8 +118,8 @@
- @parameter var Variable to convert.
- */
- template <typename T> string stringify(T const &t) {
--ostrstream os;
-- os << t << '\0';
-+ostringstream os;
-+ os << t;
- return os.str();
- }
-
-@@ -135,7 +135,7 @@
- @parameter str Strings to convert to type T.
- */
- template <typename T> T destringify(string const &str) {
--istrstream os(str.c_str());
-+istringstream os(str);
- T t;
-
- os >> t;
diff --git a/app-misc/devtodo/files/digest-devtodo-0.1.17-r2 b/app-misc/devtodo/files/digest-devtodo-0.1.17-r2
deleted file mode 100644
index 21e6c99eeb79..000000000000
--- a/app-misc/devtodo/files/digest-devtodo-0.1.17-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 cc3cdd3064eaa7270191bee63d3b1a2c devtodo-0.1.17.tar.gz 312755
diff --git a/app-misc/devtodo/files/digest-devtodo-0.1.18-r1 b/app-misc/devtodo/files/digest-devtodo-0.1.18-r1
deleted file mode 100644
index 1e3f25c5d61f..000000000000
--- a/app-misc/devtodo/files/digest-devtodo-0.1.18-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 6ca0a414685cb7a7f32f7ae22cb3a2a9 devtodo-0.1.18.tar.gz 432858
diff --git a/app-misc/devtodo/files/digest-devtodo-0.1.19 b/app-misc/devtodo/files/digest-devtodo-0.1.19
new file mode 100644
index 000000000000..92ca1a8b9d5a
--- /dev/null
+++ b/app-misc/devtodo/files/digest-devtodo-0.1.19
@@ -0,0 +1 @@
+MD5 723c86eae76c425ab9f271760bb951a3 devtodo-0.1.19.tar.gz 442920