summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-10-28 17:25:25 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-10-28 17:25:25 +0000
commitfc214abf1f15cacab96a64cb0e14c02515dbcd59 (patch)
treecc410420e2a24d4141d24af5babcba31052825bc /app-misc/hivex
parentApply Interfaces patch against configure.ac instead of configure.ac.in. Thank... (diff)
downloadgentoo-2-fc214abf1f15cacab96a64cb0e14c02515dbcd59.tar.gz
gentoo-2-fc214abf1f15cacab96a64cb0e14c02515dbcd59.tar.bz2
gentoo-2-fc214abf1f15cacab96a64cb0e14c02515dbcd59.zip
Bump to 1.3.2, thanks to slepnoga
(Portage version: 2.1.10.26/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/hivex')
-rw-r--r--app-misc/hivex/ChangeLog8
-rw-r--r--app-misc/hivex/files/autoconf_fix-1.3.2.patch104
-rw-r--r--app-misc/hivex/hivex-1.3.2.ebuild78
3 files changed, 189 insertions, 1 deletions
diff --git a/app-misc/hivex/ChangeLog b/app-misc/hivex/ChangeLog
index a01bf9fcf41d..103a7b5320e4 100644
--- a/app-misc/hivex/ChangeLog
+++ b/app-misc/hivex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/hivex
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.4 2011/09/18 12:22:56 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.5 2011/10/28 17:25:25 maksbotan Exp $
+
+*hivex-1.3.2 (28 Oct 2011)
+
+ 28 Oct 2011; Maxim Koltsov <maksbotan@gentoo.org> +hivex-1.3.2.ebuild,
+ +files/autoconf_fix-1.3.2.patch:
+ Bump to 1.3.2, thanks to slepnoga
18 Sep 2011; Maxim Koltsov <maksbotan@gentoo.org> metadata.xml:
Fix herd to be proxy-maintainers
diff --git a/app-misc/hivex/files/autoconf_fix-1.3.2.patch b/app-misc/hivex/files/autoconf_fix-1.3.2.patch
new file mode 100644
index 000000000000..2a9495b51cea
--- /dev/null
+++ b/app-misc/hivex/files/autoconf_fix-1.3.2.patch
@@ -0,0 +1,104 @@
+--- configure.ac.orig 2011-08-15 22:29:28.309745342 +0300
++++ configure.ac 2011-08-15 22:34:54.324549151 +0300
+@@ -170,11 +170,18 @@
+ AC_SUBST([LIBXML2_CFLAGS])
+ AC_SUBST([LIBXML2_LIBS])
+
++
++dnl ////////////////////////////////////////////////////////////////////////////
+ dnl Check for OCaml (optional, for OCaml bindings).
++
++AC_ARG_ENABLE([ocaml],
++ AS_HELP_STRING([--with-ocaml],[build Ocaml binding]))
++
++
+ AC_PROG_OCAML
+ AC_PROG_FINDLIB
+ AM_CONDITIONAL([HAVE_OCAML],
+- [test "x$OCAMLC" != "xno" && test "x$OCAMLFIND" != "xno"])
++ [test "x$OCAMLC" != "xno" -a "x$OCAMLFIND" != "xno" -a "x$enable_ocaml" = "xyes"])
+ AM_CONDITIONAL([HAVE_OCAMLOPT],
+ [test "x$OCAMLOPT" != "xno" && test "x$OCAMLFIND" != "xno"])
+
+@@ -207,6 +214,8 @@
+ rm -f conftest conftest.* conftest_ml.*
+ fi
+
++dnl ///////////////////////////////////////////////////////////////////////////////////////
++
+ dnl Check for Perl (optional, for Perl bindings).
+ dnl XXX This isn't quite right, we should check for Perl devel library.
+ AC_CHECK_PROG([PERL],[perl],[perl],[no])
+@@ -214,21 +223,35 @@
+ dnl Check for Perl modules that must be present to compile and
+ dnl test the Perl bindings.
+ missing_perl_modules=no
+-for pm in Test::More ExtUtils::MakeMaker IO::Stringy; do
+- AC_MSG_CHECKING([for $pm])
+- if ! perl -M$pm -e1 >/dev/null 2>&1; then
+- AC_MSG_RESULT([no])
+- missing_perl_modules=yes
+- else
+- AC_MSG_RESULT([yes])
+- fi
+-done
+-if test "x$missing_perl_modules" = "xyes"; then
+- AC_MSG_WARN([some Perl modules required to compile or test the Perl bindings are missing])
+-fi
++
++AC_ARG_ENABLE([perl],
++ AS_HELP_STRING([--with-perl],[build Perl binding]))
++
++
++PERL=
++AS_IF([test "x$enable_perl" != "xno" ],[
++ AC_CHECK_PROG([PERL],[perl],[yes],[no])
++
++ for pm in Test::More ExtUtils::MakeMaker IO::Stringy; do
++ AC_MSG_CHECKING([for $pm])
++ if ! perl -M$pm -e1 >/dev/null 2>&1; then
++ AC_MSG_RESULT([no])
++ missing_perl_modules=yes
++ else
++ AC_MSG_RESULT([yes])
++ fi
++ done
++
++ AS_IF([test "x$missing_perl_modules" = "xyes"],
++ [AC_MSG_FAILURE([some Perl modules required to compile or test the Perl bindings are missing])],
++ )
++])
++
+
+ AM_CONDITIONAL([HAVE_PERL],
+- [test "x$PERL" != "xno" && test "x$missing_perl_modules" != "xyes"])
++ [test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes" -a "x$enable_perl" = "xyes"])
++
++dnl //////////////////////////////////////////////////////////////////////////////////////////////////
+
+ dnl Check for Python (optional, for Python bindings).
+ AC_CHECK_PROG([PYTHON],[python],[python],[no])
+@@ -266,15 +289,21 @@
+ AC_SUBST(PYTHON_INCLUDEDIR)
+ AC_SUBST(PYTHON_SITE_PACKAGES)
+
++AC_ARG_ENABLE([python],
++ AS_HELP_STRING([--with-python],[build Python binding]))
++
+ AM_CONDITIONAL([HAVE_PYTHON],
+- [test "x$PYTHON_INCLUDEDIR" != "x" && test "x$PYTHON_SITE_PACKAGES" != "x"])
++ [test "x$PYTHON_INCLUDEDIR" != "x" -a "x$PYTHON_SITE_PACKAGES" != "x" -a "x$enable_python" = "xyes"])
+
+ dnl Check for Ruby and rake (optional, for Ruby bindings).
+ AC_CHECK_LIB([ruby],[ruby_init],[HAVE_LIBRUBY=1],[HAVE_LIBRUBY=0])
+ AC_CHECK_PROG([RAKE],[rake],[rake],[no])
+
++AC_ARG_ENABLE([ruby],
++ AS_HELP_STRING([--with-ruby],[build Ruby binding]))
++
+ AM_CONDITIONAL([HAVE_RUBY],
+- [test "x$RAKE" != "xno" && test -n "$HAVE_LIBRUBY"])
++ [test "x$RAKE" != "xno" && test -n "$HAVE_LIBRUBY" -a "x$enable_ruby" = "xyes"])
+
+ dnl dnl Check for Java.
+ dnl AC_ARG_WITH(java_home,
diff --git a/app-misc/hivex/hivex-1.3.2.ebuild b/app-misc/hivex/hivex-1.3.2.ebuild
new file mode 100644
index 000000000000..1964b3a73c72
--- /dev/null
+++ b/app-misc/hivex/hivex-1.3.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.2.ebuild,v 1.1 2011/10/28 17:25:25 maksbotan Exp $
+
+EAPI=4
+
+WANT_AUTOMAKE="1.11"
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit base autotools-utils perl-app python
+
+PYTHON_DEPEND="python? 2:2.6"
+
+DESCRIPTION="Library for reading and writing Windows Registry "hive" binary files."
+HOMEPAGE="http://libguestfs.org"
+SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocaml readline perl python test static-libs ruby"
+
+RDEPEND="virtual/libiconv
+ virtual/libintl
+ dev-libs/libxml2:2
+ ocaml? ( dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ )
+ readline? ( sys-libs/readline )
+ perl? ( dev-perl/IO-stringy )
+ "
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ perl? (
+ test? ( dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage ) )
+ ruby? ( dev-ruby/rake )
+ "
+PATCHES=("${FILESDIR}"/autoconf_fix-${PV}.patch)
+DOCS=(README)
+
+pkg_config() {
+ python_set_active_version 2
+ python_need_rebuild
+}
+
+src_prepare() {
+ autotools-utils_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with readline)
+ $(use_enable ocaml)
+ $(use_enable perl)
+ --enable-nls
+ $(use_enable python)
+ $(use_enable ruby)
+ --disable-rpath )
+
+ autotools-utils_src_configure
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ strip-linguas -i po
+
+ autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
+
+ if use perl; then
+ fixlocalpod
+ fi
+}