summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2007-09-09 22:13:53 +0000
committerRobert Buchholz <rbu@gentoo.org>2007-09-09 22:13:53 +0000
commitbd62796702d40bdd28673e55e3ebe8c729d081ae (patch)
tree7211e74201a832f5e3c82ae8cfa4dd906f012e4b /app-misc/lcd-stuff
parentVersion bumped. (diff)
downloadgentoo-2-bd62796702d40bdd28673e55e3ebe8c729d081ae.tar.gz
gentoo-2-bd62796702d40bdd28673e55e3ebe8c729d081ae.tar.bz2
gentoo-2-bd62796702d40bdd28673e55e3ebe8c729d081ae.zip
Version bump, introducing rss display improvements and mpd crash/display bugs
(Portage version: 2.1.3.7)
Diffstat (limited to 'app-misc/lcd-stuff')
-rw-r--r--app-misc/lcd-stuff/ChangeLog8
-rw-r--r--app-misc/lcd-stuff/files/digest-lcd-stuff-0.1.43
-rw-r--r--app-misc/lcd-stuff/files/lcd-stuff.confd2
-rw-r--r--app-misc/lcd-stuff/lcd-stuff-0.1.4.ebuild58
4 files changed, 69 insertions, 2 deletions
diff --git a/app-misc/lcd-stuff/ChangeLog b/app-misc/lcd-stuff/ChangeLog
index 0696b1b07dfb..6d8e35d40a8f 100644
--- a/app-misc/lcd-stuff/ChangeLog
+++ b/app-misc/lcd-stuff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/lcd-stuff
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lcd-stuff/ChangeLog,v 1.10 2007/08/08 20:43:02 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcd-stuff/ChangeLog,v 1.11 2007/09/09 22:13:52 rbu Exp $
+
+*lcd-stuff-0.1.4 (09 Sep 2007)
+
+ 09 Sep 2007; Robert Buchholz <rbu@gentoo.org> files/lcd-stuff.confd,
+ +lcd-stuff-0.1.4.ebuild:
+ Version bump, introducing rss display improvements and mpd crash/display bugs
*lcd-stuff-0.1.3 (08 Aug 2007)
diff --git a/app-misc/lcd-stuff/files/digest-lcd-stuff-0.1.4 b/app-misc/lcd-stuff/files/digest-lcd-stuff-0.1.4
new file mode 100644
index 000000000000..53497adb9c00
--- /dev/null
+++ b/app-misc/lcd-stuff/files/digest-lcd-stuff-0.1.4
@@ -0,0 +1,3 @@
+MD5 d185443751759a9ab33ea69d45d9e781 lcd-stuff-0.1.4.tar.bz2 123430
+RMD160 87d56755c019307856e7b9ebab43f79bedfc9550 lcd-stuff-0.1.4.tar.bz2 123430
+SHA256 b065e296599380d153a9f06c7c40d9e4c23e7c0bfa624760855209a4d1e24d45 lcd-stuff-0.1.4.tar.bz2 123430
diff --git a/app-misc/lcd-stuff/files/lcd-stuff.confd b/app-misc/lcd-stuff/files/lcd-stuff.confd
index 3381aa82a9f5..c32169ba42ff 100644
--- a/app-misc/lcd-stuff/files/lcd-stuff.confd
+++ b/app-misc/lcd-stuff/files/lcd-stuff.confd
@@ -10,4 +10,4 @@ TCPPORT=13666
REPORTLEVEL=2
# Configuration file for lcd-stuff
-CONFIGFILE="/etc/lcd-stuff.conf" \ No newline at end of file
+CONFIGFILE="/etc/lcd-stuff.conf"
diff --git a/app-misc/lcd-stuff/lcd-stuff-0.1.4.ebuild b/app-misc/lcd-stuff/lcd-stuff-0.1.4.ebuild
new file mode 100644
index 000000000000..afb5eb8db782
--- /dev/null
+++ b/app-misc/lcd-stuff/lcd-stuff-0.1.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcd-stuff/lcd-stuff-0.1.4.ebuild,v 1.1 2007/09/09 22:13:52 rbu Exp $
+
+inherit eutils
+
+DESCRIPTION="lcd-stuff is a client for lcdproc that displays RSS, Weather, MPD and new mail."
+HOMEPAGE="http://lcd-stuff.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2" # and GPL-2 only
+
+RDEPEND="app-misc/lcdproc
+ net-misc/curl
+ dev-libs/glib
+ imap? ( net-libs/libetpan )
+ mpd? ( >=media-libs/libmpd-0.12.0 )
+ mp3? ( media-libs/taglib )
+ xml? ( net-libs/libnxml )
+ rss? ( net-libs/libmrss net-libs/libnxml )"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+IUSE="imap mpd mp3 xml rss"
+
+src_compile() {
+ local XMLRSSLIB="$(use_enable rss mrss)"
+ if use rss ; then
+ # If we want rss, we must also have xml
+ XMLRSSLIB="${XMLRSSLIB} --enable-nxml"
+ else
+ XMLRSSLIB="${XMLRSSLIB} $(use_enable xml nxml)"
+ fi
+
+ econf \
+ $(use_enable imap libetpan) \
+ $(use_enable mpd libmpd) \
+ $(use_enable mp3 taglib_c) \
+ $XMLRSSLIB \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install()
+{
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ insinto /etc
+ doins lcd-stuff.conf
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}-0.1.2-r1.initd" ${PN}
+
+ dodoc ChangeLog README
+}