summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-09-14 05:12:42 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-09-14 05:12:42 +0000
commit1886d967693448fdd1a189306edbdaf8c75898d9 (patch)
tree920758b678d667c2c7ebe8fb8fa7e1d24eb6770f /app-misc/mc
parentDrop vecho usage, and ebuild attempt to do UI the PM does for test phase (diff)
downloadgentoo-2-1886d967693448fdd1a189306edbdaf8c75898d9.tar.gz
gentoo-2-1886d967693448fdd1a189306edbdaf8c75898d9.tar.bz2
gentoo-2-1886d967693448fdd1a189306edbdaf8c75898d9.zip
Fix tab effect bug in editor (bug #434688 by Lars Wendler).
(Portage version: 2.2.0_alpha124_p5/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/ChangeLog9
-rw-r--r--app-misc/mc/files/mc-4.8.5-Ticket-2881-fix-tabs.patch39
-rw-r--r--app-misc/mc/mc-4.8.5-r1.ebuild (renamed from app-misc/mc/mc-4.8.5.ebuild)4
3 files changed, 50 insertions, 2 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index 4f4b76a2463c..4920e00c0fa4 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/mc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.265 2012/09/10 21:02:57 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.266 2012/09/14 05:12:42 slyfox Exp $
+
+*mc-4.8.5-r1 (14 Sep 2012)
+
+ 14 Sep 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/mc-4.8.5-Ticket-2881-fix-tabs.patch, +mc-4.8.5-r1.ebuild,
+ -mc-4.8.5.ebuild:
+ Fix tab effect bug in editor (bug #434688 by Lars Wendler).
*mc-4.8.5 (10 Sep 2012)
diff --git a/app-misc/mc/files/mc-4.8.5-Ticket-2881-fix-tabs.patch b/app-misc/mc/files/mc-4.8.5-Ticket-2881-fix-tabs.patch
new file mode 100644
index 000000000000..ca4a6cbf64d0
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.5-Ticket-2881-fix-tabs.patch
@@ -0,0 +1,39 @@
+https://www.midnight-commander.org/ticket/2881
+https://bugs.gentoo.org/show_bug.cgi?id=434688
+
+commit 28cd54da5a73e6d722bd0534e3f43baedb398cea
+Author: Andrew Borodin <aborodin@vmail.ru>
+Date: Tue Sep 11 10:14:48 2012 +0400
+
+ Ticket #2881: (edit_move_forward3): fix two-columns extra offset of cursor
+
+ ...after tab character.
+
+ Signed-off-by: Andrew Borodin <aborodin@vmail.ru>
+
+diff --git a/src/editor/edit.c b/src/editor/edit.c
+index bfda1b9..3dfd22e 100644
+--- a/src/editor/edit.c
++++ b/src/editor/edit.c
+@@ -3073,16 +3073,15 @@ edit_move_forward3 (WEdit * edit, off_t current, long cols, off_t upto)
+ c = convert_to_display_c (c);
+ #endif
+
++ if (c == '\n')
++ return (upto != 0 ? (off_t) col : p);
+ if (c == '\t')
+ col += TAB_SIZE - col % TAB_SIZE;
+- else if (c == '\n')
+- return (upto != 0 ? (off_t) col : p);
+-
+- if ((c < 32 || c == 127) && (orig_c == c
++ else if ((c < 32 || c == 127) && (orig_c == c
+ #ifdef HAVE_CHARSET
+- || (!mc_global.utf8_display && !edit->utf8)
++ || (!mc_global.utf8_display && !edit->utf8)
+ #endif
+- ))
++ ))
+ /* '\r' is shown as ^M, so we must advance 2 characters */
+ /* Caret notation for control characters */
+ col += 2;
diff --git a/app-misc/mc/mc-4.8.5.ebuild b/app-misc/mc/mc-4.8.5-r1.ebuild
index 0c4035147cc6..4ce6df9e82e0 100644
--- a/app-misc/mc/mc-4.8.5.ebuild
+++ b/app-misc/mc/mc-4.8.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.8.5.ebuild,v 1.1 2012/09/10 21:02:57 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.8.5-r1.ebuild,v 1.1 2012/09/14 05:12:42 slyfox Exp $
EAPI=4
@@ -43,6 +43,8 @@ DEPEND="${RDEPEND}
src_prepare() {
[[ -n ${LIVE_EBUILD} ]] && ./autogen.sh
+
+ epatch "${FILESDIR}"/${P}-Ticket-2881-fix-tabs.patch
}
S=${WORKDIR}/${MY_P}