summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-10-02 07:00:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-10-02 07:00:16 +0000
commit7f3c48c90e690a36fcafaebf7dedae17cf1465c8 (patch)
treeb55fdfff594654d41ee8f3593770fc5f8c2821c7 /app-misc/media-player-info
parentVersion bump. (diff)
downloadgentoo-2-7f3c48c90e690a36fcafaebf7dedae17cf1465c8.tar.gz
gentoo-2-7f3c48c90e690a36fcafaebf7dedae17cf1465c8.tar.bz2
gentoo-2-7f3c48c90e690a36fcafaebf7dedae17cf1465c8.zip
Fix a problem with missing empty line in the udev rule.
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-misc/media-player-info')
-rw-r--r--app-misc/media-player-info/ChangeLog8
-rw-r--r--app-misc/media-player-info/files/media-player-info-21-udev.patch20
-rw-r--r--app-misc/media-player-info/media-player-info-21-r1.ebuild43
3 files changed, 70 insertions, 1 deletions
diff --git a/app-misc/media-player-info/ChangeLog b/app-misc/media-player-info/ChangeLog
index 41358c4be383..5f0680dbee38 100644
--- a/app-misc/media-player-info/ChangeLog
+++ b/app-misc/media-player-info/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/media-player-info
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/media-player-info/ChangeLog,v 1.31 2013/08/11 19:00:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/media-player-info/ChangeLog,v 1.32 2013/10/02 07:00:16 ssuominen Exp $
+
+*media-player-info-21-r1 (02 Oct 2013)
+
+ 02 Oct 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +files/media-player-info-21-udev.patch, +media-player-info-21-r1.ebuild:
+ Fix a problem with missing empty line in the udev rule.
11 Aug 2013; Samuli Suominen <ssuominen@gentoo.org>
media-player-info-21.ebuild:
diff --git a/app-misc/media-player-info/files/media-player-info-21-udev.patch b/app-misc/media-player-info/files/media-player-info-21-udev.patch
new file mode 100644
index 000000000000..fd2fe4b28af3
--- /dev/null
+++ b/app-misc/media-player-info/files/media-player-info-21-udev.patch
@@ -0,0 +1,20 @@
+From 952a7e728356681f019f3a5076169daa24b946b9 Mon Sep 17 00:00:00 2001
+From: Martin Pitt <martinpitt@gnome.org>
+Date: Mon, 30 Sep 2013 12:07:49 +0000
+Subject: Terminate udev rules with an empty line
+
+Apparently newer udev versions now complain about the lack of it. Reported by
+Frederic Crozat.
+---
+diff --git a/tools/mpi2udev.py b/tools/mpi2udev.py
+index d33055b..33fdfa2 100755
+--- a/tools/mpi2udev.py
++++ b/tools/mpi2udev.py
+@@ -126,4 +126,4 @@ for f in sys.argv[2:]:
+ parse_mpi(f, hwdb)
+
+ # udev rules footer
+-os.write(sys.stdout.fileno(), b'\nLABEL="media_player_end"')
++os.write(sys.stdout.fileno(), b'\nLABEL="media_player_end"\n')
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/app-misc/media-player-info/media-player-info-21-r1.ebuild b/app-misc/media-player-info/media-player-info-21-r1.ebuild
new file mode 100644
index 000000000000..d954457f8f4f
--- /dev/null
+++ b/app-misc/media-player-info/media-player-info-21-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/media-player-info/media-player-info-21-r1.ebuild,v 1.1 2013/10/02 07:00:16 ssuominen Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_2,3_3} )
+
+inherit eutils python-any-r1
+
+DESCRIPTION="A repository of data files describing media player capabilities"
+HOMEPAGE="http://cgit.freedesktop.org/media-player-info/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+# http://cgit.freedesktop.org/media-player-info/commit/?id=d83dd01a0a1df6198ee08954da1c033b88a1004b
+RDEPEND=">=virtual/udev-196[hwdb(+)]"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS NEWS README"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-udev.patch
+}
+
+pkg_postinst() {
+ # Run for /lib/udev/hwdb.d/20-usb-media-players.hwdb
+ udevadm hwdb --update --root="${ROOT%/}"
+ # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
+ return 0
+ fi
+ udevadm control --reload
+}