summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2009-10-09 14:47:50 +0000
committerMarijn Schouten <hkbst@gentoo.org>2009-10-09 14:47:50 +0000
commit710412bb60094b756282a8284fa553f297b2deec (patch)
treef93aa08fc5dadbb84d090368fdf57e447d47f6f9 /app-misc/rlwrap/rlwrap-0.32.ebuild
parentbump (bug 287235), thanks to gmalecha@gmail.com for testing (diff)
downloadgentoo-2-710412bb60094b756282a8284fa553f297b2deec.tar.gz
gentoo-2-710412bb60094b756282a8284fa553f297b2deec.tar.bz2
gentoo-2-710412bb60094b756282a8284fa553f297b2deec.zip
bump
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/rlwrap/rlwrap-0.32.ebuild')
-rw-r--r--app-misc/rlwrap/rlwrap-0.32.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-misc/rlwrap/rlwrap-0.32.ebuild b/app-misc/rlwrap/rlwrap-0.32.ebuild
new file mode 100644
index 000000000000..c0b0c32d032a
--- /dev/null
+++ b/app-misc/rlwrap/rlwrap-0.32.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rlwrap/rlwrap-0.32.ebuild,v 1.1 2009/10/09 14:47:50 hkbst Exp $
+
+DESCRIPTION="GNU readline wrapper"
+HOMEPAGE="http://utopia.knoware.nl/~hlub/uck/rlwrap"
+SRC_URI="http://utopia.knoware.nl/~hlub/uck/rlwrap/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="debug"
+
+DEPEND="sys-libs/readline"
+RDEPEND="sys-libs/readline"
+
+src_compile() {
+ econf $(use_enable debug)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README
+}