summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-10-26 17:22:44 +0000
committerMichael Weber <xmw@gentoo.org>2010-10-26 17:22:44 +0000
commit2518bd3973c27eb2a35bb886c76ebe7e3ee55f20 (patch)
tree3da17e7033961aeb5d5116045a07bfc8d557f9dd /app-misc/specto/specto-0.3.1.ebuild
parentUpdated zipcode. Clean up ebuild. (diff)
downloadgentoo-2-2518bd3973c27eb2a35bb886c76ebe7e3ee55f20.tar.gz
gentoo-2-2518bd3973c27eb2a35bb886c76ebe7e3ee55f20.tar.bz2
gentoo-2-2518bd3973c27eb2a35bb886c76ebe7e3ee55f20.zip
Initial import
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/specto/specto-0.3.1.ebuild')
-rw-r--r--app-misc/specto/specto-0.3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/specto/specto-0.3.1.ebuild b/app-misc/specto/specto-0.3.1.ebuild
new file mode 100644
index 000000000000..fe8b49f4cdf3
--- /dev/null
+++ b/app-misc/specto/specto-0.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/specto/specto-0.3.1.ebuild,v 1.1 2010/10/26 17:22:44 xmw Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="2"
+PYTHON_MODNAME="spectlib"
+
+inherit distutils eutils
+
+DESCRIPTION="watch configurable events and trigger notifications"
+HOMEPAGE="http://specto.sourceforge.net/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_cs linguas_de linguas_es linguas_fr linguas_it
+ linguas_pt_BR linguas_ro linguas_sv linguas_tr"
+
+RDEPEND="dev-python/gconf-python
+ dev-python/dbus-python
+ dev-python/notify-python
+ >=dev-python/pygtk-2.10"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-icon-theme.patch
+
+ sed -e "s:share/doc/specto:share/doc/${PF}:" \
+ -i setup.py spectlib/util.py || die
+
+ sed -e "/^i18n_languages = /s: = .*: = \"${LINGUAS}\":" \
+ -i setup.py || die
+}