summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-02-07 19:19:07 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-02-07 19:19:07 +0000
commitbb6838aa1d995914fef9932ae53598a214312de2 (patch)
tree88ccaec7c39abe71316f758644d5d73d28497887 /app-misc/strigi
parentstable amd64, bug 256746 (diff)
downloadgentoo-2-bb6838aa1d995914fef9932ae53598a214312de2.tar.gz
gentoo-2-bb6838aa1d995914fef9932ae53598a214312de2.tar.bz2
gentoo-2-bb6838aa1d995914fef9932ae53598a214312de2.zip
Cleanup. Strigi doenst support sqlite anymore
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/strigi')
-rw-r--r--app-misc/strigi/ChangeLog6
-rw-r--r--app-misc/strigi/strigi-0.6.3.ebuild93
-rw-r--r--app-misc/strigi/strigi-0.6.4.ebuild8
3 files changed, 8 insertions, 99 deletions
diff --git a/app-misc/strigi/ChangeLog b/app-misc/strigi/ChangeLog
index 3b03bdd7ef7a..bdd30d3eed08 100644
--- a/app-misc/strigi/ChangeLog
+++ b/app-misc/strigi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/strigi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.23 2009/02/02 22:17:50 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.24 2009/02/07 19:19:07 alexxy Exp $
+
+ 07 Feb 2009; Alexey Shvetsov <alexxy@gentoo.org> -strigi-0.6.3.ebuild,
+ strigi-0.6.4.ebuild:
+ Cleanup. Strigi doenst support sqlite anymore
*strigi-0.6.4 (02 Feb 2009)
diff --git a/app-misc/strigi/strigi-0.6.3.ebuild b/app-misc/strigi/strigi-0.6.3.ebuild
deleted file mode 100644
index 5c4e1c4ef130..000000000000
--- a/app-misc/strigi/strigi-0.6.3.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/strigi-0.6.3.ebuild,v 1.3 2009/02/01 23:00:48 jmbsvicetto Exp $
-
-EAPI="2"
-
-inherit cmake-utils eutils
-
-DESCRIPTION="Fast crawling desktop search engine with Qt4 GUI"
-HOMEPAGE="http://www.vandenoever.info/software/strigi"
-SRC_URI="http://www.vandenoever.info/software/strigi/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="+clucene +dbus debug exif fam hyperestraier inotify log +qt4 test"
-
-COMMONDEPEND="
- dev-libs/libxml2
- virtual/libiconv
- clucene? ( >=dev-cpp/clucene-0.9.19 )
- dbus? ( sys-apps/dbus
- || ( ( x11-libs/qt-dbus:4
- x11-libs/qt-gui:4 )
- =x11-libs/qt-4.3*:4[dbus] )
- )
- exif? ( >=media-gfx/exiv2-0.17 )
- fam? ( virtual/fam )
- hyperestraier? ( app-text/hyperestraier )
- log? ( >=dev-libs/log4cxx-0.9.7 )
- qt4? (
- || ( ( x11-libs/qt-core:4
- x11-libs/qt-gui:4
- x11-libs/qt-dbus:4 )
- =x11-libs/qt-4.3*:4[dbus] )
- )
- !clucene? (
- !hyperestraier? (
- >=dev-cpp/clucene-0.9.19
- )
- )
-"
-# sqlite? ( dev-db/sqlite:3 )"
-DEPEND="${COMMONDEPEND}
- test? ( dev-util/cppunit )"
-RDEPEND="${COMMONDEPEND}"
-
-src_compile() {
- # Strigi needs either expat or libxml2.
- # However libxml2 seems to be required in both cases, linking to 2 xml parsers
- # is just silly, so we forcefully disable linking to expat.
- # Enabled: POLLING (only reliable way to check for files changed.)
-
- mycmakeargs="${mycmakeargs}
- -DENABLE_EXPAT=OFF -DENABLE_POLLING=ON
- -DFORCE_DEPS=ON -DENABLE_CPPUNIT=OFF
- -DENABLE_REGENERATEXSD=OFF
- $(cmake-utils_use_enable clucene CLUCENE)
- $(cmake-utils_use_enable dbus DBUS)
- $(cmake-utils_use_enable exif EXIV2)
- $(cmake-utils_use_enable fam FAM)
- $(cmake-utils_use_enable hyperestraier HYPERESTRAIER)
- $(cmake-utils_use_enable inotify INOTIFY)
- $(cmake-utils_use_enable log LOG4CXX)
- $(cmake-utils_use_enable qt4 DBUS)
- $(cmake-utils_use_enable qt4 QT4)"
-# $(cmake-utils_use_enable sqlite SQLITE)"
-
- if ! use clucene && ! use hyperestraier; then # && ! use sqlite; then
- mycmakeargs="${mycmakeargs} -DENABLE_CLUCENE=ON"
- fi
-
- cmake-utils_src_compile
-}
-
-src_test() {
- mycmakeargs="${mycmakeargs} -DENABLE_CPPUNIT=ON"
- cmake-utils_src_compile
-
- pushd "${WORKDIR}/${PN}_build"
- ctest --extra-verbose || die "Tests failed."
- popd
-}
-
-pkg_postinst() {
- if ! use clucene && ! use hyperestraier; then # && ! use sqlite; then
- elog "Because you didn't enable any of the supported backends:"
- elog "clucene, hyperestraier and sqlite"
- elog "clucene support was silently installed."
- elog "If you prefer another backend, be sure to reinstall strigi"
- elog "and to enable that backend use flag"
- fi
-}
diff --git a/app-misc/strigi/strigi-0.6.4.ebuild b/app-misc/strigi/strigi-0.6.4.ebuild
index f3cdb6b4f32e..7e3c2f2c5cc7 100644
--- a/app-misc/strigi/strigi-0.6.4.ebuild
+++ b/app-misc/strigi/strigi-0.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/strigi-0.6.4.ebuild,v 1.1 2009/02/02 22:17:50 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/strigi-0.6.4.ebuild,v 1.2 2009/02/07 19:19:07 alexxy Exp $
EAPI="2"
@@ -40,7 +40,6 @@ COMMONDEPEND="
)
)
"
-# sqlite? ( dev-db/sqlite:3 )"
DEPEND="${COMMONDEPEND}
test? ( dev-util/cppunit )"
RDEPEND="${COMMONDEPEND}"
@@ -64,9 +63,8 @@ src_compile() {
$(cmake-utils_use_enable log LOG4CXX)
$(cmake-utils_use_enable qt4 DBUS)
$(cmake-utils_use_enable qt4 QT4)"
-# $(cmake-utils_use_enable sqlite SQLITE)"
- if ! use clucene && ! use hyperestraier; then # && ! use sqlite; then
+ if ! use clucene && ! use hyperestraier; then
mycmakeargs="${mycmakeargs} -DENABLE_CLUCENE=ON"
fi
@@ -83,7 +81,7 @@ src_test() {
}
pkg_postinst() {
- if ! use clucene && ! use hyperestraier; then # && ! use sqlite; then
+ if ! use clucene && ! use hyperestraier; then
elog "Because you didn't enable any of the supported backends:"
elog "clucene, hyperestraier and sqlite"
elog "clucene support was silently installed."