summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-12-11 08:36:49 +0000
committerPeter Volkov <pva@gentoo.org>2007-12-11 08:36:49 +0000
commit4863821f81e6975be000be16e629df87143a43f6 (patch)
tree0d0151d89348f387f0a4591c5ff22d3970410c98 /app-misc/symlinks
parentset VARTEXFONTS, so we avoid access violations with sandbox. Suggested by And... (diff)
downloadgentoo-2-4863821f81e6975be000be16e629df87143a43f6.tar.gz
gentoo-2-4863821f81e6975be000be16e629df87143a43f6.tar.bz2
gentoo-2-4863821f81e6975be000be16e629df87143a43f6.zip
Fixed QA warning about implicit declarations, bug #201837. Thank Thomas A. (Arch Tester) <gentoofan23 AT gmail.com> for report and fix.
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-misc/symlinks')
-rw-r--r--app-misc/symlinks/ChangeLog8
-rw-r--r--app-misc/symlinks/files/symlinks-1.2-fix-implicit-declaration.patch11
-rw-r--r--app-misc/symlinks/symlinks-1.2-r2.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/app-misc/symlinks/ChangeLog b/app-misc/symlinks/ChangeLog
index c30980704b4d..1d9557afd6f4 100644
--- a/app-misc/symlinks/ChangeLog
+++ b/app-misc/symlinks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/symlinks
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/symlinks/ChangeLog,v 1.16 2007/12/10 17:20:55 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/symlinks/ChangeLog,v 1.17 2007/12/11 08:36:49 pva Exp $
+
+ 11 Dec 2007; <pva@gentoo.org>
+ +files/symlinks-1.2-fix-implicit-declaration.patch,
+ symlinks-1.2-r2.ebuild:
+ Fixed QA warning about implicit declarations, bug #201837. Thank Thomas A.
+ (Arch Tester) <gentoofan23 AT gmail.com> for report and fix.
10 Dec 2007; Raúl Porcel <armin76@gentoo.org> symlinks-1.2-r2.ebuild:
alpha/ia64/sparc stable wrt #201837
diff --git a/app-misc/symlinks/files/symlinks-1.2-fix-implicit-declaration.patch b/app-misc/symlinks/files/symlinks-1.2-fix-implicit-declaration.patch
new file mode 100644
index 000000000000..a5e9b0d6314a
--- /dev/null
+++ b/app-misc/symlinks/files/symlinks-1.2-fix-implicit-declaration.patch
@@ -0,0 +1,11 @@
+diff -Naur symlinks-1.2-orig/symlinks.c symlinks-1.2/symlinks.c
+--- symlinks-1.2-orig/symlinks.c 1996-10-15 15:02:57.000000000 -0400
++++ symlinks-1.2/symlinks.c 2007-12-10 18:08:43.000000000 -0500
+@@ -3,6 +3,7 @@
+ #define _POSIX_SOURCE
+ #endif
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <malloc.h>
+ #include <string.h>
+ #include <fcntl.h>
diff --git a/app-misc/symlinks/symlinks-1.2-r2.ebuild b/app-misc/symlinks/symlinks-1.2-r2.ebuild
index 74c5038ef813..94b03630005a 100644
--- a/app-misc/symlinks/symlinks-1.2-r2.ebuild
+++ b/app-misc/symlinks/symlinks-1.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/symlinks/symlinks-1.2-r2.ebuild,v 1.3 2007/12/10 17:20:55 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/symlinks/symlinks-1.2-r2.ebuild,v 1.4 2007/12/11 08:36:49 pva Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -19,6 +19,7 @@ src_unpack() {
# bugfixes from the debian project.
epatch "${DISTDIR}"/${P/-/_}-4.1.diff.gz
+ epatch "${FILESDIR}"/${P}-fix-implicit-declaration.patch
}
src_compile() {