summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2004-03-16 22:36:10 +0000
committerMichael Cummings <mcummings@gentoo.org>2004-03-16 22:36:10 +0000
commit72d1db7850974287d6a26b1ed38af4c66dd23fc4 (patch)
tree85460ad461b955db933314f74f2b474294c149f5 /app-misc/tinyca/tinyca-0.5.4-r1.ebuild
parentglibc fails to link properly with global LDFLAGS=-pie so we filter it with ne... (diff)
downloadgentoo-2-72d1db7850974287d6a26b1ed38af4c66dd23fc4.tar.gz
gentoo-2-72d1db7850974287d6a26b1ed38af4c66dd23fc4.tar.bz2
gentoo-2-72d1db7850974287d6a26b1ed38af4c66dd23fc4.zip
Missing dependancy.
Diffstat (limited to 'app-misc/tinyca/tinyca-0.5.4-r1.ebuild')
-rw-r--r--app-misc/tinyca/tinyca-0.5.4-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/tinyca/tinyca-0.5.4-r1.ebuild b/app-misc/tinyca/tinyca-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..198d128388ce
--- /dev/null
+++ b/app-misc/tinyca/tinyca-0.5.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tinyca/tinyca-0.5.4-r1.ebuild,v 1.1 2004/03/16 22:36:10 mcummings Exp $
+
+DESCRIPTION="Simple Perl/Tk GUI to manage a small certification authority"
+HOMEPAGE="http://tinyca.sm-zone.net/"
+SRC_URI="http://tinyca.sm-zone.net/${P}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=dev-libs/openssl-0.9.6i
+ dev-perl/Locale-gettext
+ >=dev-perl/MIME-Base64-2.12
+ dev-perl/gtk-perl
+ >=dev-perl/perl-tk-800.024"
+
+S=${WORKDIR}/TinyCA
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # this app was written to be run from cwd and not meant to be installed
+ # this little hack fixes that... pretty silly if you ask me
+ sed -i \
+ -e "s:\./lib:/usr/share/tinyca/lib:" \
+ -e "s:\./template:/usr/share/tinyca/template:" \
+ tinyca
+}
+
+src_install() {
+ dodir /usr/bin
+ exeinto /usr/share/tinyca/
+ doexe tinyca
+ dosym /usr/share/tinyca/tinyca /usr/bin/tinyca
+ insinto /usr/share/tinyca/lib
+ doins lib/*
+ insinto /usr/share/tinyca/templates
+ doins templates/*
+}