summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-07-13 17:53:50 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-07-13 17:53:50 +0000
commit9321a72fc22d49d3a380df5a0c7938e7dca02f10 (patch)
tree36fadf53a70d6b7c8560c86ceacad493afc38c3b /app-misc/towitoko/towitoko-2.0.7-r1.ebuild
parentadded ~ppc (Manifest recommit) (diff)
downloadgentoo-2-9321a72fc22d49d3a380df5a0c7938e7dca02f10.tar.gz
gentoo-2-9321a72fc22d49d3a380df5a0c7938e7dca02f10.tar.bz2
gentoo-2-9321a72fc22d49d3a380df5a0c7938e7dca02f10.zip
add use flag for moneyplex to enable usage of libtowitoko with moneyplex software from matrica.de. Thanks to: Diego Garcia <diego@envigo.net> in bug #40611
Diffstat (limited to 'app-misc/towitoko/towitoko-2.0.7-r1.ebuild')
-rw-r--r--app-misc/towitoko/towitoko-2.0.7-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/towitoko/towitoko-2.0.7-r1.ebuild b/app-misc/towitoko/towitoko-2.0.7-r1.ebuild
new file mode 100644
index 000000000000..8d20ef96cd9d
--- /dev/null
+++ b/app-misc/towitoko/towitoko-2.0.7-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/towitoko/towitoko-2.0.7-r1.ebuild,v 1.1 2004/07/13 17:53:50 seemant Exp $
+
+IUSE="static moneyplex"
+
+DESCRIPTION="This library provides a driver for using Towitoko smartcard readers under UNIX environment."
+SRC_URI="http://www.geocities.com/cprados/files/${P}.tar.gz"
+HOMEPAGE="http://www.geocities.com/cprados/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile() {
+ local myconf
+
+ myconf="--enable-devfs"
+ use moneyplex && myconf="${myconf} --disable-atr-check"
+
+ econf \
+ `use_enable static` \
+ `use_enable moneyplex win32-com` \
+ ${myconf} || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+}
+
+pkg_postinst() {
+ if ! use moneyplex
+ then
+ einfo "If you want to use the moneyplex home banking software from"
+ einfo "http://www.matrica.de"
+ einfo "then please re-emerge this package with 'moneyplex' in USE"
+ fi
+}