summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2013-02-06 12:17:52 +0000
committerAlex Alexander <wired@gentoo.org>2013-02-06 12:17:52 +0000
commit027e90efce7e4c66f23cb1dd26ce44782d65ffa8 (patch)
treebcf1a07dc91e03cf379a7b1005c6da4186b7eae7 /app-misc
parentversion bump, merged vim-* USE flags, used vim-plugin eclass for proper plugi... (diff)
downloadgentoo-2-027e90efce7e4c66f23cb1dd26ce44782d65ffa8.tar.gz
gentoo-2-027e90efce7e4c66f23cb1dd26ce44782d65ffa8.tar.bz2
gentoo-2-027e90efce7e4c66f23cb1dd26ce44782d65ffa8.zip
reworked 0.7.4b ebuild to not use vim-plugin, because the eclass hardcoded vim in DEPEND. switched back to two USE flags as a result, used vim-doc eclass to auto-register vim-compatible documentation.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key EB9B4AFA)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/vifm/ChangeLog10
-rw-r--r--app-misc/vifm/metadata.xml2
-rw-r--r--app-misc/vifm/vifm-0.7.4b-r1.ebuild79
-rw-r--r--app-misc/vifm/vifm-0.7.4b.ebuild54
4 files changed, 89 insertions, 56 deletions
diff --git a/app-misc/vifm/ChangeLog b/app-misc/vifm/ChangeLog
index 32ce0bd91edf..09fd7d3b410f 100644
--- a/app-misc/vifm/ChangeLog
+++ b/app-misc/vifm/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/vifm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/vifm/ChangeLog,v 1.27 2013/02/06 11:54:36 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/vifm/ChangeLog,v 1.28 2013/02/06 12:17:52 wired Exp $
+
+*vifm-0.7.4b-r1 (06 Feb 2013)
+
+ 06 Feb 2013; Alex Alexander <wired@gentoo.org> -vifm-0.7.4b.ebuild,
+ +vifm-0.7.4b-r1.ebuild, metadata.xml:
+ reworked 0.7.4b ebuild to not use vim-plugin, because the eclass hardcoded
+ vim in DEPEND. switched back to two USE flags as a result, used vim-doc
+ eclass to auto-register vim-compatible documentation.
*vifm-0.7.4b (06 Feb 2013)
diff --git a/app-misc/vifm/metadata.xml b/app-misc/vifm/metadata.xml
index 5d50cb372497..acba9d310918 100644
--- a/app-misc/vifm/metadata.xml
+++ b/app-misc/vifm/metadata.xml
@@ -10,7 +10,7 @@
<flag name="extended-keys">Support for extended keys (arrows, home etc)</flag>
<flag name="gtk">Use gtk+ to determine mimetypes</flag>
<flag name="magic">Use libmagic to determine mimetypes</flag>
- <flag name="vim">Install the vifm vim plugin, documentation and syntax</flag>
+ <flag name="vim">Install the vifm vim plugin and vim-compatible documentation</flag>
<flag name="vim-plugin">Install the vifm vim plugin</flag>
</use>
<longdescription>
diff --git a/app-misc/vifm/vifm-0.7.4b-r1.ebuild b/app-misc/vifm/vifm-0.7.4b-r1.ebuild
new file mode 100644
index 000000000000..81c4176ebabb
--- /dev/null
+++ b/app-misc/vifm/vifm-0.7.4b-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/vifm/vifm-0.7.4b-r1.ebuild,v 1.1 2013/02/06 12:17:52 wired Exp $
+
+EAPI=5
+inherit base vim-doc
+
+DESCRIPTION="Console file manager with vi(m)-like keybindings"
+HOMEPAGE="http://vifm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vifm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+IUSE="X +extended-keys gtk +magic vim vim-syntax"
+
+DEPEND="
+ >=sys-libs/ncurses-5.7-r7
+ magic? ( sys-apps/file )
+ gtk? ( x11-libs/gtk+:2 )
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="
+ ${DEPEND}
+ vim? ( || ( app-editors/vim app-editors/gvim ) )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+"
+
+DOCS=( AUTHORS TODO README )
+
+src_configure() {
+ econf \
+ $(use_enable extended-keys) \
+ $(use_with magic libmagic) \
+ $(use_with gtk) \
+ $(use_with X X11)
+}
+
+src_install() {
+ base_src_install
+
+ if use vim; then
+ local t
+ for t in doc plugin; do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins "${S}"/data/vim/"${t}"/"${PN}".*
+ done
+ fi
+
+ if use vim-syntax; then
+ local t
+ for t in ftdetect ftplugin syntax; do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins "${S}"/data/vim/"${t}"/"${PN}".vim
+ done
+ fi
+}
+
+pkg_postinst() {
+ if use vim; then
+ update_vim_helptags
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "You don't need to copy or link any files for"
+ elog " the vim plugin and documentation to work anymore."
+ elog "If you copied any vifm files to ~/.vim/ manually"
+ elog " in earlier vifm versions, please delete them."
+ fi
+ elog
+ elog "To use vim in vifm to view the documentation"
+ elog " edit ~/.vifm/vifmrc and set vimhelp instead of novimhelp"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ use vim && update_vim_helptags
+}
diff --git a/app-misc/vifm/vifm-0.7.4b.ebuild b/app-misc/vifm/vifm-0.7.4b.ebuild
deleted file mode 100644
index 6db53d1ca50b..000000000000
--- a/app-misc/vifm/vifm-0.7.4b.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/vifm/vifm-0.7.4b.ebuild,v 1.1 2013/02/06 11:54:36 wired Exp $
-
-EAPI=5
-inherit base vim-plugin
-
-DESCRIPTION="Console file manager with vi(m)-like keybindings"
-HOMEPAGE="http://vifm.sourceforge.net/"
-SRC_URI="mirror://sourceforge/vifm/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~s390 ~x86"
-IUSE="X +extended-keys gtk +magic vim"
-
-DEPEND="
- >=sys-libs/ncurses-5.7-r7
- magic? ( sys-apps/file )
- gtk? ( x11-libs/gtk+:2 )
- X? ( x11-libs/libX11 )
-"
-RDEPEND="
- ${DEPEND}
-"
-
-DOCS=( AUTHORS TODO README )
-
-src_configure() {
- econf \
- $(use_enable extended-keys) \
- $(use_with magic libmagic) \
- $(use_with gtk) \
- $(use_with X X11)
-}
-
-src_install() {
- base_src_install
-
- if use vim; then
- local s="${S}"
- S="${S}"/data/vim/
- vim-plugin_src_install
- S="${s}"
- fi
-}
-
-pkg_postinst() {
- use vim && vim-plugin_pkg_postinst
-}
-
-pkg_postrm() {
- use vim && vim-plugin_pkg_postrm
-}