summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-10-06 17:58:26 +0000
committerPacho Ramos <pacho@gentoo.org>2010-10-06 17:58:26 +0000
commit396d1429f67f0d3037ab68c4f52e40bf18619865 (patch)
tree9cbfe1b50c0be3ff2120ea9aefcb04f5f329483a /app-misc
parentRevision bump to create a revision ready for stabilization without ruby19. (diff)
downloadgentoo-2-396d1429f67f0d3037ab68c4f52e40bf18619865.tar.gz
gentoo-2-396d1429f67f0d3037ab68c4f52e40bf18619865.tar.bz2
gentoo-2-396d1429f67f0d3037ab68c4f52e40bf18619865.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/workrave/ChangeLog11
-rw-r--r--app-misc/workrave/workrave-1.9.2.ebuild70
2 files changed, 80 insertions, 1 deletions
diff --git a/app-misc/workrave/ChangeLog b/app-misc/workrave/ChangeLog
index 7d145bb74e8c..47c3d74dc7be 100644
--- a/app-misc/workrave/ChangeLog
+++ b/app-misc/workrave/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-misc/workrave
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/workrave/ChangeLog,v 1.67 2010/07/09 09:13:18 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/workrave/ChangeLog,v 1.68 2010/10/06 17:58:26 pacho Exp $
+
+*workrave-1.9.2 (06 Oct 2010)
+
+ 06 Oct 2010; Pacho Ramos <pacho@gentoo.org> +workrave-1.9.2.ebuild:
+ Version bump (bug #339088 by Johannes Rauh): Workrave can now mute all
+ audio during breaks (requires pulseaudio), now properly remembers the
+ Window hide/show notification icon settings, the activity insensitive
+ breaks have been replaced by a 'reading mode', many bug fixes and updated
+ tranlations.
09 Jul 2010; Pacho Ramos <pacho@gentoo.org>
-files/workrave-1.8.4-nls_macros.patch, -workrave-1.8.5.ebuild,
diff --git a/app-misc/workrave/workrave-1.9.2.ebuild b/app-misc/workrave/workrave-1.9.2.ebuild
new file mode 100644
index 000000000000..f6d1a7213103
--- /dev/null
+++ b/app-misc/workrave/workrave-1.9.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/workrave/workrave-1.9.2.ebuild,v 1.1 2010/10/06 17:58:26 pacho Exp $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+DESCRIPTION="Helpful utility to attack Repetitive Strain Injury (RSI)"
+HOMEPAGE="http://www.workrave.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus doc distribution gnome gstreamer nls pulseaudio test xml"
+
+RDEPEND=">=dev-libs/glib-2.10
+ >=gnome-base/gconf-2
+ >=x11-libs/gtk+-2.8
+ >=dev-cpp/gtkmm-2.10
+ >=dev-cpp/glibmm-2.10
+ >=dev-libs/libsigc++-2
+ dbus? (
+ >=sys-apps/dbus-1.2
+ dev-libs/dbus-glib )
+ distribution? ( >=net-libs/gnet-2 )
+ gnome? (
+ >=gnome-base/gnome-panel-2.0.10
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2.8.3 )
+ gstreamer? (
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-base-0.10 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.15 )
+ xml? ( dev-libs/gdome2 )
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/libXt
+ x11-libs/libXmu"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/recordproto
+ dev-python/cheetah
+ >=dev-util/pkgconfig-0.9
+ doc? (
+ app-text/docbook-sgml-utils
+ app-text/xmlto )
+ nls? ( sys-devel/gettext )"
+
+DOCS="AUTHORS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --without-arts
+ --disable-kde
+ --enable-gconf
+ $(use_enable dbus)
+ $(use_enable doc manual)
+ $(use_enable distribution)
+ $(use_enable gnome)
+ $(use_enable gstreamer)
+ $(use_enable nls)
+ $(use_enable pulseaudio pulse)
+ $(use_enable test tests)
+ $(use_enable xml)"
+}