summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-02-16 12:02:57 +0000
committerPacho Ramos <pacho@gentoo.org>2013-02-16 12:02:57 +0000
commit925769269e2af028303614ec43d10fb3fae429ce (patch)
treeeb30f4ff8a4e2609d0cb8a4a6d5fb95e3ae43dbd /app-misc
parentVersion bump. The new version fixes portage dependency parsing and package li... (diff)
downloadgentoo-2-925769269e2af028303614ec43d10fb3fae429ce.tar.gz
gentoo-2-925769269e2af028303614ec43d10fb3fae429ce.tar.bz2
gentoo-2-925769269e2af028303614ec43d10fb3fae429ce.zip
Don't show elog messages always (#457596)
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/recoll/ChangeLog5
-rw-r--r--app-misc/recoll/recoll-1.18.1.ebuild34
2 files changed, 24 insertions, 15 deletions
diff --git a/app-misc/recoll/ChangeLog b/app-misc/recoll/ChangeLog
index 634be51f6122..e70f86374850 100644
--- a/app-misc/recoll/ChangeLog
+++ b/app-misc/recoll/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-misc/recoll
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/recoll/ChangeLog,v 1.16 2013/02/15 22:10:24 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/recoll/ChangeLog,v 1.17 2013/02/16 12:02:57 pacho Exp $
+
+ 16 Feb 2013; Pacho Ramos <pacho@gentoo.org> recoll-1.18.1.ebuild:
+ Don't show elog messages always (#457596)
15 Feb 2013; Markos Chandras <hwoarang@gentoo.org> recoll-1.16.2.ebuild,
recoll-1.17.3-r1.ebuild, recoll-1.17.3.ebuild, recoll-1.18.1.ebuild:
diff --git a/app-misc/recoll/recoll-1.18.1.ebuild b/app-misc/recoll/recoll-1.18.1.ebuild
index 2790c0f6dd39..f32400228c56 100644
--- a/app-misc/recoll/recoll-1.18.1.ebuild
+++ b/app-misc/recoll/recoll-1.18.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/recoll/recoll-1.18.1.ebuild,v 1.3 2013/02/15 22:10:24 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/recoll/recoll-1.18.1.ebuild,v 1.4 2013/02/16 12:02:57 pacho Exp $
EAPI="4"
PYTHON_DEPEND="2"
-inherit toolchain-funcs qt4-r2 linux-info python
+inherit toolchain-funcs qt4-r2 linux-info python readme.gentoo
DESCRIPTION="A personal full text search package"
HOMEPAGE="http://www.lesbonscomptes.com/recoll/"
@@ -87,6 +87,20 @@ pkg_setup() {
}
src_prepare() {
+ use xattr && has_version "${CATEGORY}/${PN}:${SLOT}[-xattr]" && FORCE_PRINT_ELOG="yes"
+ ! use xattr && has_version "${CATEGORY}/${PN}:${SLOT}[xattr]" && FORCE_PRINT_ELOG="yes"
+
+ DOC_CONTENTS="Default configuration files located at
+ /usr/share/${PN}/examples. Either edit these files to match
+ your needs or copy them to ~/.recoll/ and edit these files
+ instead."
+
+ use xattr && DOC_CONTENTS+="
+ Use flag \"xattr\" enables support for fetching field values
+ from extended file attributes. You will also need to set up a
+ map from the attributes names to the Recoll field names
+ (see comment at the end of the fields configuration file."
+
# remember configure.ac is b0rked. Fix it before using eautoreconf in the
# future
# eautoreconf
@@ -143,21 +157,13 @@ src_install() {
dodoc ChangeLog README
mv "${D}/usr/share/${PN}/doc" "${D}/usr/share/doc/${PF}/html"
dosym /usr/share/doc/${PF}/html /usr/share/${PN}/doc
+
+ readme.gentoo_create_doc
}
pkg_postinst() {
- elog
- elog "Default configuration files located at"
- elog "/usr/share/${PN}/examples. Either edit these files to match"
- elog "your needs or copy them to ~/.recoll/ and edit these files"
- elog "instead."
- elog
- if use xattr; then
- elog "Use flag \"xattr\" enables support for fetching field values"
- elog "from extended file attributes. You will also need to set up a"
- elog "map from the attributes names to the Recoll field names"
- elog "(see comment at the end of the fields configuration file."
- fi
+ readme.gentoo_print_elog
+
if [[ -n ${REPLACING_VERSIONS} ]]; then
elog
elog "1.18 introduces significant index formats"