summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2012-05-10 10:13:40 +0000
committerHanno Böck <hanno@gentoo.org>2012-05-10 10:13:40 +0000
commitfcd75e115955802296a5b1342af547ae2fada615 (patch)
tree8b991cc9c5d3a14fe2f118ae4bc03171f81261c5 /app-misc
parentDepend on correct slot of gucharmap (bug #415315, thanks to Kris Hepler). (diff)
downloadgentoo-2-fcd75e115955802296a5b1342af547ae2fada615.tar.gz
gentoo-2-fcd75e115955802296a5b1342af547ae2fada615.tar.bz2
gentoo-2-fcd75e115955802296a5b1342af547ae2fada615.zip
app-misc/ktoblzcheck: Version bump.
(Portage version: 2.1.10.58/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ktoblzcheck/ChangeLog7
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.38.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/app-misc/ktoblzcheck/ChangeLog b/app-misc/ktoblzcheck/ChangeLog
index 77ef76b0b21b..7161056d08f1 100644
--- a/app-misc/ktoblzcheck/ChangeLog
+++ b/app-misc/ktoblzcheck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/ktoblzcheck
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.79 2012/01/21 16:11:42 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.80 2012/05/10 10:13:40 hanno Exp $
+
+*ktoblzcheck-1.38 (10 May 2012)
+
+ 10 May 2012; Hanno Boeck <hanno@gentoo.org> +ktoblzcheck-1.38.ebuild:
+ Version bump.
21 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ktoblzcheck-1.33.ebuild:
x86 stable wrt bug #397841
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.38.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.38.ebuild
new file mode 100644
index 000000000000..18f58b3554a0
--- /dev/null
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.38.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-1.38.ebuild,v 1.1 2012/05/10 10:13:40 hanno Exp $
+
+EAPI=4
+PYTHON_DEPEND="python? 2:2.6"
+inherit python
+
+DESCRIPTION="Library to check account numbers and bank codes of German banks"
+HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+
+RDEPEND="app-text/recode
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/sed
+ || ( net-misc/wget www-client/lynx )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2.6b"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ >py-compile
+}
+
+src_configure() {
+ econf $(use_enable python)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize ktoblzcheck.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ktoblzcheck.py
+}