summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-09-06 10:28:04 +0000
committerAlin Năstac <mrness@gentoo.org>2007-09-06 10:28:04 +0000
commit7a09f01be95974737980a5b73ff8d2580ec328d8 (patch)
tree539c1d8d19ddedeb0435273716d423c7495bdcee /app-mobilephone
parentVersion bump; fix several buffer overflows (#191303). (diff)
downloadgentoo-2-7a09f01be95974737980a5b73ff8d2580ec328d8.tar.gz
gentoo-2-7a09f01be95974737980a5b73ff8d2580ec328d8.tar.bz2
gentoo-2-7a09f01be95974737980a5b73ff8d2580ec328d8.zip
Select wxpython 2.6 in case there are others available (#191304).
(Portage version: 2.1.2.12)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/wammu/ChangeLog8
-rw-r--r--app-mobilephone/wammu/files/digest-wammu-0.21-r13
-rw-r--r--app-mobilephone/wammu/files/wammu-wxversion-2.6.patch11
-rw-r--r--app-mobilephone/wammu/wammu-0.21-r1.ebuild55
4 files changed, 76 insertions, 1 deletions
diff --git a/app-mobilephone/wammu/ChangeLog b/app-mobilephone/wammu/ChangeLog
index d9446284322d..70889f9a2bb7 100644
--- a/app-mobilephone/wammu/ChangeLog
+++ b/app-mobilephone/wammu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/wammu
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.22 2007/08/22 07:08:20 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.23 2007/09/06 10:28:04 mrness Exp $
+
+*wammu-0.21-r1 (06 Sep 2007)
+
+ 06 Sep 2007; Alin Năstac <mrness@gentoo.org>
+ +files/wammu-wxversion-2.6.patch, +wammu-0.21-r1.ebuild:
+ Select wxpython 2.6 in case there are others available (#191304).
22 Aug 2007; Christian Faulhammer <opfer@gentoo.org> wammu-0.21.ebuild:
stable x86, bug 139308
diff --git a/app-mobilephone/wammu/files/digest-wammu-0.21-r1 b/app-mobilephone/wammu/files/digest-wammu-0.21-r1
new file mode 100644
index 000000000000..50804bdebaef
--- /dev/null
+++ b/app-mobilephone/wammu/files/digest-wammu-0.21-r1
@@ -0,0 +1,3 @@
+MD5 6bd3fa7e8842a3713d9534ccb1a5d777 wammu-0.21.tar.bz2 278255
+RMD160 2d590c528700c2fa61745b9ddea4f623cbe0899d wammu-0.21.tar.bz2 278255
+SHA256 16c85bfe200afe96b0cbbd093b55c14cd566de86cde550fcf0d22ae07e1bddc1 wammu-0.21.tar.bz2 278255
diff --git a/app-mobilephone/wammu/files/wammu-wxversion-2.6.patch b/app-mobilephone/wammu/files/wammu-wxversion-2.6.patch
new file mode 100644
index 000000000000..6c3f4057fb87
--- /dev/null
+++ b/app-mobilephone/wammu/files/wammu-wxversion-2.6.patch
@@ -0,0 +1,11 @@
+--- wammu.py.old 2007-09-04 22:45:00.000000000 +0200
++++ wammu.py 2007-09-04 22:45:25.000000000 +0200
+@@ -24,6 +24,8 @@
+ 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ '''
+
++import wxversion
++wxversion.select("2.6")
+ import os
+ import sys
+ import getopt
diff --git a/app-mobilephone/wammu/wammu-0.21-r1.ebuild b/app-mobilephone/wammu/wammu-0.21-r1.ebuild
new file mode 100644
index 000000000000..2c55aeeabe80
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.21-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.21-r1.ebuild,v 1.1 2007/09/06 10:28:04 mrness Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="front-end for gammu (Nokia and other mobiles)"
+HOMEPAGE="http://www.cihar.com/gammu/wammu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bluetooth"
+
+#gnome-bluetooth is used for additional functionality - see bug #101067
+RDEPEND=">=dev-python/wxpython-2.6.3.3
+ >=dev-python/python-gammu-0.22
+ bluetooth? (
+ dev-python/pybluez
+ net-wireless/gnome-bluetooth
+ )"
+DEPEND="${RDEPEND}"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" af ca cs de es et fi fr hu it ko nl pl pt_BR ru sk sv zh_CN"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_unpack() {
+ unpack ${A}
+
+ # Select wxpython 2.6 in case there are others available
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-wxversion-2.6.patch
+
+ cd locale || die "locale directory not found"
+ local lang
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm -r ${lang}
+ fi
+ done
+}
+
+src_compile() {
+ # SKIPWXCHECK: else 'import wx' results in
+ # Xlib: connection to ":0.0" refused by server
+ SKIPWXCHECK=yes distutils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS FAQ NEWS"
+ SKIPWXCHECK=yes distutils_src_install
+}