summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-06-27 18:00:39 +0000
committerAlin Năstac <mrness@gentoo.org>2007-06-27 18:00:39 +0000
commit90567156c78787f61dd74c75267cbb80466ece31 (patch)
treeb7de45243055986d41c96af6be3caa9002a2055d /app-mobilephone
parentold (diff)
downloadgentoo-2-90567156c78787f61dd74c75267cbb80466ece31.tar.gz
gentoo-2-90567156c78787f61dd74c75267cbb80466ece31.tar.bz2
gentoo-2-90567156c78787f61dd74c75267cbb80466ece31.zip
Version bump, done by Peter Volkov <pva@gentoo.org> (#183044).
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/gnokii/ChangeLog7
-rw-r--r--app-mobilephone/gnokii/files/digest-gnokii-0.6.173
-rw-r--r--app-mobilephone/gnokii/gnokii-0.6.17.ebuild137
3 files changed, 146 insertions, 1 deletions
diff --git a/app-mobilephone/gnokii/ChangeLog b/app-mobilephone/gnokii/ChangeLog
index 5edf78d2b502..c4abb4f5c612 100644
--- a/app-mobilephone/gnokii/ChangeLog
+++ b/app-mobilephone/gnokii/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/gnokii
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/ChangeLog,v 1.53 2007/05/06 04:52:06 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/ChangeLog,v 1.54 2007/06/27 18:00:39 mrness Exp $
+
+*gnokii-0.6.17 (27 Jun 2007)
+
+ 27 Jun 2007; Alin Năstac <mrness@gentoo.org> +gnokii-0.6.17.ebuild:
+ Version bump, done by Peter Volkov <pva@gentoo.org> (#183044).
06 May 2007; Tobias Scherbaum <dertobi123@gentoo.org>
gnokii-0.6.14-r2.ebuild:
diff --git a/app-mobilephone/gnokii/files/digest-gnokii-0.6.17 b/app-mobilephone/gnokii/files/digest-gnokii-0.6.17
new file mode 100644
index 000000000000..b9f9ac2537ec
--- /dev/null
+++ b/app-mobilephone/gnokii/files/digest-gnokii-0.6.17
@@ -0,0 +1,3 @@
+MD5 42b78d30e9eff4de9cfa20a54ead1818 gnokii-0.6.17.tar.bz2 1739452
+RMD160 ebe140c6f24f18e707fecca426f6069dd3dae9ff gnokii-0.6.17.tar.bz2 1739452
+SHA256 f16ab192c72161f99473f2644e2afa9e31c7702b2544b5595231213e26a90f6c gnokii-0.6.17.tar.bz2 1739452
diff --git a/app-mobilephone/gnokii/gnokii-0.6.17.ebuild b/app-mobilephone/gnokii/gnokii-0.6.17.ebuild
new file mode 100644
index 000000000000..8b311b88781b
--- /dev/null
+++ b/app-mobilephone/gnokii/gnokii-0.6.17.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/gnokii-0.6.17.ebuild,v 1.1 2007/06/27 18:00:39 mrness Exp $
+
+inherit eutils flag-o-matic linux-info
+
+DESCRIPTION="user space driver and tools for use with mobile phones"
+HOMEPAGE="http://www.gnokii.org/"
+SRC_URI="http://www.gnokii.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls bluetooth ical irda sms postgres mysql usb X debug"
+
+RESTRICT="test" #test fails; maybe it will work in the future, but till then...
+
+RDEPEND="X? ( >=x11-libs/gtk+-2.8.19 )
+ bluetooth? ( >=net-wireless/bluez-libs-2.25 )
+ sms? ( >=dev-libs/glib-2.10.3
+ postgres? ( >=dev-db/postgresql-8.0.8 )
+ mysql? ( >=virtual/mysql-4.1 )
+ )
+ ical? ( >=dev-libs/libical-0.26.6 )
+ usb? ( >=dev-libs/libusb-0.1.11 )"
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( >=sys-devel/gettext-0.14.5 )"
+
+CONFIG_CHECK="UNIX98_PTYS"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use sms ; then
+ local MY_SMSD_DB_OBJS="file.lo"
+ local MY_SMSD_DB_LIBS="libfile.la"
+ if use postgres; then
+ MY_SMSD_DB_OBJS="${MY_SMSD_DB_OBJS} pq.lo"
+ MY_SMSD_DB_LIBS="${MY_SMSD_DB_LIBS} libpq.la"
+ fi
+ if use mysql; then
+ MY_SMSD_DB_OBJS="${MY_SMSD_DB_OBJS} mysql.lo"
+ MY_SMSD_DB_LIBS="${MY_SMSD_DB_LIBS} libmysql.la"
+ fi
+
+ sed -i \
+ -e "s/^DB_OBJS.*=.*file[.]lo/DB_OBJS = ${MY_SMSD_DB_OBJS}/" \
+ -e "s/^DB_LIBS.*=.*libfile[.]la/DB_LIBS = ${MY_SMSD_DB_LIBS}/" \
+ -e 's/\(^.*LIBTOOL.*--mode=finish.*$\)/#\1/' \
+ smsd/Makefile
+
+ #Change default database module
+ local MY_DEFAULT_DB_MODULE="file"
+ if use postgres ; then
+ MY_DEFAULT_DB_MODULE="pq"
+ elif use mysql ; then
+ MY_DEFAULT_DB_MODULE="mysql"
+ fi
+ [[ ${MY_DEFAULT_DB_MODULE} == "file" ]] || \
+ sed -i -e "s/\"file\"/\"${MY_DEFAULT_DB_MODULE}\"/" smsd/smsd.c
+ fi
+}
+
+src_compile() {
+ append-flags -fno-strict-aliasing
+ append-ldflags $(bindnow-flags) #avoid QA notices
+
+ config_xdebug="--disable-xdebug"
+ use X && use debug && config_xdebug="--enable-xdebug"
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable ical libical) \
+ $(use_enable usb libusb) \
+ $(use_enable irda) \
+ $(use_enable bluetooth) \
+ $(use_with X x) \
+ $(use_enable debug) \
+ ${config_xdebug} \
+ $(use_enable debug rlpdebug) \
+ --enable-security \
+ --disable-unix98test \
+ || die "configure failed"
+
+ emake -j1 || die "make failed"
+
+ if use sms; then
+ pushd "${S}/smsd"
+ emake || die "smsd make install failed"
+ popd
+ fi
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ if use X; then
+ insinto /usr/share/pixmaps
+ newins Docs/sample/logo/gnokii.xpm xgnokii.xpm
+ fi
+
+ insinto /etc
+ doins Docs/sample/gnokiirc
+ sed -i -e 's:/usr/local:/usr:' "${D}/etc/gnokiirc"
+
+ doman Docs/man/*
+
+ dodir "/usr/share/doc/${PF}"
+ cp -r Docs/sample "${D}/usr/share/doc/${PF}/sample"
+ cp -r Docs/protocol "${D}/usr/share/doc/${PF}/protocol"
+ rm -rf Docs/man Docs/sample Docs/protocol
+ dodoc Docs/* ChangeLog TODO MAINTAINERS
+
+ # only one file needs suid root to make a pseudo device
+ fperms 4755 /usr/sbin/mgnokiidev
+
+ if use sms; then
+ pushd "${S}/smsd"
+ einstall || die "smsd make install failed"
+ insinto /usr/share/doc/${PF}/smsd
+ use mysql && doins sms.tables.mysql.sql README.MySQL
+ use postgres && doins sms.tables.pq.sql
+ doins README ChangeLog README.Tru64 action
+ popd
+ fi
+}
+
+pkg_postinst() {
+ elog "gnokii does not need it's own group anymore."
+ elog "Make sure the user that runs gnokii has read/write access to the device"
+ elog "which your phone is connected to. eg. chown <user> /dev/ttyS0"
+ echo
+ ewarn "We received at least one report of gnokii with usb connection breaking the phone,"
+ ewarn "which was in need to be serviced afterwards. Be careful if you decide to try that..."
+}