summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2011-12-20 23:43:58 +0000
committerJohannes Huber <johu@gentoo.org>2011-12-20 23:43:58 +0000
commita0ee21544e48ea502b749f5303806caef4ce81d7 (patch)
tree96acceba00133fcad4c38f2c2bc299340c716239 /app-office/akonadi-server
parentFixed automagic and jpeg2k support, bug #391797 (diff)
downloadgentoo-2-a0ee21544e48ea502b749f5303806caef4ce81d7.tar.gz
gentoo-2-a0ee21544e48ea502b749f5303806caef4ce81d7.tar.bz2
gentoo-2-a0ee21544e48ea502b749f5303806caef4ce81d7.zip
Remove old. Rev bump fix available driver array fill, bug #395165.
Thanks to jer to show the root path of the solution. (Portage version: 2.2.0_alpha81/cvs/Linux i686)
Diffstat (limited to 'app-office/akonadi-server')
-rw-r--r--app-office/akonadi-server/ChangeLog12
-rw-r--r--app-office/akonadi-server/akonadi-server-1.3.1.ebuild77
-rw-r--r--app-office/akonadi-server/akonadi-server-1.5.2-r1.ebuild102
-rw-r--r--app-office/akonadi-server/akonadi-server-1.6.2-r1.ebuild102
-rw-r--r--app-office/akonadi-server/files/akonadi-server-1.6.0_Fix_crash_on_agent_launcher_exit.patch64
-rw-r--r--app-office/akonadi-server/metadata.xml3
6 files changed, 215 insertions, 145 deletions
diff --git a/app-office/akonadi-server/ChangeLog b/app-office/akonadi-server/ChangeLog
index 9217468ea0a6..18af55e5ee27 100644
--- a/app-office/akonadi-server/ChangeLog
+++ b/app-office/akonadi-server/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-office/akonadi-server
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.64 2011/12/07 22:06:37 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.65 2011/12/20 23:43:57 johu Exp $
+
+*akonadi-server-1.6.2-r1 (20 Dec 2011)
+*akonadi-server-1.5.2-r1 (20 Dec 2011)
+
+ 20 Dec 2011; Johannes Huber <johu@gentoo.org> +akonadi-server-1.5.2-r1.ebuild,
+ +akonadi-server-1.6.2-r1.ebuild, -akonadi-server-1.3.1.ebuild,
+ -files/akonadi-server-1.6.0_Fix_crash_on_agent_launcher_exit.patch,
+ metadata.xml:
+ Remove old. Rev bump fix available driver array fill, bug #395165. Thanks to
+ jer to show the root path of the solution.
07 Dec 2011; Markos Chandras <hwoarang@gentoo.org>
akonadi-server-1.6.2.ebuild:
diff --git a/app-office/akonadi-server/akonadi-server-1.3.1.ebuild b/app-office/akonadi-server/akonadi-server-1.3.1.ebuild
deleted file mode 100644
index bbd307d0e697..000000000000
--- a/app-office/akonadi-server/akonadi-server-1.3.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.3.1.ebuild,v 1.12 2011/10/17 17:08:57 jer Exp $
-
-EAPI="2"
-
-inherit cmake-utils
-
-DESCRIPTION="The server part of Akonadi"
-HOMEPAGE="http://pim.kde.org/akonadi"
-SRC_URI="http://download.akonadi-project.org/${P/-server/}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="+mysql postgres sqlite +server"
-
-CDEPEND="
- dev-libs/boost
- >=dev-libs/soprano-2.2
- >=x11-libs/qt-gui-4.5.0:4[dbus]
- >=x11-libs/qt-sql-4.5.0:4[mysql?,postgres?,sqlite?]
- >=x11-libs/qt-test-4.5.0:4
- x11-misc/shared-mime-info
-"
-DEPEND="${CDEPEND}
- dev-libs/libxslt
- >=dev-util/automoc-0.9.88
-"
-RDEPEND="${CDEPEND}
- server? (
- postgres? ( dev-db/postgresql-server )
- )
-"
-
-S="${WORKDIR}/${P/-server/}"
-
-src_install() {
- # Set default storage backend in order: MySQL, PostgreSQL, SQLite
- if use mysql; then
- driver="QMYSQL"
- elif use postgres; then
- driver="QPSQL"
- elif use sqlite; then
- driver="QSQLITE"
- fi
- # Who knows, maybe it accidentally fixes our permission issues
- cat <<-EOF > "${T}"/akonadiserverrc
-[%General]
-Driver=${driver}
-EOF
- insinto /usr/share/config/akonadi
- doins "${T}"/akonadiserverrc || die "doins failed"
-
- cmake-utils_src_install
-}
-
-pkg_postinst() {
- if use mysql || use postgres || use sqlite; then
- local func=elog
- ( use postgres || use sqlite ) && func=ewarn
- echo
- ${func} "${driver} has been set as your default akonadi storage backend."
- ${func} "You can override it in your ~/.config/akonadi/akonadiserverrc."
- ${func} "Available drivers are:"
- ${func} "QMYSQL, QPSQL (testing), QSQLITE (experimental)"
- ${func} "Be advised that QMYSQL is the one fully tested and officially supported."
- use sqlite && ewarn "If you experience random data losses using QSQLITE driver, you have been warned."
- echo
- else
- echo
- ewarn "You have decided to build akonadi-server with"
- ewarn "'mysql', 'postgres' and 'sqlite' USE flags disabled."
- ewarn "akonadi-server will not be functional."
- echo
- fi
-}
diff --git a/app-office/akonadi-server/akonadi-server-1.5.2-r1.ebuild b/app-office/akonadi-server/akonadi-server-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..8ce25e093020
--- /dev/null
+++ b/app-office/akonadi-server/akonadi-server-1.5.2-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.5.2-r1.ebuild,v 1.1 2011/12/20 23:43:57 johu Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="The server part of Akonadi"
+HOMEPAGE="http://pim.kde.org/akonadi"
+SRC_URI="mirror://kde/stable/${PN/-server/}/src/${P/-server/}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="mysql postgres +sqlite test"
+
+CDEPEND="
+ dev-libs/boost
+ >=dev-libs/soprano-2.2
+ >=x11-libs/qt-gui-4.5.0:4[dbus]
+ >=x11-libs/qt-sql-4.5.0:4[mysql?,postgres?]
+ >=x11-libs/qt-test-4.5.0:4
+ x11-misc/shared-mime-info
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt
+ >=dev-util/automoc-0.9.88
+"
+RDEPEND="${CDEPEND}
+ postgres? ( dev-db/postgresql-server )
+"
+
+REQUIRED_USE="|| ( sqlite mysql postgres )"
+
+S=${WORKDIR}/${P/-server/}
+
+pkg_setup() {
+ # Set default storage backend in order: SQLite, MySQL, PostgreSQL
+ # reverse driver check to keep the order
+
+ if use postgres; then
+ DRIVER="QPSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use mysql; then
+ DRIVER="QMYSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use sqlite; then
+ DRIVER="QSQLITE3"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ # Notify about driver name change
+ if use sqlite && has_version "<=${CATEGORY}/${PN}-1.4.0[sqlite]"; then
+ ewarn
+ ewarn "SQLite driver name changed from QSQLITE to QSQLITE3."
+ ewarn "Please edit your ~/.config/akonadi/akonadiserverrc."
+ fi
+
+ # Notify about MySQL not being default anymore
+ if ! use mysql && has_version "<=${CATEGORY}/${PN}-1.4.0[mysql]"; then
+ ewarn
+ ewarn "MySQL driver is not enabled by default in Gentoo anymore."
+ ewarn "If you intend to use it, please enable mysql USE flag and reinstall"
+ ewarn "${CATEGORY}/${PN}."
+ ewarn "Otherwise select different driver in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "Available drivers are:${AVAILABLE}"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DAKONADI_USE_STRIGI_SEARCH=OFF"
+ $(cmake-utils_use test AKONADI_BUILD_TESTS)
+ $(cmake-utils_use sqlite INSTALL_QSQLITE_IN_QT_PREFIX)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ # Who knows, maybe it accidentally fixes our permission issues
+ cat <<-EOF > "${T}"/akonadiserverrc
+[%General]
+Driver=${DRIVER}
+EOF
+ insinto /usr/share/config/akonadi
+ doins "${T}"/akonadiserverrc
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ echo
+ elog "${DRIVER} has been set as your default akonadi storage backend."
+ elog "You can override it in your ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are: ${AVAILABLE}"
+}
diff --git a/app-office/akonadi-server/akonadi-server-1.6.2-r1.ebuild b/app-office/akonadi-server/akonadi-server-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..84d57aa61941
--- /dev/null
+++ b/app-office/akonadi-server/akonadi-server-1.6.2-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.6.2-r1.ebuild,v 1.1 2011/12/20 23:43:57 johu Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="The server part of Akonadi"
+HOMEPAGE="http://pim.kde.org/akonadi"
+SRC_URI="mirror://kde/stable/${PN/-server/}/src/${P/-server/}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="mysql postgres +sqlite test"
+
+CDEPEND="
+ dev-libs/boost
+ >=dev-libs/soprano-2.6.51
+ >=x11-libs/qt-gui-4.5.0:4[dbus]
+ >=x11-libs/qt-sql-4.5.0:4[mysql?,postgres?]
+ >=x11-libs/qt-test-4.5.0:4
+ x11-misc/shared-mime-info
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt
+ >=dev-util/automoc-0.9.88
+"
+RDEPEND="${CDEPEND}
+ postgres? ( dev-db/postgresql-server )
+"
+
+REQUIRED_USE="|| ( sqlite mysql postgres )"
+
+S=${WORKDIR}/${P/-server/}
+
+pkg_setup() {
+ # Set default storage backend in order: SQLite, MySQL, PostgreSQL
+ # reverse driver check to keep the order
+
+ if use postgres; then
+ DRIVER="QPSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use mysql; then
+ DRIVER="QMYSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use sqlite; then
+ DRIVER="QSQLITE3"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ # Notify about driver name change
+ if use sqlite && has_version "<=${CATEGORY}/${PN}-1.4.0[sqlite]"; then
+ ewarn
+ ewarn "SQLite driver name changed from QSQLITE to QSQLITE3."
+ ewarn "Please edit your ~/.config/akonadi/akonadiserverrc."
+ fi
+
+ # Notify about MySQL not being default anymore
+ if ! use mysql && has_version "<=${CATEGORY}/${PN}-1.4.0[mysql]"; then
+ ewarn
+ ewarn "MySQL driver is not enabled by default in Gentoo anymore."
+ ewarn "If you intend to use it, please enable mysql USE flag and reinstall"
+ ewarn "${CATEGORY}/${PN}."
+ ewarn "Otherwise select different driver in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "Available drivers are:${AVAILABLE}"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DAKONADI_USE_STRIGI_SEARCH=OFF"
+ $(cmake-utils_use test AKONADI_BUILD_TESTS)
+ $(cmake-utils_use sqlite INSTALL_QSQLITE_IN_QT_PREFIX)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ # Who knows, maybe it accidentally fixes our permission issues
+ cat <<-EOF > "${T}"/akonadiserverrc
+[%General]
+Driver=${DRIVER}
+EOF
+ insinto /usr/share/config/akonadi
+ doins "${T}"/akonadiserverrc
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ echo
+ elog "${DRIVER} has been set as your default akonadi storage backend."
+ elog "You can override it in your ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are: ${AVAILABLE}"
+}
diff --git a/app-office/akonadi-server/files/akonadi-server-1.6.0_Fix_crash_on_agent_launcher_exit.patch b/app-office/akonadi-server/files/akonadi-server-1.6.0_Fix_crash_on_agent_launcher_exit.patch
deleted file mode 100644
index 49228ef8b8f0..000000000000
--- a/app-office/akonadi-server/files/akonadi-server-1.6.0_Fix_crash_on_agent_launcher_exit.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-commit c8e45b10c32679bf070af5b7ad9a22b91eb9a02c
-Author: Sergio Martins <iamsergio@gmail.com>
-Date: Mon Sep 12 13:48:33 2011 +0100
-
- Fix crash on agent_launcher exit.
-
- Don't unload plugins here. They will be unloaded on application exit,
- so it's redundant.
-
- Seems they are being unloaded too early, before QThreadStorage
- cleanup occurs:
-
- ==18802== Invalid read of size 8
- ==18802== at 0x53178AE: QThreadStorage<QFontCache*>::deleteData(void*) (in
- /data/installation/qt/qt-4.7/lib/libQtGui.so.4.7.1)
- ==18802== by 0x5E8F8CF: QThreadStorageData::set(void*)
- (qthreadstorage.cpp:165)
- ==18802== by 0x5317940: void
- qThreadStorage_setLocalData<QFontCache>(QThreadStorageData&, QFontCache**)
- (qthreadstorage.h:92)
- ==18802== by 0x53165BA:
- QThreadStorage<QFontCache*>::setLocalData(QFontCache*) (qthreadstorage.h:148)
- ==18802== by 0x531407A: QFontCache::cleanup() (qfont.cpp:2632)
- ==18802== by 0x5406536: QFont::cleanup() (qfont_x11.cpp:182)
- ==18802== by 0x5104E35: qt_cleanup() (qapplication_x11.cpp:2647)
- ==18802== by 0x50603B2: QApplication::~QApplication()
- (qapplication.cpp:1172)
- ==18802== by 0x41B1F6: main (agentlauncher.cpp:28)
- ==18802== Address 0x11a090b0 is not stack'd, malloc'd or (recently) free'd
-
- CCBUG: 261788
-
-diff --git a/agentserver/agentpluginloader.cpp b/agentserver/agentpluginloader.cpp
-index 2d62d3b..456a124 100644
---- a/agentserver/agentpluginloader.cpp
-+++ b/agentserver/agentpluginloader.cpp
-@@ -25,13 +25,8 @@ using namespace Akonadi;
-
- AgentPluginLoader::~AgentPluginLoader()
- {
-- QHash<QString, QPluginLoader*>::iterator it = m_pluginLoaders.begin();
-- while ( it != m_pluginLoaders.end() ) {
-- it.value()->unload();
-- ++it;
-- }
--
- qDeleteAll( m_pluginLoaders );
-+ m_pluginLoaders.clear();
- }
-
- QPluginLoader *AgentPluginLoader::load( const QString &pluginName )
-diff --git a/agentserver/agentpluginloader.h b/agentserver/agentpluginloader.h
-index 77f5de9..c8c815f 100644
---- a/agentserver/agentpluginloader.h
-+++ b/agentserver/agentpluginloader.h
-@@ -26,7 +26,7 @@ class AgentPluginLoader
- {
- public:
- /**
-- Unloads and deletes all instantiated QPluginLoaders.
-+ Deletes all instantiated QPluginLoaders.
- */
- ~AgentPluginLoader();
-
diff --git a/app-office/akonadi-server/metadata.xml b/app-office/akonadi-server/metadata.xml
index f580a202f05f..8d1e86a9cefb 100644
--- a/app-office/akonadi-server/metadata.xml
+++ b/app-office/akonadi-server/metadata.xml
@@ -2,7 +2,4 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>kde</herd>
-<use>
- <flag name="server">Use locally installed database server.</flag>
-</use>
</pkgmetadata>