summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2004-09-03 09:07:13 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2004-09-03 09:07:13 +0000
commit8908d90ef0f23a6c8763a6d82b09e298286bbb78 (patch)
tree50feefaa14cc5cf0277a0983142062e0a041f53d /app-office/glabels/glabels-2.0.1.ebuild
parentStable x86. (Manifest recommit) (diff)
downloadgentoo-2-8908d90ef0f23a6c8763a6d82b09e298286bbb78.tar.gz
gentoo-2-8908d90ef0f23a6c8763a6d82b09e298286bbb78.tar.bz2
gentoo-2-8908d90ef0f23a6c8763a6d82b09e298286bbb78.zip
New version, including patch to avoid sandbox violation (bug #60545)
Diffstat (limited to 'app-office/glabels/glabels-2.0.1.ebuild')
-rw-r--r--app-office/glabels/glabels-2.0.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-office/glabels/glabels-2.0.1.ebuild b/app-office/glabels/glabels-2.0.1.ebuild
new file mode 100644
index 000000000000..94e17653a94d
--- /dev/null
+++ b/app-office/glabels/glabels-2.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/glabels/glabels-2.0.1.ebuild,v 1.1 2004/09/03 09:07:13 leonardop Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Program for creating labels and business cards"
+HOMEPAGE="http://glabels.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.2
+ >=x11-libs/gtk+-2.0.5
+ >=gnome-base/libgnome-2.0.1
+ >=gnome-base/libgnomeui-2.0.1
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libbonoboui-2
+ >=dev-libs/libxml2-2.4.23
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2
+ >=gnome-base/libgnomecanvas-2.0.1
+ >=gnome-base/libglade-2.0.1"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig
+ >=dev-util/intltool-0.21"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_unpack() {
+ unpack ${A}
+
+ # Small syntax correction.
+ sed -i -e 's:;Office:;Office;:' ${S}/data/desktop/glabels.desktop.in
+
+ # Avoid sandbox violation. See bug #60545.
+ epatch ${FILESDIR}/${P}-sandbox_fix.patch
+}