summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2010-02-14 23:28:04 +0000
committerRémi Cardona <remi@gentoo.org>2010-02-14 23:28:04 +0000
commit06a32ff8feba12a9608250c566d2ae4d534074cd (patch)
treee528a8fef63c9f1dc7343bcf5b893e6d7f970a8f /app-office/grisbi
parentVersion bump, bug #304825. (diff)
downloadgentoo-2-06a32ff8feba12a9608250c566d2ae4d534074cd.tar.gz
gentoo-2-06a32ff8feba12a9608250c566d2ae4d534074cd.tar.bz2
gentoo-2-06a32ff8feba12a9608250c566d2ae4d534074cd.zip
app-office/grisbi: bump to 0.6.0_rc2, ebuild adapted from bug #304937
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'app-office/grisbi')
-rw-r--r--app-office/grisbi/ChangeLog8
-rw-r--r--app-office/grisbi/files/0.6.0_rc2-properly-detect-gmodule.patch38
-rw-r--r--app-office/grisbi/grisbi-0.6.0_rc2.ebuild64
3 files changed, 109 insertions, 1 deletions
diff --git a/app-office/grisbi/ChangeLog b/app-office/grisbi/ChangeLog
index 7028e13e0c95..f69ea16b2f93 100644
--- a/app-office/grisbi/ChangeLog
+++ b/app-office/grisbi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/grisbi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/grisbi/ChangeLog,v 1.32 2010/02/13 21:01:20 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/grisbi/ChangeLog,v 1.33 2010/02/14 23:28:04 remi Exp $
+
+*grisbi-0.6.0_rc2 (14 Feb 2010)
+
+ 14 Feb 2010; Rémi Cardona <remi@gentoo.org>
+ +files/0.6.0_rc2-properly-detect-gmodule.patch, +grisbi-0.6.0_rc2.ebuild:
+ bump to 0.6.0_rc2, ebuild adapted from bug #304937
13 Feb 2010; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Updating Guillaume's mail
diff --git a/app-office/grisbi/files/0.6.0_rc2-properly-detect-gmodule.patch b/app-office/grisbi/files/0.6.0_rc2-properly-detect-gmodule.patch
new file mode 100644
index 000000000000..d36bcdbc4166
--- /dev/null
+++ b/app-office/grisbi/files/0.6.0_rc2-properly-detect-gmodule.patch
@@ -0,0 +1,38 @@
+From ad49bfcb6a29dda93170ea14c38d599df2bbf72d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?R=C3=A9mi=20Cardona?= <remi@gentoo.org>
+Date: Sun, 14 Feb 2010 21:39:50 +0100
+Subject: [PATCH 1/2] properly detect gmodule
+
+This usually doesn't happen unless gcc is configured to force
+--as-needed through spec files.
+---
+ configure.in | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 972fbc2..e2e84ce 100644
+--- a/configure.in
++++ b/configure.in
+@@ -32,7 +32,7 @@ AC_CHECK_LIB(intl,main)
+ dnl
+ dnl Standard GTK checks
+ dnl
+-PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.2.0 glib-2.0 >= 2.2)
++PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.2.0 glib-2.0 >= 2.2 gmodule-2.0 >= 2.2])
+ LDFLAGS="${LDFLAGS} ${GTK_LIBS}"
+ CFLAGS="${CFLAGS} ${GTK_CFLAGS}"
+
+@@ -44,8 +44,8 @@ dnl
+ AC_MSG_CHECKING(whether GLib supports loadable modules)
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+-CFLAGS="$CFLAGS $GLIB_CFLAGS"
+-LIBS="$GLIB_LIBS $LIBS"
++CFLAGS="$CFLAGS $GTK_CFLAGS"
++LIBS="$GTK_LIBS $LIBS"
+ AC_TRY_RUN([
+ #include <glib.h>
+ #include <gmodule.h>
+--
+1.6.6.1
+
diff --git a/app-office/grisbi/grisbi-0.6.0_rc2.ebuild b/app-office/grisbi/grisbi-0.6.0_rc2.ebuild
new file mode 100644
index 000000000000..45b09eab43c7
--- /dev/null
+++ b/app-office/grisbi/grisbi-0.6.0_rc2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/grisbi/grisbi-0.6.0_rc2.ebuild,v 1.1 2010/02/14 23:28:04 remi Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+IUSE="nls ofx ssl"
+
+MY_PV=${PV/_rc/rc}
+DESCRIPTION="Grisbi is a personal accounting application for Linux"
+HOMEPAGE="http://www.grisbi.org"
+SRC_URI="mirror://sourceforge/grisbi/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+# minimum gtk 2.10 to have print support
+RDEPEND="dev-libs/libxml2
+ >=x11-libs/gtk+-2.10.0
+ ssl? ( dev-libs/openssl )
+ ofx? ( >=dev-libs/libofx-0.7.0 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.20"
+
+src_prepare() {
+ epatch "${FILESDIR}/0.6.0_rc2-properly-detect-gmodule.patch"
+
+ # Apply location patchs
+ ebegin "Applying Gentoo documentation location patch"
+ for i in \
+ $(find ./ -name 'Makefile.am') \
+ $(find ./ -name 'grisbi-manuel.html')
+ do
+ sed -i "s;doc/grisbi/;doc/${PF}/;g" "${i}"
+ done
+ eend 0
+
+ AT_M4DIR="macros" eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-plugins \
+ $(use_with ofx) \
+ $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS NEWS README
+}
+
+pkg_postinst() {
+ elog "The first thing you should do is set up the browser command in"
+ elog "preferences after you start up grisbi. Otherwise you will not"
+ elog "be able to see the help and manuals."
+}