summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-19 17:19:37 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-19 17:19:37 +0000
commit9504c7149ab954d4b8acec98b863a6efbc5cc6e1 (patch)
tree5a822bc1549a0e1a17417919482ee49d1a025927 /app-office/karbon/karbon-1.5.2.ebuild
parentRemove redundent 10-udev.hotplug symlink. Noticed by Walt <wa1ter@myrealbox.... (diff)
downloadgentoo-2-9504c7149ab954d4b8acec98b863a6efbc5cc6e1.tar.gz
gentoo-2-9504c7149ab954d4b8acec98b863a6efbc5cc6e1.tar.bz2
gentoo-2-9504c7149ab954d4b8acec98b863a6efbc5cc6e1.zip
Version bump.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'app-office/karbon/karbon-1.5.2.ebuild')
-rw-r--r--app-office/karbon/karbon-1.5.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-office/karbon/karbon-1.5.2.ebuild b/app-office/karbon/karbon-1.5.2.ebuild
new file mode 100644
index 000000000000..765d510ddd92
--- /dev/null
+++ b/app-office/karbon/karbon-1.5.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/karbon-1.5.2.ebuild,v 1.1 2006/07/19 17:19:37 flameeyes Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice vector drawing application."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ >=media-gfx/imagemagick-5.5.2
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkopalette lib/kopalette
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store"
+
+KMEXTRACTONLY="lib/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/karbon"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile liboofilter first
+ echo "SUBDIRS = liboofilter karbon" > $S/filters/Makefile.am
+
+ kde-meta_src_unpack makefiles
+}