summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-10-10 22:04:41 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-10-10 22:04:41 +0000
commit2c4bf0a39233832e367a8a1555964b27eb045aef (patch)
tree3501e671cf4a1d91d6a3affb6b86db6249a13d19 /app-office/kexi
parentFix by R. Bosch to use strsignal as needed by uClibc systems #103189 by Chan ... (diff)
downloadgentoo-2-2c4bf0a39233832e367a8a1555964b27eb045aef.tar.gz
gentoo-2-2c4bf0a39233832e367a8a1555964b27eb045aef.tar.bz2
gentoo-2-2c4bf0a39233832e367a8a1555964b27eb045aef.zip
New version.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'app-office/kexi')
-rw-r--r--app-office/kexi/ChangeLog7
-rw-r--r--app-office/kexi/files/digest-kexi-1.4.21
-rw-r--r--app-office/kexi/kexi-1.4.2.ebuild46
3 files changed, 53 insertions, 1 deletions
diff --git a/app-office/kexi/ChangeLog b/app-office/kexi/ChangeLog
index dc5ea31b27b3..588c54209a5a 100644
--- a/app-office/kexi/ChangeLog
+++ b/app-office/kexi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kexi
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.12 2005/09/11 18:14:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.13 2005/10/10 22:04:12 greg_g Exp $
+
+*kexi-1.4.2 (10 Oct 2005)
+
+ 10 Oct 2005; Gregorio Guidi <greg_g@gentoo.org> +kexi-1.4.2.ebuild:
+ New version.
11 Sep 2005; Aron Griffis <agriffis@gentoo.org> kexi-1.4.1.ebuild:
Mark 1.4.1 stable on alpha
diff --git a/app-office/kexi/files/digest-kexi-1.4.2 b/app-office/kexi/files/digest-kexi-1.4.2
new file mode 100644
index 000000000000..a054824ae545
--- /dev/null
+++ b/app-office/kexi/files/digest-kexi-1.4.2
@@ -0,0 +1 @@
+MD5 6b456fb7d54c84b11396b27a96ae0cf8 koffice-1.4.2.tar.bz2 19486852
diff --git a/app-office/kexi/kexi-1.4.2.ebuild b/app-office/kexi/kexi-1.4.2.ebuild
new file mode 100644
index 000000000000..43db87a9eed7
--- /dev/null
+++ b/app-office/kexi/kexi-1.4.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-1.4.2.ebuild,v 1.1 2005/10/10 22:04:12 greg_g Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated environment for database management."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mysql postgres"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ sys-libs/readline
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-libs/libpqxx )
+ dev-lang/python
+ !dev-db/kexi"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkoscript lib/koscript
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store"
+
+KMEXTRACTONLY="lib/"
+
+need-kde 3.3
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql)"
+
+ kde-meta_src_compile
+}