summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2011-02-05 10:45:17 +0000
committerAndreas Proschofsky <suka@gentoo.org>2011-02-05 10:45:17 +0000
commit1e6ec8ada975c07171ec2464601f56deb8585b26 (patch)
treeca5b8a878891d1103c1e9dcbb37a6f9ae862bc45 /app-office/openoffice
parentEAPI3 and prefix fixes, bug #353035, also clean up pax-stuff, bug #353587 (diff)
downloadgentoo-2-1e6ec8ada975c07171ec2464601f56deb8585b26.tar.gz
gentoo-2-1e6ec8ada975c07171ec2464601f56deb8585b26.tar.bz2
gentoo-2-1e6ec8ada975c07171ec2464601f56deb8585b26.zip
Also fix pax stuff and bump EAPI in older ebuild
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'app-office/openoffice')
-rw-r--r--app-office/openoffice/ChangeLog5
-rw-r--r--app-office/openoffice/openoffice-3.2.0.ebuild20
2 files changed, 14 insertions, 11 deletions
diff --git a/app-office/openoffice/ChangeLog b/app-office/openoffice/ChangeLog
index 2357d5160d26..5fcdcaeb1da6 100644
--- a/app-office/openoffice/ChangeLog
+++ b/app-office/openoffice/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-office/openoffice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.545 2011/02/05 10:40:31 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.546 2011/02/05 10:45:17 suka Exp $
+
+ 05 Feb 2011; Andreas Proschofsky <suka@gentoo.org> openoffice-3.2.0.ebuild:
+ Also fix pax stuff and bump EAPI in older ebuild
05 Feb 2011; Andreas Proschofsky <suka@gentoo.org>
+files/ooo-build-3.0.1.2-prefix.patch, openoffice-3.2.1-r1.ebuild:
diff --git a/app-office/openoffice/openoffice-3.2.0.ebuild b/app-office/openoffice/openoffice-3.2.0.ebuild
index 2243c5879cb2..6f4d379b43c3 100644
--- a/app-office/openoffice/openoffice-3.2.0.ebuild
+++ b/app-office/openoffice/openoffice-3.2.0.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-3.2.0.ebuild,v 1.29 2010/11/07 19:45:55 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-3.2.0.ebuild,v 1.30 2011/02/05 10:45:17 suka Exp $
WANT_AUTOMAKE="1.9"
-EAPI="2"
+EAPI="3"
KDE_REQUIRED="optional"
CMAKE_REQUIRED="never"
PYTHON_DEPEND="2"
PYTHON_USE_WITH="threads"
-inherit autotools bash-completion check-reqs db-use eutils fdo-mime flag-o-matic java-pkg-opt-2 kde4-base mono multilib python toolchain-funcs
+inherit autotools bash-completion check-reqs db-use eutils fdo-mime flag-o-matic java-pkg-opt-2 kde4-base mono multilib pax-utils python toolchain-funcs
IUSE="binfilter cups dbus debug eds gnome gstreamer gtk kde ldap mono nsplugin odk opengl pam templates"
@@ -364,18 +364,18 @@ src_install() {
make DESTDIR="${D}" install || die "Installation failed!"
# Fix the permissions for security reasons
- chown -RP root:0 "${D}"
+ chown -RP root:0 "${ED}"
# record java libraries
if use java; then
- java-pkg_regjar "${D}"/usr/$(get_libdir)/openoffice/${BASIS}/program/classes/*.jar
- java-pkg_regjar "${D}"/usr/$(get_libdir)/openoffice/ure/share/java/*.jar
+ java-pkg_regjar "${ED}"/usr/$(get_libdir)/openoffice/${BASIS}/program/classes/*.jar
+ java-pkg_regjar "${ED}"/usr/$(get_libdir)/openoffice/ure/share/java/*.jar
fi
# Upstream places the bash-completion module in /etc. Gentoo places them in
# /usr/share/bash-completion. bug 226061
- dobashcompletion "${D}"/etc/bash_completion.d/ooffice.sh ooffice
- rm -rf "${D}"/etc/bash_completion.d/ || die "rm failed"
+ dobashcompletion "${ED}"/etc/bash_completion.d/ooffice.sh ooffice
+ rm -rf "${ED}"/etc/bash_completion.d/ || die "rm failed"
}
@@ -385,7 +385,7 @@ pkg_postinst() {
fdo-mime_mime_database_update
BASHCOMPLETION_NAME=ooffice && bash-completion_pkg_postinst
- ( [[ -x /sbin/chpax ]] || [[ -x /sbin/paxctl ]] ) && [[ -e /usr/$(get_libdir)/openoffice/program/soffice.bin ]] && scanelf -Xzm /usr/$(get_libdir)/openoffice/program/soffice.bin
+ pax-mark -m /usr/$(get_libdir)/openoffice/program/soffice.bin
# Add available & useful jars to openoffice classpath
use java && /usr/$(get_libdir)/openoffice/${BASIS}/program/java-set-classpath $(java-config --classpath=jdbc-mysql 2>/dev/null) >/dev/null