summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-06-26 22:30:31 +0000
committerJohannes Huber <johu@gentoo.org>2015-06-26 22:30:31 +0000
commit5494f92523723e499bb00f1103e728eea2138016 (patch)
treec2dcfc301225c8aad312d417d384f87612e6ca31 /app-office
parentFix S assignment for EAPI 5. Resolves bug #553228 (diff)
downloadgentoo-2-5494f92523723e499bb00f1103e728eea2138016.tar.gz
gentoo-2-5494f92523723e499bb00f1103e728eea2138016.tar.bz2
gentoo-2-5494f92523723e499bb00f1103e728eea2138016.zip
Revision bump adds patch by Brian Evans <grknight@gentoo.org>, fixes a crash with dev-db/mysql-5.6m bug #530012.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xFDF4F788)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/akonadi-server/ChangeLog13
-rw-r--r--app-office/akonadi-server/akonadi-server-1.13.0-r1.ebuild138
-rw-r--r--app-office/akonadi-server/akonadi-server-1.13.0.ebuild4
-rw-r--r--app-office/akonadi-server/files/akonadi-server-1.13.0-mysql56-crash.patch20
4 files changed, 171 insertions, 4 deletions
diff --git a/app-office/akonadi-server/ChangeLog b/app-office/akonadi-server/ChangeLog
index fd1fa63d1992..d8e6d668267c 100644
--- a/app-office/akonadi-server/ChangeLog
+++ b/app-office/akonadi-server/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-office/akonadi-server
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.155 2014/12/28 14:53:20 titanofold Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.156 2015/06/26 22:30:31 johu Exp $
+
+*akonadi-server-1.13.0-r1 (26 Jun 2015)
+
+ 26 Jun 2015; Johannes Huber <johu@gentoo.org>
+ +akonadi-server-1.13.0-r1.ebuild,
+ +files/akonadi-server-1.13.0-mysql56-crash.patch,
+ akonadi-server-1.13.0.ebuild:
+ Revision bump adds patch by Brian Evans <grknight@gentoo.org>, fixes a crash
+ with dev-db/mysql-5.6m bug #530012.
28 Dec 2014; Aaron W. Swenson <titanofold@gentoo.org>
akonadi-server-1.13.0.ebuild:
diff --git a/app-office/akonadi-server/akonadi-server-1.13.0-r1.ebuild b/app-office/akonadi-server/akonadi-server-1.13.0-r1.ebuild
new file mode 100644
index 000000000000..291873229918
--- /dev/null
+++ b/app-office/akonadi-server/akonadi-server-1.13.0-r1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.13.0-r1.ebuild,v 1.1 2015/06/26 22:30:31 johu Exp $
+
+EAPI=5
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-r3
+ EGIT_REPO_URI=( "git://anongit.kde.org/akonadi" )
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://kde/stable/${PN/-server/}/src/${P/-server/}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${P/-server/}"
+fi
+
+inherit cmake-utils ${scm_eclass}
+
+DESCRIPTION="The server part of Akonadi"
+HOMEPAGE="http://pim.kde.org/akonadi"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="+mysql postgres +qt4 qt5 soprano sqlite test"
+
+REQUIRED_USE="^^ ( qt4 qt5 ) || ( sqlite mysql postgres )"
+
+CDEPEND="
+ dev-libs/boost:=
+ x11-misc/shared-mime-info
+ qt4? (
+ >=dev-qt/qtcore-4.8.5:4
+ >=dev-qt/qtdbus-4.8.5:4
+ >=dev-qt/qtgui-4.8.5:4
+ >=dev-qt/qtsql-4.8.5:4[mysql?,postgres?]
+ >=dev-qt/qttest-4.8.5:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[mysql?,postgres?]
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ soprano? ( dev-libs/soprano[-qt4,qt5] )
+ )
+ soprano? ( dev-libs/soprano )
+ sqlite? ( dev-db/sqlite:3 )
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt
+ >=dev-util/automoc-0.9.88
+ test? ( sys-apps/dbus )
+"
+RDEPEND="${CDEPEND}
+ postgres? ( dev-db/postgresql[server] )
+"
+
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${P}-mysql56-crash.patch" )
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]] ) \
+ && die "Sorry, but gcc-4.6 and earlier won't work (see bug #520102)."
+ fi
+}
+
+pkg_setup() {
+ # Set default storage backend in order: MySQL, SQLite PostgreSQL
+ # reverse driver check to keep the order
+ if use postgres; then
+ DRIVER="QPSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use sqlite; then
+ DRIVER="QSQLITE3"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use mysql; then
+ DRIVER="QMYSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ # Notify about MySQL is recommend by upstream
+ if use sqlite || has_version "<${CATEGORY}/${P}[sqlite]"; then
+ ewarn
+ ewarn "We strongly recommend you change your Akonadi database backend to MySQL in your"
+ ewarn "user configuration. This is the backend recommended by KDE upstream."
+ ewarn "In particular, kde-base/kmail-4.10 does not work properly with the sqlite"
+ ewarn "backend anymore."
+ ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "Available drivers are:${AVAILABLE}"
+ ewarn
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_QSQLITE_IN_QT_PREFIX=ON
+ $(cmake-utils_use test AKONADI_BUILD_TESTS)
+ $(cmake-utils_use_with soprano)
+ $(cmake-utils_use sqlite AKONADI_BUILD_QSQLITE)
+ $(cmake-utils_use qt5 QT5_BUILD)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ export $(dbus-launch)
+ cmake-utils_src_test
+}
+
+src_install() {
+ # Who knows, maybe it accidentally fixes our permission issues
+ cat <<-EOF > "${T}"/akonadiserverrc
+[%General]
+Driver=${DRIVER}
+EOF
+ insinto /usr/share/config/akonadi
+ doins "${T}"/akonadiserverrc
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ elog "${DRIVER} has been set as your default akonadi storage backend."
+ elog "You can override it in your ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are: ${AVAILABLE}"
+}
diff --git a/app-office/akonadi-server/akonadi-server-1.13.0.ebuild b/app-office/akonadi-server/akonadi-server-1.13.0.ebuild
index 08ca8a454911..c8a7fac8c6b7 100644
--- a/app-office/akonadi-server/akonadi-server-1.13.0.ebuild
+++ b/app-office/akonadi-server/akonadi-server-1.13.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.13.0.ebuild,v 1.9 2014/12/28 14:53:20 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.13.0.ebuild,v 1.10 2015/06/26 22:30:31 johu Exp $
EAPI=5
diff --git a/app-office/akonadi-server/files/akonadi-server-1.13.0-mysql56-crash.patch b/app-office/akonadi-server/files/akonadi-server-1.13.0-mysql56-crash.patch
new file mode 100644
index 000000000000..204961832767
--- /dev/null
+++ b/app-office/akonadi-server/files/akonadi-server-1.13.0-mysql56-crash.patch
@@ -0,0 +1,20 @@
+diff -aruN akonadi-1.13.0.old/server/src/storage/dbconfigmysql.cpp akonadi-1.13.0/server/src/storage/dbconfigmysql.cpp
+--- akonadi-1.13.0.old/server/src/storage/dbconfigmysql.cpp 2014-08-10 06:38:58.000000000 -0400
++++ akonadi-1.13.0/server/src/storage/dbconfigmysql.cpp 2015-01-08 15:08:36.906134212 -0500
+@@ -76,6 +76,7 @@
+ << QLatin1String( "/usr/local/sbin" )
+ << QLatin1String( "/usr/local/libexec" )
+ << QLatin1String( "/usr/libexec" )
++ << QLatin1String( "/usr/share/mysql/scripts" )
+ << QLatin1String( "/opt/mysql/libexec" )
+ << QLatin1String( "/opt/local/lib/mysql5/bin" )
+ << QLatin1String( "/opt/mysql/sbin" );
+@@ -278,7 +279,7 @@
+ // first run, some MySQL versions need a mysql_install_db run for that
+ const QString confFile = XdgBaseDirs::findResourceFile( "config", QLatin1String( "akonadi/mysql-global.conf" ) );
+ if ( QDir( dataDir ).entryList( QDir::NoDotAndDotDot | QDir::AllEntries ).isEmpty() && !mMysqlInstallDbPath.isEmpty() ) {
+- const QStringList arguments = QStringList() << QString::fromLatin1( "--force" ) << QString::fromLatin1( "--defaults-file=%1" ).arg( confFile ) << QString::fromLatin1( "--datadir=%1/" ).arg( dataDir );
++ const QStringList arguments = QStringList() << QString::fromLatin1( "--force" ) << QString::fromLatin1( "--defaults-file=%1" ).arg( confFile ) << QString::fromLatin1( "--datadir=%1/" ).arg( dataDir ) << QString::fromLatin1( "--basedir=/usr" ) ;
+ QProcess::execute( mMysqlInstallDbPath, arguments );
+ }
+