summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-19 17:00:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-19 17:00:49 +0000
commit78ecbffe4dcd1d9deb8a8421e136ebf3ece29850 (patch)
tree34cdca4592d1ab652fa0ea70b44692915cf0c265 /app-office
parentVersion bump (diff)
downloadgentoo-2-78ecbffe4dcd1d9deb8a8421e136ebf3ece29850.tar.gz
gentoo-2-78ecbffe4dcd1d9deb8a8421e136ebf3ece29850.tar.bz2
gentoo-2-78ecbffe4dcd1d9deb8a8421e136ebf3ece29850.zip
Version bump
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kexi/ChangeLog7
-rw-r--r--app-office/kexi/files/digest-kexi-1.5.23
-rw-r--r--app-office/kexi/kexi-1.5.2.ebuild50
3 files changed, 59 insertions, 1 deletions
diff --git a/app-office/kexi/ChangeLog b/app-office/kexi/ChangeLog
index a5e16e50b26a..25ec4aeac1d1 100644
--- a/app-office/kexi/ChangeLog
+++ b/app-office/kexi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kexi
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.37 2006/06/30 20:30:59 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.38 2006/07/19 17:00:49 flameeyes Exp $
+
+*kexi-1.5.2 (19 Jul 2006)
+
+ 19 Jul 2006; Diego Pettenò <flameeyes@gentoo.org> +kexi-1.5.2.ebuild:
+ Version bump
30 Jun 2006; Lars Weiler <pylon@gentoo.org> kexi-1.5.1.ebuild:
Stable on ppc; gcc-4 related; bug #138099.
diff --git a/app-office/kexi/files/digest-kexi-1.5.2 b/app-office/kexi/files/digest-kexi-1.5.2
new file mode 100644
index 000000000000..d1ae4451f5cb
--- /dev/null
+++ b/app-office/kexi/files/digest-kexi-1.5.2
@@ -0,0 +1,3 @@
+MD5 cbe9deeb7c811a6bb5a954989b25c1f2 koffice-1.5.2.tar.bz2 35878218
+RMD160 eb33d9e74adec0fc3409d38c2bfe84b5dfdd5546 koffice-1.5.2.tar.bz2 35878218
+SHA256 d57d8a7611337f2678a7e28b100b9ab64148bf5483c01dbd204529f07b148611 koffice-1.5.2.tar.bz2 35878218
diff --git a/app-office/kexi/kexi-1.5.2.ebuild b/app-office/kexi/kexi-1.5.2.ebuild
new file mode 100644
index 000000000000..4b86993580a6
--- /dev/null
+++ b/app-office/kexi/kexi-1.5.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-1.5.2.ebuild,v 1.1 2006/07/19 17:00:49 flameeyes Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated environment for database management."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mysql postgres"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ sys-libs/readline
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-libs/libpqxx )
+ dev-lang/python"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkoproperty lib/koproperty
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkrossmain lib/kross/main/
+ libkrossapi lib/kross/api/"
+
+KMEXTRACTONLY="lib/"
+
+need-kde 3.4
+
+PATCHES="${FILESDIR}/kexi-1.5.1-form_plugins.patch
+ ${FILESDIR}/kexi-1.5.1-kexi_checkbox_data_saving.patch"
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql) --enable-kexi-reports"
+
+ kde-meta_src_compile
+}