summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-26 21:54:24 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-26 21:54:24 +0000
commit98409eacac9ad9d1721f82e8fbedc24799368aa4 (patch)
treea8168a0f7d8661921b65a4a583f21b8c1b9cf040 /app-office
parentFix up pkg-config files so they mirror what Debian does. (diff)
downloadgentoo-2-98409eacac9ad9d1721f82e8fbedc24799368aa4.tar.gz
gentoo-2-98409eacac9ad9d1721f82e8fbedc24799368aa4.tar.bz2
gentoo-2-98409eacac9ad9d1721f82e8fbedc24799368aa4.zip
Bump to 1.8.4. Bug fixes.
(Portage version: 2.2_rc22/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/ChangeLog10
-rw-r--r--app-office/gnumeric/gnumeric-1.8.4.ebuild100
2 files changed, 108 insertions, 2 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index 22fc757ef5e2..463278d3c2ee 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/gnumeric
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.176 2008/12/04 22:04:07 eva Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.177 2009/01/26 21:54:24 eva Exp $
+
+*gnumeric-1.8.4 (26 Jan 2009)
+
+ 26 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnumeric-1.8.4.ebuild:
+ Bump to 1.8.4. Bug fixes.
04 Dec 2008; Gilles Dartiguelongue <eva@gentoo.org> gnumeric-1.8.3.ebuild:
Add call to python_need_rebuild, bug #244746.
diff --git a/app-office/gnumeric/gnumeric-1.8.4.ebuild b/app-office/gnumeric/gnumeric-1.8.4.ebuild
new file mode 100644
index 000000000000..c778bec4a6ea
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.8.4.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.8.4.ebuild,v 1.1 2009/01/26 21:54:24 eva Exp $
+
+inherit gnome2 flag-o-matic python
+
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+HOMEPAGE="http://www.gnome.org/projects/gnumeric/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="gnome perl python"
+# bonobo guile libgda mono (experimental)
+
+# lots of missing files, wait for next release
+RESTRICT="test"
+
+RDEPEND="sys-libs/zlib
+ app-arch/bzip2
+ >=dev-libs/glib-2.6
+ >=gnome-extra/libgsf-1.14.6
+ >=x11-libs/goffice-0.6.3
+ >=dev-libs/libxml2-2.4.12
+ >=x11-libs/pango-1.8.1
+
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libglade-2.3.6
+ >=media-libs/libart_lgpl-2.3.11
+
+ gnome? (
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libbonobo-2.2
+ >=gnome-base/libbonoboui-2.2 )
+ perl? ( dev-lang/perl )
+ python? (
+ >=dev-lang/python-2
+ >=dev-python/pygtk-2 )"
+ # libgda? (
+ # >=gnome-extra/libgda-3.1.1
+ # >=gnome-extra/libgnomedb-3.0.1 )
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.29
+ >=dev-util/pkgconfig-0.18
+ app-text/scrollkeeper"
+
+DOCS="AUTHORS BEVERAGES BUGS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ local will_die=false
+
+ G2CONF="${G2CONF}
+ --enable-ssindex
+ --enable-static
+ --without-gda
+ --without-guile
+ --without-mono
+ $(use_with perl)
+ $(use_with python)
+ $(use_with gnome)"
+
+ if ! built_with_use x11-libs/cairo svg; then
+ eerror "x11-libs/cairo needs to be built with svg support"
+ eerror "please rebuild x11-libs/cairo with svg support"
+ will_die=true
+ fi
+
+ if use gnome && ! built_with_use gnome-extra/libgsf gnome; then
+ eerror "gnome-extra/libgsf needs to be compiled with gnome support"
+ eerror "for this version of gnumeric to work. Rebuild"
+ eerror "gnome-extra/libgsf first like this :"
+ eerror "USE=gnome emerge libgsf -vp"
+ will_die=true
+ fi
+
+ if ${will_die} ; then
+ die "Please rebuild the packages with the use flags above."
+ fi
+
+ # gcc bug (http://bugs.gnome.org/show_bug.cgi?id=128834)
+ replace-flags "-Os" "-O2"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # make gnumeric find its help
+ dosym \
+ /usr/share/gnome/help/gnumeric \
+ /usr/share/${PN}/${PV}/doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+}