summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-02-06 18:59:38 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2013-02-06 18:59:38 +0000
commit9f2f29626fb14096d9ba807fdf654494ba76b2b9 (patch)
tree388d5a9a080d7f795e0537919160c67ab0ed13e4 /app-office
parentVersion bump KDE SC 4.10.0 (diff)
downloadgentoo-2-9f2f29626fb14096d9ba807fdf654494ba76b2b9.tar.gz
gentoo-2-9f2f29626fb14096d9ba807fdf654494ba76b2b9.tar.bz2
gentoo-2-9f2f29626fb14096d9ba807fdf654494ba76b2b9.zip
Change default backend to mysql wrt bug 441596
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/akonadi-server/ChangeLog5
-rw-r--r--app-office/akonadi-server/akonadi-server-1.9.0.ebuild22
2 files changed, 15 insertions, 12 deletions
diff --git a/app-office/akonadi-server/ChangeLog b/app-office/akonadi-server/ChangeLog
index b3700c908aaf..8369c6a23432 100644
--- a/app-office/akonadi-server/ChangeLog
+++ b/app-office/akonadi-server/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-office/akonadi-server
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.95 2013/02/06 18:52:54 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.96 2013/02/06 18:59:38 alexxy Exp $
+
+ 06 Feb 2013; Alexey Shvetsov <alexxy@gentoo.org> akonadi-server-1.9.0.ebuild:
+ Change default backend to mysql wrt bug 441596
*akonadi-server-1.9.0 (06 Feb 2013)
diff --git a/app-office/akonadi-server/akonadi-server-1.9.0.ebuild b/app-office/akonadi-server/akonadi-server-1.9.0.ebuild
index ac626e541ec8..d97cc19265ad 100644
--- a/app-office/akonadi-server/akonadi-server-1.9.0.ebuild
+++ b/app-office/akonadi-server/akonadi-server-1.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.9.0.ebuild,v 1.1 2013/02/06 18:52:54 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.9.0.ebuild,v 1.2 2013/02/06 18:59:38 alexxy Exp $
EAPI=4
@@ -22,7 +22,7 @@ HOMEPAGE="http://pim.kde.org/akonadi"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="mysql postgres +sqlite test"
+IUSE="+mysql postgres sqlite test"
CDEPEND="
dev-libs/boost
@@ -47,20 +47,20 @@ RESTRICT=test
PATCHES=( "${FILESDIR}/${P}-qt5.patch" )
pkg_setup() {
- # Set default storage backend in order: SQLite, MySQL, PostgreSQL
+ # Set default storage backend in order: MySQL, SQLite PostgreSQL
# reverse driver check to keep the order
if use postgres; then
DRIVER="QPSQL"
AVAILABLE+=" ${DRIVER}"
fi
- if use mysql; then
- DRIVER="QMYSQL"
+ if use sqlite; then
+ DRIVER="QSQLITE3"
AVAILABLE+=" ${DRIVER}"
fi
- if use sqlite; then
- DRIVER="QSQLITE3"
+ if use mysql; then
+ DRIVER="QMYSQL"
AVAILABLE+=" ${DRIVER}"
fi
@@ -72,12 +72,12 @@ pkg_setup() {
fi
# Notify about MySQL not being default anymore
- if ! use mysql && has_version "<=${CATEGORY}/${PN}-1.4.0[mysql]"; then
+ if ! use sqlite && has_version "<=${CATEGORY}/${PN}-1.4.0[sqlite]"; then
ewarn
- ewarn "MySQL driver is not enabled by default in Gentoo anymore."
- ewarn "If you intend to use it, please enable mysql USE flag and reinstall"
+ ewarn "The default storage drive has changed from SQLite to MySQL."
+ ewarn "If you want to stay with SQLite, enable the sqlite USE flag and reinstall"
ewarn "${CATEGORY}/${PN}."
- ewarn "Otherwise select different driver in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "Otherwise, select a different driver in your ~/.config/akonadi/akonadiserverrc."
ewarn "Available drivers are:${AVAILABLE}"
fi
}