summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-02-22 18:21:15 +0000
committerTorsten Veller <tove@gentoo.org>2010-02-22 18:21:15 +0000
commitc11c90ed70a047a6ff0b70f44b5010758ec23e62 (patch)
tree787d6a1bd9ea795fed35abec32f9621f95559c58 /app-office
parentPut the docs in correct place wrt bug #241308 by flameeyes. Also fix some rep... (diff)
downloadgentoo-2-c11c90ed70a047a6ff0b70f44b5010758ec23e62.tar.gz
gentoo-2-c11c90ed70a047a6ff0b70f44b5010758ec23e62.tar.bz2
gentoo-2-c11c90ed70a047a6ff0b70f44b5010758ec23e62.zip
Version bump
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/ChangeLog8
-rw-r--r--app-office/gnucash/files/test-dbi-stuff.h4
-rw-r--r--app-office/gnucash/gnucash-2.3.10.ebuild113
3 files changed, 124 insertions, 1 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index 8be21bd12599..b55529328d60 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/gnucash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.208 2010/01/17 19:39:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.209 2010/02/22 18:21:14 tove Exp $
+
+*gnucash-2.3.10 (22 Feb 2010)
+
+ 22 Feb 2010; Torsten Veller <tove@gentoo.org> +gnucash-2.3.10.ebuild,
+ +files/test-dbi-stuff.h:
+ Version bump
17 Jan 2010; Samuli Suominen <ssuominen@gentoo.org>
gnucash-2.2.9-r1.ebuild, gnucash-2.3.8.ebuild:
diff --git a/app-office/gnucash/files/test-dbi-stuff.h b/app-office/gnucash/files/test-dbi-stuff.h
new file mode 100644
index 000000000000..7a890def18e4
--- /dev/null
+++ b/app-office/gnucash/files/test-dbi-stuff.h
@@ -0,0 +1,4 @@
+#ifndef _TEST_DBI_STUFF_H_
+#define _TEST_DBI_STUFF_H_
+void test_dbi_store_and_reload( const gchar* driver, QofSession* session_1, const gchar* url );
+#endif
diff --git a/app-office/gnucash/gnucash-2.3.10.ebuild b/app-office/gnucash/gnucash-2.3.10.ebuild
new file mode 100644
index 000000000000..fb210c4efbfe
--- /dev/null
+++ b/app-office/gnucash/gnucash-2.3.10.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-2.3.10.ebuild,v 1.1 2010/02/22 18:21:14 tove Exp $
+
+EAPI=2
+
+inherit eutils gnome2
+
+DOC_VER="2.2.0"
+
+DESCRIPTION="A personal finance manager"
+HOMEPAGE="http://www.gnucash.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+IUSE="+doc ofx hbci chipcard debug quotes sqlite postgres mysql webkit"
+
+# FIXME: rdepend on dev-libs/qof when upstream fix their mess (see configure.in)
+
+RDEPEND=">=dev-libs/glib-2.6.3
+ >=dev-scheme/guile-1.8.3[deprecated,regex]
+ dev-scheme/guile-www
+ >=dev-scheme/slib-3.1.4
+ >=sys-libs/zlib-1.1.4
+ >=dev-libs/popt-1.5
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libgnomeui-2.4
+ >=gnome-base/libglade-2.4
+ >=dev-libs/libxml2-2.5.10
+ >=gnome-base/gconf-2
+ >=x11-libs/goffice-0.6[gnome]
+ ofx? ( >=dev-libs/libofx-0.9.1 )
+ hbci? ( >=net-libs/aqbanking-4.2[qt4]
+ chipcard? ( sys-libs/libchipcard )
+ )
+ quotes? ( dev-perl/DateManip
+ >=dev-perl/Finance-Quote-1.11
+ dev-perl/HTML-TableExtract )
+ webkit? ( net-libs/webkit-gtk )
+ !webkit? ( >=gnome-extra/gtkhtml-3.14 )
+ sqlite? ( dev-db/libdbi dev-db/libdbi-drivers[sqlite3] )
+ postgres? ( dev-db/libdbi dev-db/libdbi-drivers[postgres] )
+ mysql? ( dev-db/libdbi dev-db/libdbi-drivers[mysql] )
+ media-libs/libart_lgpl
+ x11-libs/pango"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/libtool
+ >=app-text/scrollkeeper-0.3"
+
+PDEPEND="doc? ( >=app-doc/gnucash-docs-${DOC_VER} )"
+ELTCONF="--patch-only"
+DOCS="doc/README.OFX doc/README.HBCI"
+
+# FIXME: no the best thing to do but it'd be even better to fix autofoo
+#MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ ewarn "This is one of several unstable 2.3.x releases of the GnuCash Free"
+ ewarn "Accounting Software which will eventually lead to the stable version"
+ ewarn "2.4.0."
+ ewarn "This release is intended for developers and testers who want to help"
+ ewarn "tracking down all those bugs that are still in there."
+ ewarn ""
+ ewarn "WARNING WARNING WARNING"
+ ewarn "Make sure you make backups of any files used in testing versions of"
+ ewarn "GnuCash in the 2.3.x series."
+
+ if use webkit ; then
+ G2CONF="${G2CONF} --with-html-engine=webkit"
+ else
+ G2CONF="${G2CONF} --with-html-engine=gtkhtml"
+ fi
+
+ if use sqlite || use mysql || use postgres ; then
+ G2CONF="${G2CONF}
+ --enable-dbi"
+ fi
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_enable ofx)
+ $(use_enable hbci aqbanking)
+ --disable-doxygen
+ --enable-locale-specific-tax
+ --disable-error-on-warning"
+}
+
+src_unpack() {
+ default
+ cp "${FILESDIR}"/test-dbi-stuff.h "${S}"/src/backend/dbi/test || die
+}
+
+src_test() {
+ GUILE_WARN_DEPRECATED=no \
+ GNC_DOT_DIR="${T}"/.gnucash \
+ emake check \
+ || die "Make check failed. See above for details."
+}
+
+src_install() {
+ gnome2_src_install GNC_DOC_INSTALL_DIR=/usr/share/doc/${PF}
+
+ rm -rf "${D}"/usr/share/doc/${PF}/{examples/,COPYING,INSTALL,*win32-bin.txt,projects.html}
+# prepalldocs
+ mv "${D}"/usr/share/doc/${PF} "${T}"/cantuseprepalldocs || die
+ dodoc "${T}"/cantuseprepalldocs/* || die
+ find "${D}" -name '*.la' -delete || die
+}