summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-08-12 08:20:26 +0000
committerJustin Lecher <jlec@gentoo.org>2014-08-12 08:20:26 +0000
commitc3ebb5e11f6a88b1c120b033b2984f23b0e3f909 (patch)
tree0127bf3b8e469e371f9fcea256417b218b784aaa /app-office
parentx86 stable, see bug 502622 (diff)
downloadgentoo-2-c3ebb5e11f6a88b1c120b033b2984f23b0e3f909.tar.gz
gentoo-2-c3ebb5e11f6a88b1c120b033b2984f23b0e3f909.tar.bz2
gentoo-2-c3ebb5e11f6a88b1c120b033b2984f23b0e3f909.zip
app-office/texstudio: Version BUmp, #518430
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texstudio/ChangeLog8
-rw-r--r--app-office/texstudio/files/texstudio-2.8.2-desktop.patch22
-rw-r--r--app-office/texstudio/texstudio-2.8.2.ebuild83
3 files changed, 112 insertions, 1 deletions
diff --git a/app-office/texstudio/ChangeLog b/app-office/texstudio/ChangeLog
index bbe2bcc19311..205f35943197 100644
--- a/app-office/texstudio/ChangeLog
+++ b/app-office/texstudio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texstudio
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/ChangeLog,v 1.26 2014/07/06 11:00:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/ChangeLog,v 1.27 2014/08/12 08:20:26 jlec Exp $
+
+*texstudio-2.8.2 (12 Aug 2014)
+
+ 12 Aug 2014; Justin Lecher <jlec@gentoo.org> +texstudio-2.8.2.ebuild,
+ +files/texstudio-2.8.2-desktop.patch:
+ Version BUmp, #518430
*texstudio-2.8.0 (06 Jul 2014)
diff --git a/app-office/texstudio/files/texstudio-2.8.2-desktop.patch b/app-office/texstudio/files/texstudio-2.8.2-desktop.patch
new file mode 100644
index 000000000000..d464e8a4881f
--- /dev/null
+++ b/app-office/texstudio/files/texstudio-2.8.2-desktop.patch
@@ -0,0 +1,22 @@
+ utilities/texstudio.desktop | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/utilities/texstudio.desktop b/utilities/texstudio.desktop
+index 199255f..9c95afd 100644
+--- a/utilities/texstudio.desktop
++++ b/utilities/texstudio.desktop
+@@ -1,13 +1,12 @@
+ [Desktop Entry]
+ Categories=Office;Publishing;Qt;X-SuSE-Core-Office;X-Mandriva-Office-Publishing;X-Misc;
+-Encoding=UTF-8
+ Exec=texstudio %F
+ GenericName=LaTeX Editor
+ GenericName[fr]=Editeur LaTeX
+ Comment=LaTeX development environment
+ Comment[fr]=Environnement de développement LaTeX
+ Icon=texstudio
+-MimeType=text/x-tex;
++MimeType=text/X-tex;
+ Name=TeXstudio
+ StartupNotify=false
+ Terminal=false
diff --git a/app-office/texstudio/texstudio-2.8.2.ebuild b/app-office/texstudio/texstudio-2.8.2.ebuild
new file mode 100644
index 000000000000..43d8998ed8c5
--- /dev/null
+++ b/app-office/texstudio/texstudio-2.8.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/texstudio-2.8.2.ebuild,v 1.1 2014/08/12 08:20:26 jlec Exp $
+
+EAPI=5
+
+inherit base fdo-mime prefix qt4-r2
+
+DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
+HOMEPAGE="http://texstudio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/TeXstudio%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="video"
+
+COMMON_DEPEND="
+ app-text/hunspell
+ app-text/poppler:=[qt4]
+ dev-libs/quazip
+ x11-libs/libX11
+ x11-libs/libXext
+ || ( ( >=dev-qt/qtgui-4.8.5:4 dev-qt/designer:4 ) <dev-qt/qtgui-4.8.5:4 )
+ >=dev-qt/qtcore-4.6.1:4
+ >=dev-qt/qtscript-4.6.1:4
+ dev-qt/qtsingleapplication
+ >=dev-qt/qtsvg-4.6.1:4
+ >=dev-qt/qttest-4.6.1:4
+ video? ( media-libs/phonon )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/-/}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.4-hunspell-quazip.patch
+ "${FILESDIR}"/${P}-desktop.patch
+# Get it from fedora
+ "${FILESDIR}"/${PN}-2.5-viewers-use-xdg-open.patch
+ )
+
+src_prepare() {
+ find hunspell quazip utilities/poppler-data qtsingleapplication -delete || die
+
+ if use video; then
+ sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
+ fi
+
+ sed \
+ -e '/hunspell.pri/d' \
+ -e '/quazip.pri/d' \
+ -e '/qtsingleapplication.pri/d' \
+ -e '/QUAZIP_STATIC/d' \
+ -i ${PN}.pro || die
+
+# cat >> ${PN}.pro <<- EOF
+# exists(texmakerx_my.pri):include(texmakerx_my.pri)
+# EOF
+
+ cp "${FILESDIR}"/texmakerx_my.pri ${PN}.pri || die
+ eprefixify ${PN}.pri
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ local i
+ for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
+ insinto /usr/share/icons/hicolor/${i}
+ newins utilities/${PN}${i}.png ${PN}.png
+ done
+ qt4-r2_src_install
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}