summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-01-17 21:32:05 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-01-17 21:32:05 +0000
commitcf1334cfb51e5c81a444fe64f049066741260811 (patch)
tree1f491956fc12e96b14eda8aa55721d46bcee74e4 /app-office
parentadditional cleanups (diff)
downloadgentoo-2-cf1334cfb51e5c81a444fe64f049066741260811.tar.gz
gentoo-2-cf1334cfb51e5c81a444fe64f049066741260811.tar.bz2
gentoo-2-cf1334cfb51e5c81a444fe64f049066741260811.zip
ebuild cleanup
(Portage version: 2.0.51-r13)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice-bin/ChangeLog6
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild43
2 files changed, 21 insertions, 28 deletions
diff --git a/app-office/openoffice-bin/ChangeLog b/app-office/openoffice-bin/ChangeLog
index 296e78b4b20a..185235b8bc4b 100644
--- a/app-office/openoffice-bin/ChangeLog
+++ b/app-office/openoffice-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/openoffice-bin
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.59 2005/01/17 07:26:01 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.60 2005/01/17 21:32:05 suka Exp $
+
+ 17 Jan 2005; Andreas Proschofsky <suka@gentoo.org>
+ openoffice-bin-1.1.4.ebuild:
+ Some ebuild and dependency cleanups
17 Jan 2005; Andreas Proschofsky <suka@gentoo.org>
openoffice-bin-1.1.4.ebuild:
diff --git a/app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild b/app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild
index 51e303cd2715..cbca1fb8993e 100644
--- a/app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild
+++ b/app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild
@@ -1,37 +1,38 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild,v 1.7 2005/01/17 07:26:01 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild,v 1.8 2005/01/17 21:32:05 suka Exp $
# NOTE: There are two big issues that should be addressed.
#
# 1) Language support and fonts should be addressed.
-LOC="/opt"
+IUSE="gnome java kde"
-INSTDIR="${LOC}/OpenOffice.org"
+INSTDIR="/opt/OpenOffice.org"
MY_P="OOo_${PV}_LinuxIntel_install"
use ppc && MY_P="OOo_${PV}_LinuxPowerPC_en_installer"
S="${WORKDIR}/${MY_P}"
-
DESCRIPTION="OpenOffice productivity suite"
-HOMEPAGE="http://www.openoffice.org/"
+
SRC_URI="x86? ( mirror://openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz ) \
amd64? (mirror://openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz )"
+HOMEPAGE="http://www.openoffice.org/"
+
LICENSE="|| ( LGPL-2 SISSL-1.1 )"
SLOT="0"
KEYWORDS="x86 ~amd64"
-IUSE="gnome java kde"
-RDEPEND="sys-apps/findutils
+RDEPEND="!app-office/openoffice
+ virtual/x11
virtual/libc
+ virtual/lpr
>=dev-lang/perl-5.0
- virtual/x11
+ sys-apps/findutils
app-arch/zip
app-arch/unzip
java? ( >=virtual/jre-1.4.1 )
- !app-office/openoffice
amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )"
DEPEND="${RDEPEND}"
@@ -40,15 +41,13 @@ src_install() {
# Sandbox issues; bug #8587
addpredict "/user"
addpredict "/share"
- addpredict "/pspfontcache"
+ addpredict "/dev/dri"
addpredict "/usr/bin/soffice"
+ addpredict "/pspfontcache"
addpredict "/root/.gconfd"
addpredict "/opt/OpenOffice.org/foo.tmp"
addpredict "/opt/OpenOffice.org/delme"
- # Sandbox issues; bug 8063
- addpredict "/dev/dri"
-
# Autoresponse file for main installation
cat > ${T}/rsfile-global <<-"END_RS"
[ENVIRONMENT]
@@ -76,17 +75,16 @@ src_install() {
# Fixing install location in response file
sed -e "s|<destdir>|${D}${INSTDIR}|" \
- ${T}/rsfile-global > ${T}/autoresponse
+ ${T}/rsfile-global > ${T}/autoresponse || die
einfo "Installing OpenOffice.org into build root..."
dodir ${INSTDIR}
cd ${S}
- ./setup -nogui -v -r:${T}/autoresponse || die "The setup program failed"
+ ./setup -v -noexit -nogui -r:${T}/autoresponse || die "Setup failed"
- echo
einfo "Removing build root from registry..."
# Remove totally useless stuff.
- rm -f ${D}${INSTDIR}/program/{setup.log,sopatchlevel.sh}
+ rm -f ${D}${INSTDIR}/program/{setup.log,sopatchlevel.sh} || die
# Remove build root from registry and co
egrep -rl "${D}" ${D}${INSTDIR}/* | \
xargs -i perl -pi -e "s|${D}||g" {} || :
@@ -96,15 +94,6 @@ src_install() {
find ${D}${INSTDIR}/ -type f -exec chmod a+r {} \;
chmod a+x ${D}${INSTDIR}/share/config/webcast/*.pl
- # Fix symlinks
- for x in "soffice program/spadmin" \
- "program/setup setup" \
- "program/spadmin spadmin"
- do
- dosym $(echo ${x} | awk '{print $1}') \
- ${INSTDIR}/$(echo ${x} | awk '{print $2}')
- done
-
# Install user autoresponse file
insinto /etc/openoffice
sed -e "s|<pv>|${PV}|g" ${T}/rsfile-local > ${T}/autoresponse-${PV}.conf
@@ -167,7 +156,7 @@ src_install() {
# Remove unneeded stuff
- rm -rf ${D}${INSTDIR}/share/cde
+ rm -rf ${D}${INSTDIR}/share/cde || die
# Fix instdb.ins, to *not* install local copies of these
for entry in Kdeapplnk Kdemimetext Kdeicons Gnome_Apps Gnome_Icons Gnome2_Apps; do