summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-01-18 11:06:12 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-01-18 11:06:12 +0000
commitf2626da5c9bee6b3009c2e96d432c25a773c8b27 (patch)
treef3bbc6c09cc74451662919dd8496fe8dd383a8af /app-office
parentAdd missing net-wireless/bluez-utils:udev USE flag. (diff)
downloadgentoo-2-f2626da5c9bee6b3009c2e96d432c25a773c8b27.tar.gz
gentoo-2-f2626da5c9bee6b3009c2e96d432c25a773c8b27.tar.bz2
gentoo-2-f2626da5c9bee6b3009c2e96d432c25a773c8b27.zip
Fly-by bump, with modular X dependencies added.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/plan/ChangeLog9
-rw-r--r--app-office/plan/files/digest-plan-1.92
-rw-r--r--app-office/plan/plan-1.9.ebuild66
3 files changed, 75 insertions, 2 deletions
diff --git a/app-office/plan/ChangeLog b/app-office/plan/ChangeLog
index 898fbba5ed0b..6b0800631fad 100644
--- a/app-office/plan/ChangeLog
+++ b/app-office/plan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/plan
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/plan/ChangeLog,v 1.9 2005/05/23 08:22:24 dholm Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/plan/ChangeLog,v 1.10 2006/01/18 11:06:12 spyderous Exp $
+
+*plan-1.9 (18 Jan 2006)
+
+ 18 Jan 2006; Donnie Berkholz <spyderous@gentoo.org>; +plan-1.9.ebuild:
+ Fly-by bump, with modular X dependencies added.
23 May 2005; David Holm <dholm@gentoo.org> plan-1.8.7.ebuild:
Fixed bug #63533
diff --git a/app-office/plan/files/digest-plan-1.9 b/app-office/plan/files/digest-plan-1.9
new file mode 100644
index 000000000000..2f0767d8030e
--- /dev/null
+++ b/app-office/plan/files/digest-plan-1.9
@@ -0,0 +1,2 @@
+MD5 e4b7f0d42783638168f81ebb2496e25e plan-1.9-gentoo.tar.bz2 5642
+MD5 ab9e6b67c7b087f130c030aa779ef01d plan-1.9.tar.gz 441599
diff --git a/app-office/plan/plan-1.9.ebuild b/app-office/plan/plan-1.9.ebuild
new file mode 100644
index 000000000000..ed69ca52e17c
--- /dev/null
+++ b/app-office/plan/plan-1.9.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/plan/plan-1.9.ebuild,v 1.1 2006/01/18 11:06:12 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="Motif based schedule planner"
+HOMEPAGE="http://www.bitrot.de/plan.html"
+SRC_URI="ftp://plan.ftp.fu-berlin.de/unix/X11/apps/plan/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
+
+DEPEND="x11-libs/openmotif"
+
+S=${WORKDIR}/${P}/src
+
+src_unpack() {
+ unpack ${A}
+ epatch ${WORKDIR}/${P}-errno.patch
+ epatch ${WORKDIR}/${P}-gentoo.patch
+ epatch ${WORKDIR}/${P}-webplan.patch
+}
+
+src_compile() {
+ make SHARE=/usr/share/plan linux || die "make failed"
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ SHARE=/usr/share/plan \
+ install || die "install failed"
+ keepdir /usr/share/plan/netplan.dir
+
+ cd ${S}/..
+ dodoc HISTORY README || die "dodoc failed"
+
+ cd ${S}/../misc
+ doman netplan.1 plan.1 plan.4 || die "doman failed"
+
+ insinto /usr/share/${PN}/misc
+ doins netplan.boot BlackWhite Monochrome plan.fti Plan.xpm plan.xpm \
+ || die "misc files install failed"
+ exeinto /usr/share/${PN}/misc
+ doexe Killpland cvs vsc msschedule2plan plan2vcs || die "misc files install failed"
+
+ cd ${S}/../web
+ insinto /usr/share/${PN}/web
+ doins help.html bottom.html cgi-lib.pl common.pl holiday_webplan rtsban.jpg \
+ || die "webplan install failed"
+ exeinto /usr/share/${PN}/web
+ doexe *.cgi || die "webplan install failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo " Check /usr/share/${PN}/holiday for examples to set your"
+ einfo " ~/.holiday according to your country."
+ einfo
+ einfo " WebPlan 1.8 can be found in /usr/share/${PN}/web."
+ einfo
+}