summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-10-23 09:39:44 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-10-23 09:39:44 +0000
commitfc5ea9c975b614b0f1e052f1bf380a0b8803f405 (patch)
tree8e43068bd6bfbd9dcbdd4686914df6623b292fd9 /app-office
parentVersion Bump (diff)
downloadgentoo-2-fc5ea9c975b614b0f1e052f1bf380a0b8803f405.tar.gz
gentoo-2-fc5ea9c975b614b0f1e052f1bf380a0b8803f405.tar.bz2
gentoo-2-fc5ea9c975b614b0f1e052f1bf380a0b8803f405.zip
Add binaries for x86 too.
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice-bin/ChangeLog6
-rw-r--r--app-office/libreoffice-bin/libreoffice-bin-3.4.3.2-r1.ebuild40
2 files changed, 35 insertions, 11 deletions
diff --git a/app-office/libreoffice-bin/ChangeLog b/app-office/libreoffice-bin/ChangeLog
index f88cfe5471be..65fdc5257745 100644
--- a/app-office/libreoffice-bin/ChangeLog
+++ b/app-office/libreoffice-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/libreoffice-bin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin/ChangeLog,v 1.38 2011/10/22 12:26:53 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin/ChangeLog,v 1.39 2011/10/23 09:39:44 scarabeus Exp $
+
+ 23 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ libreoffice-bin-3.4.3.2-r1.ebuild:
+ Add binaries for x86 too.
22 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org>
libreoffice-bin-3.4.3.2-r1.ebuild:
diff --git a/app-office/libreoffice-bin/libreoffice-bin-3.4.3.2-r1.ebuild b/app-office/libreoffice-bin/libreoffice-bin-3.4.3.2-r1.ebuild
index 13b9e743703d..51c827181123 100644
--- a/app-office/libreoffice-bin/libreoffice-bin-3.4.3.2-r1.ebuild
+++ b/app-office/libreoffice-bin/libreoffice-bin-3.4.3.2-r1.ebuild
@@ -1,37 +1,57 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin/libreoffice-bin-3.4.3.2-r1.ebuild,v 1.4 2011/10/22 12:26:53 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin/libreoffice-bin-3.4.3.2-r1.ebuild,v 1.5 2011/10/23 09:39:44 scarabeus Exp $
EAPI=4
KDE_REQUIRED="optional"
CMAKE_REQUIRED="never"
-BASE_URI="http://dev.gentooexperimental.org/~scarabeus/libreo_binary/amd64/"
+BASE_URI="http://dev.gentooexperimental.org/~scarabeus/libreo_binary/"
inherit kde4-base java-pkg-opt-2 pax-utils
DESCRIPTION="LibreOffice, a full office productivity suite. Binary package"
HOMEPAGE="http://www.libreoffice.org"
-SRC_URI="
+SRC_URI_AMD64="
+ kde? (
+ !java? ( ${BASE_URI}/amd64/${PN/-bin}-kde-${PVR}.tbz2 -> ${PN/-bin}-kde-amd64-${PVR}.tbz2 )
+ java? ( ${BASE_URI}/amd64/${PN/-bin}-kde-java-${PVR}.tbz2 -> ${PN/-bin}-kde-java-amd64-${PVR}.tbz2 )
+ )
+ gnome? (
+ !java? ( ${BASE_URI}/amd64/${PN/-bin}-gnome-${PVR}.tbz2 -> ${PN/-bin}-gnome-amd64-${PVR}.tbz2 )
+ java? ( ${BASE_URI}/amd64/${PN/-bin}-gnome-java-${PVR}.tbz2 -> ${PN/-bin}-gnome-java-amd64-${PVR}.tbz2 )
+ )
+ !kde? ( !gnome? (
+ !java? ( ${BASE_URI}/amd64/${PN/-bin}-base-${PVR}.tbz2 -> ${PN/-bin}-base-amd64-${PVR}.tbz2 )
+ java? ( ${BASE_URI}/amd64/${PN/-bin}-base-java-${PVR}.tbz2 -> ${PN/-bin}-base-java-amd64-${PVR}.tbz2 )
+ ) )
+"
+
+SRC_URI_X86="
kde? (
- !java? ( ${BASE_URI}/${PN/-bin}-kde-${PVR}.tbz2 )
- java? ( ${BASE_URI}/${PN/-bin}-kde-java-${PVR}.tbz2 )
+ !java? ( ${BASE_URI}/x86/${PN/-bin}-kde-${PVR}.tbz2 -> ${PN/-bin}-kde-x86-${PVR}.tbz2 )
+ java? ( ${BASE_URI}/x86/${PN/-bin}-kde-java-${PVR}.tbz2 -> ${PN/-bin}-kde-java-x86-${PVR}.tbz2 )
)
gnome? (
- !java? ( ${BASE_URI}/${PN/-bin}-gnome-${PVR}.tbz2 )
- java? ( ${BASE_URI}/${PN/-bin}-gnome-java-${PVR}.tbz2 )
+ !java? ( ${BASE_URI}/x86/${PN/-bin}-gnome-${PVR}.tbz2 -> ${PN/-bin}-gnome-x86-${PVR}.tbz2 )
+ java? ( ${BASE_URI}/x86/${PN/-bin}-gnome-java-${PVR}.tbz2 -> ${PN/-bin}-gnome-java-x86-${PVR}.tbz2 )
)
!kde? ( !gnome? (
- !java? ( ${BASE_URI}/${PN/-bin}-base-${PVR}.tbz2 )
- java? ( ${BASE_URI}/${PN/-bin}-base-java-${PVR}.tbz2 )
+ !java? ( ${BASE_URI}/x86/${PN/-bin}-base-${PVR}.tbz2 -> ${PN/-bin}-base-x86-${PVR}.tbz2 )
+ java? ( ${BASE_URI}/x86/${PN/-bin}-base-java-${PVR}.tbz2 -> ${PN/-bin}-base-java-x86-${PVR}.tbz2 )
) )
"
+SRC_URI="
+ amd64? ( ${SRC_URI_AMD64} )
+ x86? ( ${SRC_URI_X86} )
+"
+
IUSE="gnome java kde"
LICENSE="LGPL-3"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
COMMON_DEPEND="
app-arch/zip