summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-06-26 23:01:57 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-06-26 23:01:57 +0000
commitfd33624d2cbd3c260ba271ea6e3c9f08b88747bd (patch)
tree0ff5a1dc7cc6f9f6ce51fa6be3f4df79d26ef69a /app-pda/gnome-pilot
parentRevision bump, includes yahoo authentication patch from bitlbee.org. (Manifes... (diff)
downloadgentoo-2-fd33624d2cbd3c260ba271ea6e3c9f08b88747bd.tar.gz
gentoo-2-fd33624d2cbd3c260ba271ea6e3c9f08b88747bd.tar.bz2
gentoo-2-fd33624d2cbd3c260ba271ea6e3c9f08b88747bd.zip
added patch to prevent segv on missing /proc/bus/usb/devices (#42378)
Diffstat (limited to 'app-pda/gnome-pilot')
-rw-r--r--app-pda/gnome-pilot/ChangeLog6
-rw-r--r--app-pda/gnome-pilot/files/gnome-pilot-2.0.10-missing_proc.patch14
-rw-r--r--app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild5
3 files changed, 23 insertions, 2 deletions
diff --git a/app-pda/gnome-pilot/ChangeLog b/app-pda/gnome-pilot/ChangeLog
index 25a66121a7e0..87730659380d 100644
--- a/app-pda/gnome-pilot/ChangeLog
+++ b/app-pda/gnome-pilot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/gnome-pilot
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/ChangeLog,v 1.10 2004/06/24 21:42:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/ChangeLog,v 1.11 2004/06/26 23:01:57 liquidx Exp $
+
+ 26 Jun 2004; Alastair Tse <liquidx@gentoo.org>
+ +files/gnome-pilot-2.0.10-missing_proc.patch, gnome-pilot-2.0.10-r1.ebuild:
+ added patch to prevent segv on missing /proc/bus/usb/devices (#42378)
04 Feb 2004; Alastair Tse <liquidx@gentoo.org> gnome-pilot-2.0.10-r1.ebuild,
files/gnome-pilot-2.0.10-treo600.patch:
diff --git a/app-pda/gnome-pilot/files/gnome-pilot-2.0.10-missing_proc.patch b/app-pda/gnome-pilot/files/gnome-pilot-2.0.10-missing_proc.patch
new file mode 100644
index 000000000000..d664d47a3ccc
--- /dev/null
+++ b/app-pda/gnome-pilot/files/gnome-pilot-2.0.10-missing_proc.patch
@@ -0,0 +1,14 @@
+--- gpilotd/gpilotd.c 2004-06-26 21:35:21.110836648 -0400
++++ gpilotd/gpilotd.c.new 2004-06-26 21:41:14.703082456 -0400
+@@ -858,6 +858,11 @@
+ /* Check /proc/bus/usb/devices for a usb device */
+ f = fopen ("/proc/bus/usb/devices", "r");
+
++ if (f == NULL) {
++ g_warning("/proc/bus/usb/devices: %s\n", strerror(errno));
++ return FALSE;
++ }
++
+ while (fgets (line, 255, f) != NULL && !visor_exists) {
+ if (line[0] != 'P')
+ continue;
diff --git a/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild b/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild
index 782c42f6fe85..2e2963999dbc 100644
--- a/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild
+++ b/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild,v 1.7 2004/06/24 21:42:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild,v 1.8 2004/06/26 23:01:57 liquidx Exp $
inherit gnome2 eutils
@@ -39,4 +39,7 @@ src_unpack() {
# add treo600 support
# http://bugzilla.gnome.org/show_bug.cgi?id=124254
epatch ${FILESDIR}/${P}-treo600.patch
+ # prevent segv if /proc/bus/usb/devices is missing
+ # http://mail.gnome.org/archives/gnome-pilot-list/2004-February/msg00013.html
+ cd ${S}; epatch ${FILESDIR}/${P}-missing_proc.patch
}