summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-01 19:22:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-01 19:22:48 +0000
commit5ca05a78ebab57e6c8d9e1d17473a9c25139afb6 (patch)
treea20d961f001a240aa81605178b1ea01daa47861f /app-pda/gtkpod
parentFix building with latest automake-1.13, plus other improvements, see ChangeLog (diff)
downloadgentoo-2-5ca05a78ebab57e6c8d9e1d17473a9c25139afb6.tar.gz
gentoo-2-5ca05a78ebab57e6c8d9e1d17473a9c25139afb6.tar.bz2
gentoo-2-5ca05a78ebab57e6c8d9e1d17473a9c25139afb6.zip
Use upstream git 8f833a3 snapshot dated 20130428 for multiple upstream fixes, including a fix for the "Track filter" wrt #466240 by David De Sousa
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-pda/gtkpod')
-rw-r--r--app-pda/gtkpod/ChangeLog9
-rw-r--r--app-pda/gtkpod/gtkpod-2.1.4_pre20130428.ebuild120
2 files changed, 128 insertions, 1 deletions
diff --git a/app-pda/gtkpod/ChangeLog b/app-pda/gtkpod/ChangeLog
index b9efb4ed6b2d..91b68cd4c4e6 100644
--- a/app-pda/gtkpod/ChangeLog
+++ b/app-pda/gtkpod/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/gtkpod
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gtkpod/ChangeLog,v 1.126 2013/05/01 19:09:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gtkpod/ChangeLog,v 1.127 2013/05/01 19:22:48 ssuominen Exp $
+
+*gtkpod-2.1.4_pre20130428 (01 May 2013)
+
+ 01 May 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +gtkpod-2.1.4_pre20130428.ebuild:
+ Use upstream git 8f833a3 snapshot dated 20130428 for multiple upstream fixes,
+ including a fix for the "Track filter" wrt #466240 by David De Sousa
01 May 2013; Samuli Suominen <ssuominen@gentoo.org> gtkpod-2.1.3-r1.ebuild:
Use AC_CONFIG_HEADERS instead of AM_CONFIG_HEADER for automake-1.13
diff --git a/app-pda/gtkpod/gtkpod-2.1.4_pre20130428.ebuild b/app-pda/gtkpod/gtkpod-2.1.4_pre20130428.ebuild
new file mode 100644
index 000000000000..0082298fd6a0
--- /dev/null
+++ b/app-pda/gtkpod/gtkpod-2.1.4_pre20130428.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gtkpod/gtkpod-2.1.4_pre20130428.ebuild,v 1.1 2013/05/01 19:22:48 ssuominen Exp $
+
+EAPI=5
+
+inherit autotools eutils gnome2-utils
+
+MY_P=${P/_pre*/~8f833a3}
+
+DESCRIPTION="A graphical user interface to the Apple productline"
+HOMEPAGE="http://gtkpod.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
+ http://dev.gentoo.org/~ssuominen/gst-element-check-0.10.m4.xz"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aac clutter curl cdr flac gstreamer mp3 vorbis webkit"
+
+# watch out for possible musicbrainz:5 compability in next version?
+COMMON_DEPEND="
+ >=dev-libs/gdl-3.6:3
+ >=dev-libs/glib-2.28.5
+ >=dev-libs/libxml2-2.7.7
+ >=dev-util/anjuta-3.6
+ >=media-libs/libgpod-0.8.2:=
+ >=media-libs/libid3tag-0.15
+ >=x11-libs/gtk+-3.0.8:3
+ aac? ( media-libs/faad2 )
+ clutter? ( media-libs/clutter-gtk:1.0 )
+ curl? ( >=net-misc/curl-7.10 )
+ flac? ( media-libs/flac )
+ gstreamer? (
+ >=media-libs/gstreamer-0.10.25:0.10
+ >=media-libs/gst-plugins-base-0.10.25:0.10
+ cdr? (
+ >=app-cdr/brasero-3
+ media-libs/musicbrainz:3
+ )
+ )
+ mp3? ( media-sound/lame )
+ vorbis? (
+ media-libs/libvorbis
+ media-sound/vorbis-tools
+ )
+ webkit? ( >=net-libs/webkit-gtk-1.3:3 )"
+# to pull in at least -flac and -vorbis plugins , but others at the same time
+RDEPEND="${COMMON_DEPEND}
+ gstreamer? ( media-plugins/gst-plugins-meta:0.10 )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/flex
+ sys-devel/gettext
+ virtual/os-headers
+ virtual/pkgconfig"
+REQUIRED_USE="cdr? ( gstreamer )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.3-gold.patch
+
+ sed -i -e 's:python:python2:' scripts/sync-palm-jppy.py || die
+ # punt deprecated flags for forward compability
+ # use more widely used musicbrainz:3 instead of :4
+ # use AC_CONFIG_HEADERS for automake-1.13 compability wrt #467598
+ sed -e 's:CLEANLINESS_FLAGS=".*:CLEANLINESS_FLAGS="":' \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ -e '/PKG_CHECK_MODULES/s:libmusicbrainz4:&sLoT4iSdEpReCaTeD:' \
+ -i configure.ac || die
+ # /path/to/install: '/path/to/app-pda/gtkpod-2.1.2_beta2/image/usr/share/gtkpod/data/rhythmbox.gep’: File exists
+ sed -i -e '/^dist_profiles_DATA/s:=.*:=:' plugins/sjcd/data/Makefile.am || die
+
+ # m4dir for gst-element-check-0.10.m4
+ AT_M4DIR=${WORKDIR} eautoreconf
+}
+
+src_configure() {
+ export GST_INSPECT=true #420279
+
+ econf \
+ --disable-static \
+ $(use_enable webkit plugin-coverweb) \
+ $(use_enable clutter plugin-clarity) \
+ $(use_enable gstreamer plugin-media-player) \
+ $(use_enable cdr plugin-sjcd) \
+ $(use_with curl) \
+ $(use_with vorbis ogg) \
+ $(use_with flac) \
+ $(use_with aac mp4)
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF}/html \
+ figuresdir=/usr/share/doc/${PF}/html/figures \
+ install
+
+ prune_libtool_files --all
+
+ dodoc AUTHORS ChangeLog NEWS README TODO TROUBLESHOOTING
+ rm -f "${ED}"/usr/share/gtkpod/data/{AUTHORS,COPYING} || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}