summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-02-20 03:40:57 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-02-20 03:40:57 +0000
commita2ae4c693c3e1a7c760e42f870ccb2d35507fc51 (patch)
tree78c98b79d4d8ea8260bd61731c66f1b50306f77c /app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild
parentUpdate live ebuild. (diff)
downloadgentoo-2-a2ae4c693c3e1a7c760e42f870ccb2d35507fc51.tar.gz
gentoo-2-a2ae4c693c3e1a7c760e42f870ccb2d35507fc51.tar.bz2
gentoo-2-a2ae4c693c3e1a7c760e42f870ccb2d35507fc51.zip
Fix dependencies, port to python eclass (bug #311765) and EAPI 3. Fix
building against new python versions (bug #276220). (Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild')
-rw-r--r--app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild25
1 files changed, 19 insertions, 6 deletions
diff --git a/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild b/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild
index 07f248c04333..10b86f1ccb35 100644
--- a/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild
+++ b/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild,v 1.1 2007/11/26 20:23:01 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild,v 1.2 2011/02/20 03:40:57 dirtyepic Exp $
-inherit cmake-utils subversion
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+
+inherit cmake-utils python subversion
DESCRIPTION="OpenSync Python Module"
HOMEPAGE="http://www.opensync.org/"
@@ -15,6 +18,16 @@ SLOT="0"
LICENSE="LGPL-2.1"
IUSE=""
-DEPEND="=app-pda/libopensync-${PV}*
- >=dev-lang/python-2.0"
-RDEPEND="${DEPEND}"
+RDEPEND="~app-pda/libopensync-${PV}
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # hardcoded python versions, use the module shipped with cmake (bug #276220)
+ rm "${S}"/cmake/modules/FindPythonLibs.cmake || die
+}