summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-15 09:22:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-15 09:22:20 +0000
commitc9236fae7a13b4f2e69c0f3737a38a6a97514a1a (patch)
tree554d0e9ece9b7ac17746a79bb180daa4e665cbff /app-pda/synce-sync-engine
parentold (diff)
downloadgentoo-2-c9236fae7a13b4f2e69c0f3737a38a6a97514a1a.tar.gz
gentoo-2-c9236fae7a13b4f2e69c0f3737a38a6a97514a1a.tar.bz2
gentoo-2-c9236fae7a13b4f2e69c0f3737a38a6a97514a1a.zip
Use app-pda/synce-core instead of obsolete dev-libs/libsynce.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/synce-sync-engine')
-rw-r--r--app-pda/synce-sync-engine/ChangeLog8
-rw-r--r--app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild26
2 files changed, 19 insertions, 15 deletions
diff --git a/app-pda/synce-sync-engine/ChangeLog b/app-pda/synce-sync-engine/ChangeLog
index bda545ae507a..9b25e20e4169 100644
--- a/app-pda/synce-sync-engine/ChangeLog
+++ b/app-pda/synce-sync-engine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/synce-sync-engine
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/ChangeLog,v 1.14 2011/10/23 22:04:47 tetromino Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/ChangeLog,v 1.15 2012/06/15 09:22:20 ssuominen Exp $
+
+ 15 Jun 2012; Samuli Suominen <ssuominen@gentoo.org>
+ synce-sync-engine-0.15.1-r3.ebuild:
+ Use app-pda/synce-core instead of obsolete dev-libs/libsynce.
23 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
synce-sync-engine-0.15.1-r3.ebuild:
diff --git a/app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild b/app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild
index 40f7ee6eef69..e4e705da27d7 100644
--- a/app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild
+++ b/app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild,v 1.2 2011/10/23 22:04:47 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild,v 1.3 2012/06/15 09:22:20 ssuominen Exp $
-EAPI=3
+EAPI=4
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS=1
RESTRICT_PYTHON_ABIS="3.*"
inherit distutils multilib
DESCRIPTION="A synchronization engine for SynCE"
-HOMEPAGE="http://www.synce.org/"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
LICENSE="GPL-2"
@@ -19,9 +19,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="opensync"
-RDEPEND="dev-libs/librapi2[python]
- dev-libs/librra[python]
- dev-libs/librtfcomp[python]
+RDEPEND="app-pda/synce-core[python]
+ >=dev-libs/librra-0.16[python]
+ >=dev-libs/librtfcomp-1.2[python]
dev-libs/libxml2[python]
dev-libs/libxslt[python]
dev-python/dbus-python
@@ -30,9 +30,9 @@ RDEPEND="dev-libs/librapi2[python]
>=app-pda/libopensync-0.39[python]
( =app-pda/libopensync-0.22*[python] app-pda/libopensync-plugin-python )
) )"
-DEPEND="${RDEPEND}"
+DEPEND=${RDEPEND}
-PYTHON_MODNAME="SyncEngine"
+PYTHON_MODNAME=SyncEngine
src_prepare() {
sed -i -e 's:share/doc/sync-engine:foobar:' setup.py || die
@@ -50,7 +50,7 @@ src_install() {
distutils_src_install
### opensync plug-in BEGIN
- find "${D}" -type d -name plugins -exec rm -rf {} +
+ find "${ED}" -type d -name plugins -exec rm -rf {} +
if use opensync; then
local plug=plugins/synce-opensync-plugin-
@@ -69,5 +69,5 @@ src_install() {
fi
### opensync plug-in END
- rm -rf "${D}"/usr/foobar
+ rm -rf "${ED}"/usr/foobar
}