summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-15 11:10:55 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-15 11:10:55 +0000
commit3dce95bd9efea50e8e3abc80c7f15d4bfc601cb7 (patch)
tree4674427c55ac407543c7393649d87b9c5ea2b522 /app-portage
parentsci-chemistry/ccpn: Todays python patches (diff)
downloadgentoo-2-3dce95bd9efea50e8e3abc80c7f15d4bfc601cb7.tar.gz
gentoo-2-3dce95bd9efea50e8e3abc80c7f15d4bfc601cb7.tar.bz2
gentoo-2-3dce95bd9efea50e8e3abc80c7f15d4bfc601cb7.zip
app-portage/euscan: Bump to python r1 eclasses
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/euscan/ChangeLog8
-rw-r--r--app-portage/euscan/euscan-0.1.1-r1.ebuild34
-rw-r--r--app-portage/euscan/euscan-9999.ebuild40
-rw-r--r--app-portage/euscan/metadata.xml9
4 files changed, 63 insertions, 28 deletions
diff --git a/app-portage/euscan/ChangeLog b/app-portage/euscan/ChangeLog
index 35fbb2001741..af2fa25020b8 100644
--- a/app-portage/euscan/ChangeLog
+++ b/app-portage/euscan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/euscan
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/euscan/ChangeLog,v 1.10 2013/08/26 16:51:26 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/euscan/ChangeLog,v 1.11 2013/10/15 11:10:55 jlec Exp $
+
+*euscan-0.1.1-r1 (15 Oct 2013)
+
+ 15 Oct 2013; Justin Lecher <jlec@gentoo.org> +euscan-0.1.1-r1.ebuild,
+ euscan-9999.ebuild, metadata.xml:
+ Bump to python r1 eclasses
26 Aug 2013; Sébastien Fabbro <bicatali@gentoo.org> euscan-0.1.1.ebuild:
Keyword amd64-linux and x86-linux
diff --git a/app-portage/euscan/euscan-0.1.1-r1.ebuild b/app-portage/euscan/euscan-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..36b542f6940a
--- /dev/null
+++ b/app-portage/euscan/euscan-0.1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/euscan/euscan-0.1.1-r1.ebuild,v 1.1 2013/10/15 11:10:55 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Ebuild upstream scan utility"
+HOMEPAGE="http://euscan.iksaif.net"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.2.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ python_export_best
+ echo VERSION="${PV}" "${PYTHON}" setup.py set_version
+ VERSION="${PV}" "${PYTHON}" setup.py set_version
+ distutils-r1_python_prepare_all
+}
diff --git a/app-portage/euscan/euscan-9999.ebuild b/app-portage/euscan/euscan-9999.ebuild
index 9ee782079ad3..a8a0283f41d7 100644
--- a/app-portage/euscan/euscan-9999.ebuild
+++ b/app-portage/euscan/euscan-9999.ebuild
@@ -1,20 +1,18 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/euscan/euscan-9999.ebuild,v 1.4 2012/10/29 16:27:36 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/euscan/euscan-9999.ebuild,v 1.5 2013/10/15 11:10:55 jlec Exp $
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.[45] 3.* 2.7-pypy-*"
-PYTHON_USE_WITH="xml"
-PYTHON_NONVERSIONED_EXECUTABLES=(".*")
+EAPI=5
-inherit distutils python git-2
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="xml"
-EGIT_REPO_URI="git://github.com/iksaif/euscan.git"
+inherit distutils-r1 git-2
DESCRIPTION="Ebuild upstream scan utility"
HOMEPAGE="http://euscan.iksaif.net"
SRC_URI=""
+EGIT_REPO_URI="git://github.com/iksaif/euscan.git"
LICENSE="GPL-2"
SLOT="0"
@@ -22,18 +20,16 @@ IUSE=""
KEYWORDS=""
-DEPEND="sys-apps/portage"
+DEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
- >=app-portage/gentoolkit-0.2.8
- dev-python/setuptools
- dev-python/beautifulsoup:python-2
- virtual/python-argparse"
-
-distutils_src_compile_pre_hook() {
- echo VERSION="9999-${EGIT_VERSION}" "$(PYTHON)" setup.py set_version
- VERSION="9999-${EGIT_VERSION}" "$(PYTHON)" setup.py set_version
-}
-
-src_compile() {
- distutils_src_compile
+ >=app-portage/gentoolkit-0.2.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ python_export_best
+ echo VERSION="${PV}" "${PYTHON}" setup.py set_version
+ VERSION="${PV}" "${PYTHON}" setup.py set_version
+ distutils-r1_python_prepare_all
}
diff --git a/app-portage/euscan/metadata.xml b/app-portage/euscan/metadata.xml
index 63a6207b5bc7..bcc2cc5f2da5 100644
--- a/app-portage/euscan/metadata.xml
+++ b/app-portage/euscan/metadata.xml
@@ -1,9 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>iksaif@gentoo.org</email>
- <name>Corentin Chary</name>
- </maintainer>
+ <maintainer>
+ <email>iksaif@gentoo.org</email>
+ <name>Corentin Chary</name>
+ </maintainer>
</pkgmetadata>
-