summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-06-06 06:21:55 +0000
committerMike Frysinger <vapier@gentoo.org>2015-06-06 06:21:55 +0000
commit5a79354b3ec43b386ea181eea2a19557ead38ce7 (patch)
treec0c57a8c2da9b91c1cc32f0fc9d9e68210a48ed4 /app-portage
parentUpdate HOMEPAGE. (diff)
downloadgentoo-2-5a79354b3ec43b386ea181eea2a19557ead38ce7.tar.gz
gentoo-2-5a79354b3ec43b386ea181eea2a19557ead38ce7.tar.bz2
gentoo-2-5a79354b3ec43b386ea181eea2a19557ead38ce7.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portage-utils/ChangeLog7
-rw-r--r--app-portage/portage-utils/portage-utils-0.56.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/app-portage/portage-utils/ChangeLog b/app-portage/portage-utils/ChangeLog
index 79cf4dfd6acf..45a36f88e01b 100644
--- a/app-portage/portage-utils/ChangeLog
+++ b/app-portage/portage-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/portage-utils
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/portage-utils/ChangeLog,v 1.161 2015/05/19 17:39:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portage-utils/ChangeLog,v 1.162 2015/06/06 06:21:55 vapier Exp $
+
+*portage-utils-0.56 (06 Jun 2015)
+
+ 06 Jun 2015; Mike Frysinger <vapier@gentoo.org> +portage-utils-0.56.ebuild:
+ Version bump.
*portage-utils-0.55 (19 May 2015)
diff --git a/app-portage/portage-utils/portage-utils-0.56.ebuild b/app-portage/portage-utils/portage-utils-0.56.ebuild
new file mode 100644
index 000000000000..4e201707b86b
--- /dev/null
+++ b/app-portage/portage-utils/portage-utils-0.56.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portage-utils/portage-utils-0.56.ebuild,v 1.1 2015/06/06 06:21:55 vapier Exp $
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="small and fast portage helper tools written in C"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static"
+
+DEPEND="app-arch/xz-utils
+ static? ( dev-libs/iniparser[static-libs] )"
+RDEPEND="!static? ( dev-libs/iniparser )"
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # Avoid slow configure+gnulib+make if on an up-to-date Linux system
+ if use prefix || ! use kernel_linux || \
+ has_version '<sys-libs/glibc-2.10'
+ then
+ econf --with-eprefix="${EPREFIX}"
+ else
+ tc-export CC
+ fi
+}
+
+src_compile() {
+ emake NLS=$(usex nls)
+}
+
+src_install() {
+ default
+
+ exeinto /etc/portage/bin
+ doexe "${FILESDIR}"/post_sync
+ insinto /etc/portage/postsync.d
+ doins "${FILESDIR}"/q-reinitialize
+
+ # Portage fixes shebangs, we just need to fix the paths in the files
+ sed -i \
+ -e "s:\(/etc/portage/postsync.d\|/usr/bin/q\):${EPREFIX}&:g" \
+ "${ED}"/etc/portage/bin/post_sync \
+ "${ED}"/etc/portage/postsync.d/q-reinitialize || die
+}
+
+pkg_preinst() {
+ # preserve +x bit on postsync files #301721
+ local x
+ pushd "${ED}" >/dev/null
+ for x in etc/portage/postsync.d/* ; do
+ [[ -x ${EROOT}/${x} ]] && chmod +x "${x}"
+ done
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "${EPREFIX}/etc/portage/postsync.d/q-reinitialize has been installed for convenience"
+ elog "If you wish for it to be automatically run at the end of every --sync:"
+ elog " # chmod +x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
+ elog "Normally this should only take a few seconds to run but file systems"
+ elog "such as ext3 can take a lot longer. To disable, simply do:"
+ elog " # chmod -x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
+ fi
+}