summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2013-09-11 17:51:19 +0000
committerPaul Varner <fuzzyray@gentoo.org>2013-09-11 17:51:19 +0000
commit63c555e93f730bd4e56afb88d57a66798332bfee (patch)
treee4cb2f050e67c80e79ff41ed5adec115f4f88154 /app-portage
parentbump dvipsk/ps2pkm deps, bug #482728 (diff)
downloadgentoo-2-63c555e93f730bd4e56afb88d57a66798332bfee.tar.gz
gentoo-2-63c555e93f730bd4e56afb88d57a66798332bfee.tar.bz2
gentoo-2-63c555e93f730bd4e56afb88d57a66798332bfee.zip
Revision bump to add patch to get PORTDIR from portageq (Bug 478318).
(Portage version: 2.2.2/cvs/Linux x86_64, signed Manifest commit with key 0xDCB4A7FF)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/ufed/ChangeLog8
-rw-r--r--app-portage/ufed/files/ufed-0.90_rc2-get_portdir_from_portageq.patch99
-rw-r--r--app-portage/ufed/ufed-0.90_rc2-r1.ebuild41
3 files changed, 147 insertions, 1 deletions
diff --git a/app-portage/ufed/ChangeLog b/app-portage/ufed/ChangeLog
index 4a93afc2e494..fe6bdd656995 100644
--- a/app-portage/ufed/ChangeLog
+++ b/app-portage/ufed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/ufed
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ChangeLog,v 1.99 2013/04/12 14:29:14 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ChangeLog,v 1.100 2013/09/11 17:51:19 fuzzyray Exp $
+
+*ufed-0.90_rc2-r1 (11 Sep 2013)
+
+ 11 Sep 2013; Paul Varner <fuzzyray@gentoo.org> +ufed-0.90_rc2-r1.ebuild,
+ +files/ufed-0.90_rc2-get_portdir_from_portageq.patch:
+ Revision bump to add patch to get PORTDIR from portageq (Bug 478318).
*ufed-0.90_rc2 (12 Apr 2013)
diff --git a/app-portage/ufed/files/ufed-0.90_rc2-get_portdir_from_portageq.patch b/app-portage/ufed/files/ufed-0.90_rc2-get_portdir_from_portageq.patch
new file mode 100644
index 000000000000..b66398a824f6
--- /dev/null
+++ b/app-portage/ufed/files/ufed-0.90_rc2-get_portdir_from_portageq.patch
@@ -0,0 +1,99 @@
+--- a/Portage.pm 2013-09-11 08:34:10.792161194 +0200
++++ b/Portage.pm 2013-09-11 09:00:45.737142232 +0200
+@@ -46,11 +46,13 @@
+ our $used_make_conf = "";
+
+ # --- private members ---
+-my %_environment = ();
+-my $_EPREFIX = "";
+-my @_profiles = ();
+-my %_use_eh_safe = (); ## USE_EXPAND_HIDDEN safe hash. See _read_make_defaults()
+-my %_use_order = ();
++my %_environment = ();
++my $_EPREFIX = "";
++my $_PORTDIR = "";
++my $_PORTDIR_OVERLAY = "";
++my @_profiles = ();
++my %_use_eh_safe = (); ## USE_EXPAND_HIDDEN safe hash. See _read_make_defaults()
++my %_use_order = ();
+
+ # $_use_temp - hashref that represents the current state of
+ # all known flags. This is for data gathering, the public
+@@ -87,7 +89,7 @@
+ # --- private methods ---
+ sub _add_flag;
+ sub _add_temp;
+-sub _determine_eprefix;
++sub _determine_eprefix_portdir;
+ sub _determine_make_conf;
+ sub _determine_profiles;
+ sub _final_cleaning;
+@@ -112,7 +114,7 @@
+ # --- Package initialization ---
+ INIT {
+ $_environment{$_} = {} for qw{USE USE_EXPAND USE_EXPAND_HIDDEN};
+- _determine_eprefix;
++ _determine_eprefix_portdir;
+ _determine_make_conf;
+ _determine_profiles;
+ _read_make_globals;
+@@ -223,14 +225,29 @@
+ }
+
+
+-# Determine the value for EPREFIX and save it
+-# in $_EPREFIX. This is done using 'portageq'.
++# Determine the values for EPREFIX, PORTDIR
++# and PORTDIR_OVERLAY. These are saved in
++# $_EPREFIX, $_PORTDIR and $_PORTDIR_OVERLAY.
++# This is done using 'portageq'.
+ # Other output from portageq is printed on
+ # STDERR.
+ # No parameters accepted.
+-sub _determine_eprefix {
++sub _determine_eprefix_portdir {
+ my $tmp = "/tmp/ufed_$$.tmp";
+- $_EPREFIX = qx{portageq envvar EPREFIX 2>$tmp};
++ my @res = map {
++ my $x = $_;
++ chomp $x;
++ $x =~ s/'//g;
++ $x
++ } qx{portageq envvar -v EPREFIX PORTDIR PORTDIR_OVERLAY 2>$tmp};
++
++ while (my $res = shift @res) {
++ if ($res =~ /^(.*)=(.*)$/) {
++ "EPREFIX" eq $1 and $_EPREFIX = $2;
++ "PORTDIR" eq $1 and $_PORTDIR = $2;
++ "PORTDIR_OVERLAY" eq $1 and $_PORTDIR_OVERLAY = $2;
++ }
++ }
+ die "Couldn't determine EPREFIX from Portage" if $? != 0;
+
+ if ( -s $tmp ) {
+@@ -241,7 +258,6 @@
+ }
+ -e $tmp and unlink $tmp;
+
+- chomp($_EPREFIX);
+ return;
+ }
+
+@@ -631,13 +647,11 @@
+ }
+
+ # Add PORTDIR and overlays to @_profiles
+- defined ($_environment{PORTDIR})
+- and push @_profiles, "$_environment{PORTDIR}/profiles"
++ length ($_PORTDIR)
++ and push @_profiles, "${_PORTDIR}/profiles"
+ or die("Unable to determine PORTDIR!\nSomething is seriously broken here!\n");
+- defined ($_environment{PORTDIR_OVERLAY})
+- and push @_profiles,
+- map { my $x=$_; $x =~ s/^\s*(\S+)\s*$/$1\/profiles/mg ; $x }
+- split('\n', $_environment{PORTDIR_OVERLAY});
++ length ($_PORTDIR_OVERLAY)
++ and push @_profiles, split(' ', $_PORTDIR_OVERLAY);
+ -e "${_EPREFIX}/etc/portage/profile"
+ and push @_profiles, "${_EPREFIX}/etc/portage/profile";
+ return;
diff --git a/app-portage/ufed/ufed-0.90_rc2-r1.ebuild b/app-portage/ufed/ufed-0.90_rc2-r1.ebuild
new file mode 100644
index 000000000000..dde0e40d7f91
--- /dev/null
+++ b/app-portage/ufed/ufed-0.90_rc2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ufed-0.90_rc2-r1.ebuild,v 1.1 2013/09/11 17:51:19 fuzzyray Exp $
+
+EAPI=5
+
+inherit base eutils multilib autotools
+
+DESCRIPTION="Gentoo Linux USE flags editor"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~fuzzyray/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+COMMON_DEPEND="sys-libs/ncurses"
+RDEPEND="${COMMON_DEPEND}
+ dev-lang/perl"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+# Populate the patches array for patches applied for -rX releases
+# It is an array of patch file names of the form:
+# "${FILESDIR}"/${P}-make.globals-path.patch
+PATCHES=(
+ "${FILESDIR}"/${P}-get_portdir_from_portageq.patch
+)
+
+src_prepare() {
+ base_src_prepare
+ # Change the version number to reflect the ebuild version
+ sed -i "s:,\[git\],:,\[${PVR}\],:" configure.ac
+ eautoreconf
+}
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}"/usr/$(get_libdir)/ufed
+}