summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-07-09 14:16:10 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-07-09 14:16:10 +0000
commitacae2de72a84a6230c0c68ba7e6171c3b4b4ca3d (patch)
tree839237a59e1bcf35b4babcf10b280c099b21625f /app-portage
parentadd RESTRICT=mirror, thanks to tove who caught it (diff)
downloadgentoo-2-acae2de72a84a6230c0c68ba7e6171c3b4b4ca3d.tar.gz
gentoo-2-acae2de72a84a6230c0c68ba7e6171c3b4b4ca3d.tar.bz2
gentoo-2-acae2de72a84a6230c0c68ba7e6171c3b4b4ca3d.zip
version bump, only minor bug fixes, but make it usable on sparc
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gatt/ChangeLog7
-rw-r--r--app-portage/gatt/gatt-0.6.2.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/app-portage/gatt/ChangeLog b/app-portage/gatt/ChangeLog
index 07c3836f660a..06a9676071ee 100644
--- a/app-portage/gatt/ChangeLog
+++ b/app-portage/gatt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/gatt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gatt/ChangeLog,v 1.14 2008/07/09 07:37:37 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gatt/ChangeLog,v 1.15 2008/07/09 14:16:10 opfer Exp $
+
+*gatt-0.6.2 (09 Jul 2008)
+
+ 09 Jul 2008; Christian Faulhammer <opfer@gentoo.org> +gatt-0.6.2.ebuild:
+ version bump, only minor bug fixes, but make it usable on sparc
09 Jul 2008; Christian Faulhammer <opfer@gentoo.org> -gatt-0.6.0.ebuild:
clean up
diff --git a/app-portage/gatt/gatt-0.6.2.ebuild b/app-portage/gatt/gatt-0.6.2.ebuild
new file mode 100644
index 000000000000..60323d9fa5aa
--- /dev/null
+++ b/app-portage/gatt/gatt-0.6.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gatt/gatt-0.6.2.ebuild,v 1.1 2008/07/09 14:16:10 opfer Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Arch Testing Tool for architecture tester and developer"
+HOMEPAGE="http://gatt.sourceforge.net/
+ http://www.gentoo.org/proj/en/base/x86/at.xml
+ http://www.gentoo.org/proj/en/base/ppc/AT/index.xml
+ http://www.gentoo.org/proj/en/base/amd64/at/index.xml
+ http://www.gentoo.org/proj/en/base/alpha/AT/index.xml"
+SRC_URI="mirror://sourceforge/gatt/${P}.tar.bz2"
+
+LICENSE="GPL-2 GPL-3 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc libpaludis"
+
+RDEPEND=">=dev-libs/boost-1.33.1
+ >=dev-cpp/libthrowable-1.1.0
+ www-client/pybugz
+ libpaludis? ( >=sys-apps/paludis-0.26.0_alpha9 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ ewarn "Gatt is targeted at Gentoo developers, arch-testers and power users. Do"
+ ewarn "by no means use it if you are new to Gentoo. You have been warned!"
+ ewarn
+ elog "There is an Info manual shipped with some extensive examples".
+ if use libpaludis && ! built_with_use sys-apps/paludis portage; then
+ ewarn "You either have to emerge Paludis with USE=portage enabled or configure"
+ ewarn "it properly before using Gatt with it."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_compile() {
+ econf $(use_enable libpaludis) || die
+ emake || die
+ use doc && doxygen
+}
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README NEWS AUTHORS ChangeLog
+
+ if use doc; then
+ dohtml doc/html/*
+ fi
+}