summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-10-23 15:55:12 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-10-23 15:55:12 +0000
commite0c430c1f3deda49fc89cb8bb1c7ad0a0f1b3bc5 (patch)
treef98e9c3ffd06ad8aa8041882ed5f149fa115e15a /app-portage
parentStable on sparc (diff)
downloadgentoo-2-e0c430c1f3deda49fc89cb8bb1c7ad0a0f1b3bc5.tar.gz
gentoo-2-e0c430c1f3deda49fc89cb8bb1c7ad0a0f1b3bc5.tar.bz2
gentoo-2-e0c430c1f3deda49fc89cb8bb1c7ad0a0f1b3bc5.zip
Version bump
(Portage version: 2.1.3.15)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portato/ChangeLog7
-rw-r--r--app-portage/portato/files/digest-portato-0.8.6.23
-rw-r--r--app-portage/portato/portato-0.8.6.2.ebuild106
3 files changed, 115 insertions, 1 deletions
diff --git a/app-portage/portato/ChangeLog b/app-portage/portato/ChangeLog
index 41b6bed79f0b..5a1061fabbbe 100644
--- a/app-portage/portato/ChangeLog
+++ b/app-portage/portato/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/portato
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/portato/ChangeLog,v 1.3 2007/10/22 15:06:58 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portato/ChangeLog,v 1.4 2007/10/23 15:55:11 jokey Exp $
+
+*portato-0.8.6.2 (23 Oct 2007)
+
+ 23 Oct 2007; Markus Ullmann <jokey@gentoo.org> +portato-0.8.6.2.ebuild:
+ Version bump
22 Oct 2007; Markus Ullmann <jokey@gentoo.org> portato-0.8.6.ebuild:
Some fixes from sunrise/portage-review
diff --git a/app-portage/portato/files/digest-portato-0.8.6.2 b/app-portage/portato/files/digest-portato-0.8.6.2
new file mode 100644
index 000000000000..f071b5346987
--- /dev/null
+++ b/app-portage/portato/files/digest-portato-0.8.6.2
@@ -0,0 +1,3 @@
+MD5 8710726c7b4a5db995bea447dfe9adde portato-0.8.6.2.tar.gz 110262
+RMD160 f1ccba67a5d2099fac3239a63dd6a02566bab80a portato-0.8.6.2.tar.gz 110262
+SHA256 67a8715ce8a73948acc81f50a450291fefbc91350c2009ab4c5b32e13896bbf5 portato-0.8.6.2.tar.gz 110262
diff --git a/app-portage/portato/portato-0.8.6.2.ebuild b/app-portage/portato/portato-0.8.6.2.ebuild
new file mode 100644
index 000000000000..a3a0b523ac9f
--- /dev/null
+++ b/app-portage/portato/portato-0.8.6.2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portato/portato-0.8.6.2.ebuild,v 1.1 2007/10/23 15:55:11 jokey Exp $
+
+NEED_PYTHON="2.5"
+inherit python eutils distutils
+
+DESCRIPTION="A GUI for Portage written in Python."
+HOMEPAGE="http://portato.origo.ethz.ch/"
+SRC_URI="http://download.origo.ethz.ch/portato/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="kde libnotify nls userpriv"
+
+RDEPEND=">=sys-apps/portage-2.1.2
+ >=dev-python/lxml-1.3.2
+ >=dev-python/pygtk-2.10.4
+ >=x11-libs/vte-0.12.2
+ >=gnome-base/libglade-2.5.1
+ >=dev-python/pygtksourceview-2.0.0
+ !dev-util/portatosourceview
+
+ !userpriv? (
+ kde? ( || ( >=kde-base/kdesu-3.5.5 >=kde-base/kdebase-3.5.5 ) )
+ !kde? ( >=x11-libs/gksu-2.0.0 ) )
+
+ libnotify? ( >=dev-python/notify-python-0.1.1 )
+ nls? ( virtual/libintl )"
+
+# only needs gettext as build dependency
+# python should be set as DEPEND in the python-eclass
+DEPEND="nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${PN}"
+CONFIG_DIR="etc/${PN}/"
+DATA_DIR="usr/share/${PN}/"
+LOCALE_DIR="usr/share/locale/"
+PLUGIN_DIR="${DATA_DIR}/plugins"
+ICON_DIR="${DATA_DIR}/icons"
+
+pkg_setup ()
+{
+ if ! built_with_use x11-libs/vte python; then
+ echo
+ eerror "x11-libs/vte has not been built with python support."
+ eerror "Please re-emerge vte with the python use-flag enabled."
+ die "missing python flag for x11-libs/vte"
+ fi
+}
+
+src_compile ()
+{
+ cd "${S}"
+
+ # currently only gtk is supported
+ local std="gtk"
+ local frontends="[\"$std\"]"
+
+ local su="\"gksu -D 'Portato'\""
+ use kde && su="\"kdesu -t --nonewdcop -i %s -c\" % APP_ICON"
+
+ sed -i -e "s;^\(VERSION\s*=\s*\).*;\1\"${PV}\";" \
+ -e "s;^\(CONFIG_DIR\s*=\s*\).*;\1\"${ROOT}${CONFIG_DIR}\";" \
+ -e "s;^\(DATA_DIR\s*=\s*\).*;\1\"${ROOT}${DATA_DIR}\";" \
+ -e "s;^\(TEMPLATE_DIR\s*=\s*\).*;\1DATA_DIR;" \
+ -e "s;^\(ICON_DIR\s*=\s*\).*;\1\"${ROOT}${ICON_DIR}\";" \
+ -e "s;^\(LOCALE_DIR\s*=\s*\).*;\1\"${ROOT}${LOCALE_DIR}\";" \
+ -e "s;^\(FRONTENDS\s*=\s*\).*;\1${frontends};" \
+ -e "s;^\(STD_FRONTEND\s*=\s*\).*;\1\"${std}\";" \
+ -e "s;^\(SU_COMMAND\s*=\s*\).*;\1${su};" \
+ -e "s;^\(USE_CATAPULT\s*=\s*\).*;\1False;" \
+ "${PN}"/constants.py
+
+ use userpriv && sed -i -e "s/Exec=.*/Exec=portato --no-listener/" portato.desktop
+ use nls && ./pocompile.sh -emerge
+
+ distutils_src_compile
+}
+
+src_install ()
+{
+ dodir ${DATA_DIR}
+ distutils_src_install
+
+ newbin portato.py portato
+ dodoc doc/*
+
+ # config
+ insinto ${CONFIG_DIR}
+ doins etc/*
+
+ # plugins
+ insinto ${PLUGIN_DIR}
+ keepdir ${PLUGIN_DIR}
+
+ use libnotify && doins plugins/notify.xml
+
+ # desktop
+ doicon icons/portato-icon.png
+ domenu portato.desktop
+
+ # nls
+ use nls && domo i18n/mo/*
+}