summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2004-05-13 01:48:32 +0000
committerGeorge Shapovalov <george@gentoo.org>2004-05-13 01:48:32 +0000
commit9739ddf5a14ee5ded14e778e46c6edb95368ac73 (patch)
tree1ac86e92d5634fba1c03bbcd84efbb0293df2ffd /app-sci/blas-atlas
parent Version bump as per bug #49686. Thanks to the current maintainer/author Die... (diff)
downloadgentoo-2-9739ddf5a14ee5ded14e778e46c6edb95368ac73.tar.gz
gentoo-2-9739ddf5a14ee5ded14e778e46c6edb95368ac73.tar.bz2
gentoo-2-9739ddf5a14ee5ded14e778e46c6edb95368ac73.zip
added check for the g77 issue, removed old version
Diffstat (limited to 'app-sci/blas-atlas')
-rw-r--r--app-sci/blas-atlas/ChangeLog8
-rw-r--r--app-sci/blas-atlas/blas-atlas-3.4.2.ebuild119
-rw-r--r--app-sci/blas-atlas/blas-atlas-3.6.0.ebuild17
3 files changed, 21 insertions, 123 deletions
diff --git a/app-sci/blas-atlas/ChangeLog b/app-sci/blas-atlas/ChangeLog
index 1369cf7f92e0..76c8d4a70873 100644
--- a/app-sci/blas-atlas/ChangeLog
+++ b/app-sci/blas-atlas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/blas-atlas
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/blas-atlas/ChangeLog,v 1.4 2004/05/11 05:31:54 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/blas-atlas/ChangeLog,v 1.5 2004/05/13 01:48:32 george Exp $
+
+ 12 May 2004; George Shapovalov <george@gentoo.org> blas-atlas-3.6.0.ebuild :
+ added the fix for g77 issue. Moved atlas3.6.0-shared-libs.patch.bz2 to the mirrors to
+ avoid duplication (the same one is used by lapack-atlas), plus it is 5k in size, which is
+ more than 2k limit :).
+ Removed old version (3.4.2), so that we start aclean when this gets unmasked..
11 May 2004; Danny van Dyk <kugelfang@gentoo.org> blas-atlas-3.6.0.ebuild:
Marked ~amd64 and ~ppc.
diff --git a/app-sci/blas-atlas/blas-atlas-3.4.2.ebuild b/app-sci/blas-atlas/blas-atlas-3.4.2.ebuild
deleted file mode 100644
index d0f2e4e650d6..000000000000
--- a/app-sci/blas-atlas/blas-atlas-3.4.2.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/blas-atlas/blas-atlas-3.4.2.ebuild,v 1.1 2004/02/02 19:09:43 george Exp $
-
-inherit eutils
-
-DESCRIPTION="Automatically Tuned Linear Algebra Software BLAS implementation"
-HOMEPAGE="http://math-atlas.sourceforge.net/"
-MY_PN=${PN/blas-/}
-SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="doc"
-
-DEPEND="app-sci/blas-config
- sys-devel/libtool"
-
-RDEPEND=""
-
-PROVIDE="virtual/blas"
-
-S=${WORKDIR}/ATLAS
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/atlas-gentoo.patch.bz2
- cp ${FILESDIR}/war ${S}
- chmod a+x ${S}/war
-}
-
-atlas_fail() {
- eerror
- eerror "ATLAS auto-config failed."
- eerror "Please run 'interactive=1 emerge atlas-blas' to configure manually."
- eerror
- die "ATLAS auto-config failed."
-}
-
-src_compile() {
- # Libraries will be installed in ${RPATH}/atlas and ${RPATH}/threaded-atlas:
- RPATH="${DESTTREE}/lib/blas"
-
- GCC="gcc"
-
- if [ -n "${interactive}" ]
- then
- echo "${interactive}"
- make config CC="${GCC} -DUSE_LIBTOOL -DINTERACTIVE" || die
- else
- # Use ATLAS defaults for all questions:
- (echo | make config CC="${GCC} -DUSE_LIBTOOL") || atlas_fail
- fi
-
- TMPSTR=$(ls Make.Linux*)
- ATLAS_ARCH=${TMPSTR#'Make.'}
-
- make install arch=${ATLAS_ARCH} || die
-
- make shared-strip arch=${ATLAS_ARCH} RPATH=${RPATH}/atlas || die
-
- # Build shared versions of the threaded libs.
- # ATLAS only compiles threaded libs on multiprocessor machines.
- if [ -d gentoo/libptf77blas.a ]
- then
- make ptshared-strip \
- arch=${ATLAS_ARCH} RPATH=${RPATH}/threaded-atlas || die
- fi
-}
-
-src_install () {
- dodir ${RPATH}/atlas
- cd ${S}/gentoo/libs
- cp -P libatlas* ${D}/${DESTTREE}/lib
- cp -P *blas* ${D}/${RPATH}/atlas #the rest really
-
- insinto ${RPATH}
- doins ${FILESDIR}/c-ATLAS ${FILESDIR}/f77-ATLAS
-
- if [ -d ${S}/gentoo/threaded-libs ]
- then
- dodir ${RPATH}/threaded-atlas
- cd ${S}/gentoo/threaded-libs
- cp -P * ${D}/${RPATH}/threaded-atlas
- doins ${FILESDIR}/c-threaded-ATLAS ${FILESDIR}/f77-threaded-ATLAS
- fi
-
- insinto ${DESTTREE}/include/atlas
- doins ${S}/include/cblas.h
-
- # These headers contain the architecture-specific optimizations determined
- # by ATLAS. The atlas-lapack build is much shorter if they are available,
- # so save them:
- doins ${S}/include/${ATLAS_ARCH}/*.h
-
- #some docs
- cd ${S}
- dodoc README doc/{AtlasCredits.txt,ChangeLog}
- use doc && dodoc doc/*.ps
-}
-
-pkg_postinst() {
- if [ -d ${RPATH}/threaded-atlas ]
- then
- ${DESTTREE}/bin/blas-config threaded-ATLAS
- else
- ${DESTTREE}/bin/blas-config ATLAS
- fi
-
- einfo
- einfo "Fortran users link using -lblas"
- einfo
- einfo "C users compile against the header /usr/include/atlas/cblas.h and"
- einfo "link using -lcblas"
- einfo
-}
diff --git a/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild b/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild
index 42c0dfc20eeb..9a444fcc5ae4 100644
--- a/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild
+++ b/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild,v 1.2 2004/05/11 05:31:54 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild,v 1.3 2004/05/13 01:48:32 george Exp $
inherit eutils
DESCRIPTION="Automatically Tuned Linear Algebra Software BLAS implementation"
HOMEPAGE="http://math-atlas.sourceforge.net/"
MY_PN=${PN/blas-/}
-SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2"
+SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2
+ mirror://gentoo/atlas${PV}-shared-libs.patch.bz2"
LICENSE="BSD"
SLOT="0"
@@ -23,11 +24,21 @@ PROVIDE="virtual/blas"
S=${WORKDIR}/ATLAS
+pkg_setup() {
+ use ifc || if [ -z `which g77` ]; then
+ #if ifc is defined then the dep was already checked
+ eerror "No fortran compiler found on the system!"
+ eerror "Please add g77 to your USE flags and reemerge gcc!"
+ die
+ fi
+}
+
+
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/atlas3.6.0-shared-libs.patch.bz2
+ epatch ${DISTDIR}/atlas3.6.0-shared-libs.patch.bz2
cp ${FILESDIR}/war ${S}
chmod a+x ${S}/war
}