summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-08-07 05:40:36 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-08-07 05:40:36 +0000
commit5194b512cd0c55efd87272c38801ebeb49e7ec2a (patch)
tree82648d183bd0119e3221b802de387ed5ef4b987e /app-sci
parentadded two local flags for app-sci/maxima (diff)
downloadgentoo-2-5194b512cd0c55efd87272c38801ebeb49e7ec2a.tar.gz
gentoo-2-5194b512cd0c55efd87272c38801ebeb49e7ec2a.tar.bz2
gentoo-2-5194b512cd0c55efd87272c38801ebeb49e7ec2a.zip
few expansions to the ebuild
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/maxima/ChangeLog12
-rw-r--r--app-sci/maxima/Manifest6
-rw-r--r--app-sci/maxima/files/digest-maxima-5.9.0-r11
-rw-r--r--app-sci/maxima/maxima-5.9.0-r1.ebuild75
-rw-r--r--app-sci/maxima/maxima-5.9.0.ebuild4
5 files changed, 92 insertions, 6 deletions
diff --git a/app-sci/maxima/ChangeLog b/app-sci/maxima/ChangeLog
index 03ecd7b110ab..19bd29509296 100644
--- a/app-sci/maxima/ChangeLog
+++ b/app-sci/maxima/ChangeLog
@@ -1,8 +1,16 @@
# ChangeLog for app-sci/maxima
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/maxima/ChangeLog,v 1.1 2003/04/19 20:16:51 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/maxima/ChangeLog,v 1.2 2003/08/07 05:40:32 george Exp $
-*maxima-5.9.0.ebuild (19 Apr 2003)
+*maxima-5.9.0-r1 (06 Aug 2003)
+
+ 06 Aug 2003; George Shapovalov <george@gentoo.org> maxima-5.9.0-r1.ebuild :
+ expandedn the ebuild following the #16529.
+ Now has 4 use flags (two of the local) and some emacs and tex related functionality.
+ Can be built with either clisp or cmucl
+ Thanks to Cliff Yapp and Sourav Mandal for suggestions and additions
+
+*maxima-5.9.0 (19 Apr 2003)
19 Apr 2003; George Shapovalov <george@gentoo.org> maxima-5.9.0.ebuild, files/{digest-maxima-5.9.0} :
initial release (#16529)
diff --git a/app-sci/maxima/Manifest b/app-sci/maxima/Manifest
index 4f9baa688126..16027161bf2b 100644
--- a/app-sci/maxima/Manifest
+++ b/app-sci/maxima/Manifest
@@ -1,4 +1,6 @@
-MD5 8064f72064d19c899f7866a8dc83f087 ChangeLog 479
+MD5 6f9754d7fb47c441d90e8f1fc442e834 maxima-5.9.0-r1.ebuild 2146
+MD5 7fb187ece4f8b396b83c055bd268851c ChangeLog 832
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 4cb19d8e1420a88e932f92274c9c3c61 maxima-5.9.0.ebuild 824
+MD5 e12a7f825afe21a3cdb5fea002819fea maxima-5.9.0.ebuild 823
+MD5 aaa91ea4812a84a1054b82e69d3fe05b files/digest-maxima-5.9.0-r1 65
MD5 aaa91ea4812a84a1054b82e69d3fe05b files/digest-maxima-5.9.0 65
diff --git a/app-sci/maxima/files/digest-maxima-5.9.0-r1 b/app-sci/maxima/files/digest-maxima-5.9.0-r1
new file mode 100644
index 000000000000..ca2a7e39dc79
--- /dev/null
+++ b/app-sci/maxima/files/digest-maxima-5.9.0-r1
@@ -0,0 +1 @@
+MD5 a1d6d6ed6afb0eebf03df865c0a19f19 maxima-5.9.0.tar.gz 7116131
diff --git a/app-sci/maxima/maxima-5.9.0-r1.ebuild b/app-sci/maxima/maxima-5.9.0-r1.ebuild
new file mode 100644
index 000000000000..27c41754716e
--- /dev/null
+++ b/app-sci/maxima/maxima-5.9.0-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/maxima/maxima-5.9.0-r1.ebuild,v 1.1 2003/08/07 05:40:32 george Exp $
+
+DESCRIPTION="Free computer algebra environment, based on Macsyma"
+HOMEPAGE="http://maxima.sourceforge.net/"
+SRC_URI="http://dl.sourceforge.net/sourceforge/maxima/maxima-${PV}.tar.gz"
+
+LICENSE="GPL-2 AECA"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE="cmucl tetex emacs auctex"
+
+DEPEND="|| ( cmucl? ( dev-lisp/cmucl-bin ) dev-lisp/clisp )
+ tetex? ( app-text/tetex )
+ emacs? ( app-editors/emacs )
+ auctex? ( app-emacs/auctex )
+ >=sys-apps/texinfo-4.3"
+
+RDEPEND=">=dev-lang/tk-8.3.3"
+
+
+src_compile() {
+ local myconf=""
+ if [ -n "$(use cmucl)" ]; then
+ myconf="${myconf} --enable-cmucl"
+ else
+ myconf="${myconf} --enable-clisp"
+ fi
+
+ ./configure --prefix=/usr ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ if [ -n "`use emacs`" ]
+ then
+ elisp-install ${S}/interfaces/emacs/emaxima *.el *.elc
+ insinto /usr/share/emacs/site-lisp
+ doins ${S}/interfaces/emacs/emaxima/emaxima.lisp
+ fi
+ if [ -n "`use tetex`" ]
+ then
+ insinto /usr/share/texmf/tex/latex/emaxima
+ doins ${S}/interfaces/emacs/emaxima/emaxima.sty
+ fi
+ #move docs to the appropriate place
+ dodoc AUTHORS ChangeLog COPYING COPYING1 NEWS README*
+ mv ${D}/usr/share/${PN}/${PV}/doc/* ${D}/usr/share/doc/${PF}/
+}
+
+pkg_postinst() {
+ if [ -n "`use emacs`" ]
+ then
+ einfo "Running elisp-site-regen...."
+ elisp-site-regen
+ fi
+ if [ -n "`use tetex`" ]
+ then
+ einfo "Running mktexlsr to rebuild ls-R database...."
+ mktexlsr
+ fi
+ if [ -n "`use emacs`" ]
+ then
+ einfo "In order to use Maxima with emacs, add the following to your .emacs file:
+ (setq load-path (cons "/usr/share/maxima/5.9.0/emacs" load-path))
+ (autoload 'maxima-mode "maxima" "Maxima mode" t)
+ (autoload 'maxima "maxima" "Maxima interactive" t)
+ (setq auto-mode-alist (cons '("\\.max" . maxima-mode) auto-mode-alist))
+ (autoload 'emaxima-mode "emaxima" "EMaxima" t)
+ (add-hook 'emaxima-mode-hook 'emaxima-mark-file-as-emaxima)"
+ fi
+}
diff --git a/app-sci/maxima/maxima-5.9.0.ebuild b/app-sci/maxima/maxima-5.9.0.ebuild
index b8a1c798b8c0..e8fb99e68f62 100644
--- a/app-sci/maxima/maxima-5.9.0.ebuild
+++ b/app-sci/maxima/maxima-5.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/maxima/maxima-5.9.0.ebuild,v 1.2 2003/04/19 20:16:51 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/maxima/maxima-5.9.0.ebuild,v 1.3 2003/08/07 05:40:32 george Exp $
DESCRIPTION="Free computer algebra environment, based on Macsyma"
HOMEPAGE="http://maxima.sourceforge.net/"
@@ -8,7 +8,7 @@ SRC_URI="http://dl.sourceforge.net/sourceforge/maxima/maxima-${PV}.tar.gz"
LICENSE="GPL-2 AECA"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ~ppc"
IUSE=""
DEPEND=">=dev-lisp/clisp-2.29